隧道接口上的IOS QOS服务策略直通


10

我在一个网络上有一些SIP电话,它们通过IPIP隧道到达服务器。

我已经设置QOS规则来监视适当的VOIP流量,如下所示:

class-map match-any class-voice
  description Voice
  match  dscp af11
  match  dscp cs4 
  match  dscp cs3 
!
policy-map qos-out
  class class-voice
   priority 100
!
interface Tunnel1
 description Tunnel to VOIP Server
 ip address 10.10.0.2 255.255.255.252
 tunnel source FastEthernet0/1
 tunnel destination 172.16.100.100
 tunnel mode ipip
!
interface FastEthernet0/1
 description Internet
 bandwidth 1000
 ip address dhcp
 service-policy output qos-out

我的麻烦是,由于我无法将策略分配给Tunnel1,而只能分配给FastEthernet0 / 1,因此无法匹配类映射。

当然,必须有一些东西可以使这项工作……我该怎么办?

Answers:


1

我非常怀疑优先级队列是否可以以这种方式应用于隧道接口。QoS功能适用于实际竞争带宽的对象-物理接口。

如果您的隧道仅用于SIP或其他高优先级流量,则可以将其整体匹配并添加到类映射中,如下所示:

ip access-list extended sip-tunnel
 permit ipinip any host 172.16.100.100
!
class-map match-any class-voice
  description Voice
  match  dscp af11
  match  dscp cs4 
  match  dscp cs3
  match  access-group name sip-tunnel
!

UPD:在某些情况下,原始数据包中的DSCP字段被复制到隧道标头。您可以针对您的特定情况(Cisco + IOS + ipinip)检查此选项。成功时,您不需要最后一个匹配,初始配置应该可以正常工作。

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.