Digital Ocean CentOS7服务器,无法--skip-grant-tables或重新启动mysql


9

几天前,我设置了Digital Ocean Droplet(服务器),并且需要访问mysql。在我尝试过的操作中,没有root密码。但是此命令:

service mysql[d] stop

不起作用 显然我应该发出以下命令:

sudo systemctl stop mariadb.service

但这导致

Failed to stop mariadb.service: Unit mariadb.service not loaded.

此外,此命令

mysqld_safe --skip-grant-tables --skip-networking & mysql -u root

结果如下:

sudo: mysqld_safe: command not found
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
[1]+  Exit 1   sudo mysqld_safe --skip-grant-tables --skip-networking

我以root用户身份登录到服务器;我从这里做什么?


首先,您需要记住是否安装了MySQL或MariaDB,或者似乎没有安装。
— 迈克尔·汉普顿

这些命令的输出是什么?'rpm -qa | grep mariadb”和“ rpm -qa | grep mysqld'和'rpm -qa | grep的MySQL的
— 安东尼Fornito

感谢@ AnthonyFornito,mariadb mariadb-5.5.50-1.el7_2.x86_64 mariadb-libs-5.5.50-1.el7_2.x86_64的输出为,而mysql 的输出为-mysqld不php-mysql-5.4.16-36.3.el7_2.x86_64返回任何内容。
— 奥利弗·威廉姆斯

@MichaelHampton-看来我的服务器上都有。
— 奥利弗·威廉姆斯

真?我只在那里看到MariaDB。
— 迈克尔·汉普顿

Answers:


10

尝试

yum remove mysql

然后尝试

service mariadb restart

然后从外面看

service mariadb status

您应该看到它正在运行,然后您早先尝试过的命令应该可以使用

如果

 yum remove mysql

不起作用尝试

 chkconfig mysql off

重新启动并尝试再次启动maria。


第一部分没有成功。我得到了:[root @ centos-8gb-nyc2-01〜]#service mariadb restart-重定向到/ bin / systemctl restart mariadb.service-无法重新启动mariadb.service:单元mariadb.service加载失败:否这样文件或目录。[root @ centos-8gb-nyc2-01〜]#服务mariadb状态重定向到/ bin / systemctl状态mariadb.service●mariadb.service已加载:找不到(原因:没有这样的文件或目录)活动:不活动(死机)
— 奥利弗·威廉姆斯

ckconfig仅导致-bash:命令未找到错误。
— 奥利弗·威廉姆斯

chkconfig <-忘记了h
— Anthony Fornito

重新启动后,尝试使用yum安装mariadb
— Anthony Fornito

chkconfig仅适用于sysv服务systemctl enable。
— user9517 '16
By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.