服务器管理员

系统和网络管理员的问答

3
Exchange中的“交付给”标头
在某些SMTP服务器实现中(即Postfix),您可以启用Delivered-To和X-Original-To标头,这些标头将添加到您的电子邮件中。(或[X-]Envelope-To) 这对于分发列表来确定邮件已重定向到的电子邮件地址非常有用。 因此,当邮件已发送到时distribute@example.com,您可以在Delivered-To或Envelope-To标头中看到它已被重定向(分发)到xy@example.com,这是链接到单个邮箱的许多其他电子邮件地址之一。 如何找到用于将此邮件传递到Microsoft Exchange 2010上特定邮箱的地址? 查看普通邮件(带有所有标题),我找不到邮件通过地址到达的任何信息 xy@example.com 我认为Delivered-To当通过通讯组列表传递邮件时,需要在Microsoft Exchange上设置标头(或类似标头)。 有什么方法可以在Exchange 2010中启用此类标头吗? 我需要它,以便我们的票务系统(OTRS)正确识别票证所在的位置。将所有通讯组列表的所有电子邮件地址添加到系统配置不是正确的解决方案。 并且,如果有针对Exchange 2010的解决方案,这是否也可能适用于Exchange 2007?

4
为什么创建新的TCP连接被视为昂贵?
我不明白为什么创建新的TCP连接被认为是一项昂贵的任务。基本上,建立新连接是指执行TCP的3向握手。因此,这将发送两个数据包,而接收一个。考虑到将会有成千上万的(数据)数据包,握手不能成为昂贵的部分。它可以?
9 networking  tcp 


1
NFS在Debian上的性能下降
我在两台喘不过气的机器之间使用NFS的性能非常不一致,而且似乎无法确定。 设定: 机器1'video1':双5506 w / 12GB内存,8x3TB RAID6上的XFS从'/ mnt / storage'导出为'video1' 机器2'storage1':Phenom X2 @ 3.2Ghtz w / 8GB ram,5x2TB上的ZFS从/ mnt / storage1-storage导出为'storage1' 本地写入性能: mackek2@video1:/mnt/storage/testing$ dd if=/dev/zero of=localwrite10GB bs=5000k count=2000 2000+0 records in 2000+0 records out 10240000000 bytes (10 GB) copied, 16.7657 s, 611 MB/s 本地读取性能: 两者都连接到同一个HP千兆交换机,而iperf两种方式都能提供坚如磐石的940mbps。 我的问题是,当我从storage1写入video1导出时,性能无处不在。似乎对于前几(5-7)个文件传输(我希望尽快移动30-120GB AVCHD或MJPEG文件),性能从900mbps下降到150-180mbps,因此慢到30mbps。如果我重新启动NFS内核服务器,则性能会提高一些。 mackek2@storage1:/mnt/video1/testing$ dd if=/dev/zero …
9 linux  networking  nfs 

4
跨多个交换机的链路绑定?
我已经阅读了一些有关将ifsslave与nics绑定的信息。我无法理解的是,是否需要特殊配置才能将绑定拆分到两个交换机之间。例如,如果我有几台服务器,每个服务器各有两个nic,还有两个单独的交换机,我是否只需配置绑定并将每个nic分别插入1号交换机,将另一个nic插入2号交换机?还是还有更多呢? 如果绑定是活动备份,那么单台计算机上的nic故障会否意味着服务器可能会断开连接,因为其余的计算机都在使用主nic,而在使用辅助nic?还是也用一根电缆链接交换机?

4
打印EC2实例的外部主机名
我可以使用hostname命令获取实例的内部主机名。如何从实例中获取外部主机名? 具体来说,我在EY上并使用ey ssh命令,我想知道主机名是什么,以便将其传递给scp。

3
了解htaccess中的Apache 2.4 mod_proxy_fcgi和RewriteRules
我们最近将其中一台Web服务器切换为apache 2.4,并通过php-fpm和mod_proxy_fcgi运行PHP。大多数事情都运行良好,但是有一个我还不了解的问题。我们的网站之一正在运行WordPress,该网站在其.htaccess文件中提供了大量重写规则。似乎这些与vhost设置中的ProxyPass指令不能很好地配合使用。 我们的虚拟主机包含以下配置: ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.2:9126/<path>/$1 在大多数情况下,这是可行的。 现在,htaccess文件可以执行以下操作: RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^ - [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L] RewriteRule . index.php [L] 由于该站点是子目录中的多博客,因此我读到URL /blogname/wp-admin/load-styles.php?xxxx应该重写为wp-admin / load-styles.php?xxx(第二个重写规则)。但是查看mod_proxy日志,实际上传递的请求是/blogname/wp-admin/load-styles.php。 我读此书是因为存在优先级问题– ProxyPass规则在所有RewriteRules处理完毕之前就触发了。 我受阻-可能是什么原因?


5
为什么Windows Task Scheduler尝试启动多个实例?
我们在群集中的一个Server 2008 Web服务器(非R2)上运行许多Windows计划的任务。 最近,我们从原始的Web服务器群集迁移到了新的Web服务器Cluser(Server 2008-不是R2)。 运行Windows任务的新Web服务器(在群集中)的设置与我们认为的原始Web服务器相同。 但是,我们现在发现,在新的Windows Server上,Windows Task Scheduler似乎想立即启动每个任务3次。 如果我们设置将新任务排队的选项,则会得到: 事件ID 324任务计划程序将任务“ \ Client Reporting”的实例“ {9a1a8411-b042-45ff-8e6b-89874df230d7}”排入队列,并将在实例“ {2bcc3df6-ea3b-4453-90c2-75b8b1946388}”完成后立即启动。 如果我们设置停止现有任务的选项,则会得到: 事件ID 323任务计划程序已停止任务“ \ Client Reporting”的实例“ {e685a910-b32b-414e-85fd-96bbe54314a2}”,以便启动新实例“ {4db66265-1f51-4ede-8535-ac7c3cb5c4c1}”。 勾选的设置: 允许任务按需运行。 错过预定的开始后,请尽快运行任务。 如果运行时间超过1小时,请停止该任务。 如果正在运行的任务没有在请求时结束,则强制将其停止。 仅在计算机使用交流电源时才启动任务。 如果计算机切换为电池电源,请停止任务。 选定的选项:如果任务已经在运行-停止现有实例。 注意:我们将任务从群集中的一台服务器移到了另一台服务器,以查看是否是我们选择的特定服务器上的Task Scheduler引起了问题。相同的行为。 可能与新服务器的构建有关吗? 我们在另一个服务器群集上设置了非常相似的任务,这些任务可以正常运行,而无需多次启动。将这些任务与此处的任务进行比较-通过任务计划程序中的选项,对于我们而言可用的设置似乎没有什么明显不同。 触发器:计划将任务每天一次,每小时一次触发-如果超过此时间则将停止。 操作:运行一个.bat文件。 是什么导致这一点/在哪里我们可以查看一下是什么逻辑导致这种方式多次启动任务?

2
IPv4地址的最后一部分中的数字分布如何均匀?
我在创建的网站上运行重定向脚本。它将1/3的访问者发送到站点A,将1/3的访问者发送到站点B,并将1/3的访问者发送到站点C。 它的工作原理是将用户IPv4地址的最后一部分(0-255)除以3,然后根据其余用户将它们重定向到站点A,B或C。到目前为止,站点A有109位访问者,站点B有85位访问者,站点C有101位访问者。 我是否可以完全完全随机分配IPv4地址的最后一段,这是正确的吗? 另外,最后一段的数字分布是否相等?
9 ip  ip-address 

3
这些奇怪的访问请求是什么?
我在计算机上使用WAMPServer进行测试和开发。我忘记了并把它留在网上几天了,我注意到一堆甚至不是我的IP发出的随机请求。这里有些例子。 77.73.69.127 - - [29/Apr/2012:08:22:20 -0700] "HEAD /manager/html HTTP/1.0" 200 - 58.218.199.250 - - [29/Apr/2012:08:31:54 -0700] "GET http://www.verysurf.com/proxyheader.php HTTP/1.1" 404 213 58.218.199.147 - - [29/Apr/2012:08:35:37 -0700] "GET http://www.travelimgusa.com/ip.php HTTP/1.1" 200 1340 58.218.199.250 - - [29/Apr/2012:10:03:53 -0700] "GET http://61.152.144.145/judge.php HTTP/1.1" 200 1355 58.218.199.227 - - [29/Apr/2012:12:04:07 -0700] "GET http://59.53.91.9/proxy/judge.php HTTP/1.1" 200 …

2
Amazon EC2公共DNS无法正常工作
参考此问题: 如何在Amazon EC2上访问我的公共DNS 如果我根据Windows Web平台防火墙规则配置安全组,那么会有问题吗?因为当我这样做时,我无法在网络浏览器上访问公共DNS。 我的安全组为默认,入站规则为HTTP,RDP,SMTPS,ICMP。 我的实例类型是带有默认安全组的t1.micro webmatrix托管服务器。 我的Windows防火墙对域,公共和专用配置文件均处于活动状态。 我不确定这一点。其HTTP端口80,如我的安全组所示。 我是Amazon EC2的新手,这真的很紧急。

2
Debian / Ubuntu是否可以在删除它们后重新初始化/ var / lib / apt / lists和/ var / apt / cache?
在删除或最小化它们后是否可以恢复/ var / lib / apt / lists和/ var / apt / cache的功能 我试图将Ubuntu VM缩小到最小大小,并决定删除/ var / lib / apt / lists和/ var / cache / apt以便在需要更新系统时还原它们。我已经完成了/ var / cache / apt的操作而没有主要的副作用,只需重新创建一些目录即可重新启用它。/ var / lib / apt / lists是我不确定的一个。是否可以通过像/ var / cache / apt这样重新创建来删除它并恢复其功能? 这样做会破坏apt和dpkg对系统配置的了解还是将其存储在其他地方?
9 ubuntu  debian  apt  cache  var 

1
如何连接流?
我知道cat可以串联文件,但是我需要串联文件和流的混合并将结果通过管道传送到另一个进程。 为了使问题更具体,我想与串联cat abc.sql在一起,gzip -dc xyz.sql.gz并将cat qvf.sql其作为单个流传送到mysql。 实现此目标的最佳方法是什么?
9 shell  pipe  cat 

1
更改CUPS默认打印机错误策略
我在许多多用户Linux应用程序服务器上运行CUPS打印。系统为RHEL或CentOS版本4、5或6。启动EL5时,CUPS打印服务器默认为错误策略,该错误策略在出现错误或中断(USB电缆断开,网络错误,卡纸等)时基本上会禁用打印机。 )。这是文件ErrorPolicy中打印机节中的指令/etc/cups/printers.conf。 <Printer backupZ4> Info backupZ4 DeviceURI socket://backupZ4:9100 State Idle Accepting Yes Shared Yes JobSheets none none QuotaPeriod 0 PageLimit 0 KLimit 0 OpPolicy default ErrorPolicy stop-printer </Printer> 我通常将此字段更改为ErrorPolicy retry-job手动在配置文件中或通过命令行创建打印机时: lpadmin -p backupZ4 -v socket://backupZ4:9100 -o printer-error-policy=retry-job -E 当其他用户或供应商管理打印系统时,他们通常会忘记此更改,这会导致在出现卡纸或其他需要用来纠正错误的情况下使打印机硬禁用cupsenable。 我想知道如何retry-job在CUPS与中创建默认的ErrorPolicy stop-printer。

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.