服务器管理员

系统和网络管理员的问答

4
如何为CentOS 6配置24 x 1.2 TB驱动器的RAID 5,尤其是条带大小?
对于具有24个1.2TB磁盘(和1TB RAM)的Dell R920,我希望为快速IO设置RAID 5配置。该服务器将用于托管KVM VM,该KVM VM将读取/写入各种大小的文件,包括非常大的文件。我对数据安全性并不特别感兴趣,因为如果服务器由于任何原因发生故障,我们将在更换发生故障的部件后从裸机重新配置服务器。 因此,性能是主要问题。 我们之所以考虑使用RAID 5,是因为它允许我们在多个主轴上分配数据,因此可以提供更好的性能,尽管不是我们的主要关注点,但是它也可以为我们提供一些数据保护。我们的NIC是双10Gbps。 我将这个问题限制为RAID 5仅是因为我们认为这将提供最佳性能。只有当有令人信服的性能原因时,我们才会考虑其他因素。但是,我想我更喜欢与RAID 5配置有关的答案。 好的,根据以上所述,这是我们当前的配置思想: 24个硬盘:RMCP3:1.2TB,10K,2.5“ 6Gbps RAID控制器:H730P,12Gbps SAS支持,2GB NV缓存 1个热备用(如果驱动器确实发生故障,只是为了给我们更长的使用寿命) 23个数据驱动器(其中1个作为奇偶校验,剩余22个用于数据) 条带大小:1MB(1MB / 22个数据驱动器=每个磁盘〜46.5KB,或者,我是否误解了条带大小)? 读取策略:自适应预读 写策略:写回 磁盘缓存策略:已启用 如果数据驱动器上的条带大小为TOTAL,那么我认为每个驱动器〜46.5KB将为我们提供非常好的吞吐量。如果条带大小是每个主轴的,那么我就错了。 条带大小是否也占用单个文件的大小?例如,如果有一个2KB的文件,那么选择1MB的条带大小是否意味着我们要浪费几乎整个兆字节?还是一个条带中可以存在多个文件? 最后,当我们安装CentOS 6.5(或最新版本)时,是否需要做一些特别的事情来确保文件系统最佳地使用RAID?例如,mkfs.ext4具有-E跨度选项,我被告知应对应于RAID配置。但是,在安装CentOS期间,有什么方法可以做到这一点? 非常感谢您为快速IO配置RAID 5的想法。

1
如何获得Visual Studio在线负载测试代理使用的IP地址范围?
我需要在需要运行一些Visual Studio Online负载测试的环境中设置IP白名单。我能够找到有关Visual Studio Online所谓IP地址使用什么的一些文档,但是它似乎并不准确。 根据常见问题解答(http://www.visualstudio.com/get-starte/load-testing-faq-vs),Visual Studio联机负载测试在Azure US East数据中心中运行。根据Microsoft Azure数据中心IP范围(http://www.microsoft.com/en-us/download/details.aspx?id=41653)文档,我能够确定将哪些IP地址列入Azure美国东部白名单数据中心。 不幸的是,当我们在这些IP地址的出局环境中设置IP白名单时,Visual Studio在线负载测试会错误运行。我们能够暂时取消IP白名单限制,并且所有测试都成功运行,因此可以确定,肯定是IP白名单而不是负载测试设置存在问题。 有谁知道一种确定Visual Studio在线负载测试代理使用的IP地址的确定方法?此外,Visual Studio Online是否有可能在美国东部以外的任何其他数据中心中运行?

5
热备用主机与冷备用主机?
我们有几个主机,其中有一个相同的热备用主机,该主机已打补丁和更新,因此非常接近具有相同的软件和配置。发生故障时,将切换网络电缆,并使用新的MAC地址更新DHCP服务器。这是最好的情况,因为通常还需要修改一些内容。 我觉得拥有一个热备用主机会浪费电力,而且浪费时间来维护它,并且由于在发生故障转移时需要修改配置,因此我想提出以下问题: 热备用主机是否已过时,现在有更好的方法? 与其拥有一个热备用主机,不如将其变成一个冷备用,取下硬盘驱动器并将其放入主主机,并将RAID从1更改为1 + 1。万一发生故障,我所要做的就是更换网络电缆,更新DHCP服务器,取出硬盘驱动器并将它们插入冷备用中并打开电源。如我所见,这样做的好处是2x2磁盘始终保持同步,因此故障转移时仅需维护一台主机,无需更改配置。 这是一个好主意吗?

3
如何从PowerShell中的所有网站列出IIS中的虚拟目录
我遇到了一个完整的障碍,无法弄清楚如何为中的每个网站打印虚拟目录IIS 8。我一直在检索应用程序,并清空null参数错误,只是找不到一种方法来列出虚拟目录。 我需要以下数据来列出有关虚拟目录的信息: 物理路径 应用程序池协会 网站名称 证书 以下是我一直在使用并弄乱的代码: *See revised code below* 我还使用了Appcmd.exe命令来尝试列出虚拟目录: C:\Windows\System32\inetsrv\appcmd.exe LIST VDIRS 但是我仍然没有得到我需要的输出。任何东西或任何帮助将不胜感激!谢谢! 编辑# - - - - - - - - - - - - - - - - - - - - - - - - ---------------------- 通过注释两行让我的虚拟目录列出来,但它只打印出名称和: 物理路径 应用程序池协会 网站名称 证书 我仍然不知道,下面是修改后的代码: Import-Module …

2
运行Hyper-V的Windows Server 2012上的DNS解析
问题显示如下: Ping主机名<-主机回答,看来解析是通过netbios完成的 nslookup主机名<- UnKnown未找到主机名:服务器未响应。 现在来了有趣的部分。在很短的时间内,该解决方案就会起作用。也可能是一个登录到服务器的用户可以解析主机名,而另一个不能同时解析。 设定: 我有一个加入域的Windows Server 2012,该服务器安装了Hyper-V角色。服务器有4个物理网络接口,其中#1和#2被Hyper-V用作虚拟交换机,并且未配置任何IP地址。 网络接口#3和#4通过我们的DHCP服务器(这是此Hyper-V主机上的VM)获得了IPv4地址。虚拟交换机#1通过DHCP获得了一个静态IP地址,而#2获得了它的地址。 我有2个DNS服务器。两者的Nslookup结果相同。第二台DNS服务器在另一台服务器的另一台Hyper-V主机上。每个网络接口都有配置的主要和辅助DNS服务器,如ipconfig /all命令所示。 作为附加信息:该解决方案似乎在除此客户端之外的所有其他客户端/服务器上均能正常工作。 有问题的服务器上的事件日志: Hyper-V-VMMS-事件ID:32022:复制由于复制伙伴的名称解析而无法进行。 DNS客户端事件-事件ID:8015:DNS服务器上的DNS注册不起作用,超时。 主DNS服务器上的事件日志: DNS服务器服务:事件ID:4015:DNS服务器识别出严重的ActiveDirectory错误。确保AD正常运行。错误调试信息为空的“”。 广告日志未显示任何错误。 辅助DNS服务器最近未显示任何错误。 我不知道服务器重启是否有帮助,但这是我最后要做的事情,因为VM正在此服务器上运行。 故障排除: 我在每个网络接口上禁用了IPv6。 我查看了网络流量,并查找了DNS数据包。DNS服务器未从该服务器收到任何信息。 从出现此问题的服务器的网络接口看,似乎它甚至没有向dns服务器发送任何请求。 我试图禁用和启用网络接口。 由于dns解析不起作用,各种其他诊断工具(例如dcdiag)不起作用。有什么想法吗?

1
域名服务器间接访问有正式限制吗?
如果域及其名称服务器不共享TLD,则胶水记录通常不可用,并且如果它们不共享相同的二级域,则从技术上讲也不需要胶水记录,这可能导致解析域的额外步骤。解析程序必须先查找名称服务器的地址,然后才能找到您的域的地址。但是从理论上讲,您可以在其中添加更多步骤,而不仅仅是这两个步骤。 这里的问题是,该链条可以保留多长时间? if xyz.com使用nameserver ns1.xyz.info, 并xyz.info使用nameserver ns1.xyz.co, 并xyz.co使用nameserver ns1.xyz.cc, 并xyz.cc使用nameserver ns1.xyz.co.uk,...依此类推 ...您可能最终需要很长的链来让解析程序解开,才能解析您最初想要的名称。 大概有一个实际的限制-BIND应该只愿意遍历这么多的链接,否则就有可能遭到拒绝服务。但是有官方限制吗?某些步骤是否正式不需要解析器进行?

4
使用代理和远程桌面网关连接到远程桌面吗?
我已经使用Windows Server 2012 R2设置了远程桌面网关服务器。我使用远程桌面网关作为中介,通过443提供远程桌面会话,因为3389在许多客户端位置都被阻止。 但是,我遇到了一个客户端的问题,该客户端的网络似乎正在使用Web代理。 是否可以将远程桌面配置为通过Web代理连接?如果是这样,怎么办?如果没有,那么在您无法控制客户端的PC或网络的情况下,没有人对如何通过443通过代理提供远程桌面会话有任何建议吗?使用RD网关时,RemoteApps是否允许通过Web代理访问? 错误消息如下: 您的计算机无法连接到远程计算机,因为Web代理服务器需要身份验证。若要允许未经身份验证的流量通过Web代理服务器到达RD网关服务器,请与网络管理员联系。 谢谢你的帮助!

3
完全限定域名的定义
想要改善这篇文章吗?提供此问题的详细答案,包括引文和为什么答案正确的解释。答案不够详细的答案可能会被编辑或删除。 我试图在Internet上搜索FQDN的定义。维基百科说,FQDN 指定它在域名系统(DNS)的树层次结构中的确切位置,这是我可以解释的,因为它可以明确解析(在DNS中)。 WP中的示例(我不想将其用作参考)说明了 hostname.example.com. 我发现的RFC(RFC 1035是我发现的唯一的非协议专用协议)对FQDN的资格没有提供任何信息。 我以为只有像hostname.example.com这样的标识符才是有效的FQDN(包括所有单独的主机名,域和TLD),但这似乎是错误的。 即使域仅由一个主机组成,FQDN是否也需要在域旁边始终包含主机名?还是FQDN应该可以通过DNS解析的唯一定义?例如,域名.tk明确可解析,这是FQDN吗?

1
有关停产的生产软件(OpenDS)的良好做法?
使用未积极维护且在2010年进行了最后一次修补且在生产环境中需要JDK6(也已过时)的OpenDS有多糟糕? )。 如果已经存在,通常是否值得花费时间和金钱来寻找替代品,运行集成测试等?对于生产中通常使用的过时软件,采取此步骤的通用标准是什么?
8 ldap  java  opends 

2
在Nginx配置中使用尾部斜杠
location /product { proxy_pass http://10.0.0.25:8080; } 如果我使用产品文件夹的第一个位置描述,则应该使用http://mysdomain.com/product/,但不能http://mysdomain.com/product在浏览器中使用 。我的意思是我应该使用url的斜杠结尾。我想以两个状态访问产品文件夹。 之间有什么区别: location /product/ { proxy_pass http://10.0.0.25:8080; }
8 nginx  proxy 

3
我应该让电子邮件退回还是发送至黑洞?
我的机器上有许多未使用的(旧的,已死的)帐户。他们中的许多人每天实际上收到成千上万封垃圾邮件。 如果该帐户被某人使用,我会让电子邮件退回,以便任何尝试与他们联系的人都知道出了点问题。但是,我不确定该如何处理用于其他目的的数百个帐户,例如曾经用于询问我的电子邮件地址的网站的一次性帐户,或者曾经在网页上列出的地址。 选项1:将 所有邮件转发到这些帐户/dev/null。发件人未收到退信。 选项2: 让电子邮件退回。 向其发送电子邮件的好处/dev/null是,垃圾邮件发送者无法使用我来生成退回邮件(反向散布垃圾邮件)。即:伪造“发件人”行成为他们不喜欢的人,然后用我向该人发送大量退回邮件。 弹跳它们的好处是对我来说,维护较少。我可以从别名文件中删除该项目,电子邮件将被退回。另外,我一直在发现新的垃圾邮件陷阱并将其添加到“垃圾邮件黑洞”列表中,这是浪费时间。 每种方法的优缺点是什么?


1
如何生成用于制作快照的IAM策略?
我已将要安装快照的EC2实例上安装了卷。 我使用以下策略创建了一个新的IAM用户: { "Statement": [ { "Sid": "...", "Effect": "Allow", "Action": [ "ec2:CreateSnapshot", "ec2:CreateTags", "ec2:DeleteSnapshot", "ec2:DescribeAvailabilityZones", "ec2:DescribeSnapshots", "ec2:DescribeTags", "ec2:DescribeVolumeAttribute", "ec2:DescribeVolumeStatus", "ec2:DescribeVolumes" ], "Resource": [ "arn:aws:ec2:eu-west-1:MY_USER_ID" ] } ] } 我已将访问密钥和秘密添加到我的文件中~/.bashrc并获得了它。当我运行时ec2-describe-snapshots,得到以下响应:Client.UnauthorizedOperation: You are not authorized to perform this operation. 当我"Resource"还是"*"我的时候,我能够列出所有类型的亚马逊快照。我希望创建该eu-west-1区域中我自己拥有/可见的快照。

3
中止连接(读取通信数据包时出错)
mysql error.log显示 [Warning] Aborted connection 320935 to db: '...' user: '...' host: '...' (Got an error reading communication packets) 客户端得到的是: Lost connection to MySQL server at 'reading initial communication packet', system error: 111 Lost connection to MySQL server at 'reading authorization packet', system error: 0 and after a while: Host …
8 mysql 

2
ec2实例中的非常高的网络输出
两天前,我在Amazon EC2中启动了ubuntu-14.04-64bit实例。然后,我在该实例中启动了Tomcat 7.0.54,并部署了应用程序war文件。除了tomcat和默认软件外,它没有安装其他软件。在过去2天中,该实例显示了该实例的858 GB数据传输(网络输出)。我已附上Amazon CloudWatch指标“网络输出”的图形 我的应用程序不执行任何数据下载/上传。它是一个Java Spring应用程序,前端在HTML&Javascript中。在那两天内,我的应用程序流量非常低(少于20次点击)。 有没有办法找出为什么会发生这些数据传输以及是否已传输了哪些数据。如果您在图中可以看到,网络输出为每分钟20GB。 更多信息:网络进入微不足道CPU利用率很高

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.