服务器管理员

系统和网络管理员的问答

2
内核:恩。NMI在CPU 3上以未知原因31收到
我在“ Linux Debian-70-wheezy-64-minimum 3.2.0-4-amd64#1 SMP Debian 3.2.46-1 + deb7u1 x86_64”上收到此错误: Message from syslogd@hostname at Feb 14 02:54:51 ... kernel:[81927.464687] Uhhuh. NMI received for unknown reason 31 on CPU 3. Message from syslogd@hostname at Feb 14 02:54:51 ... kernel:[81927.464743] Do you have a strange power saving mode enabled? Message from syslogd@hostname …
8 debian  kernel 

1
HyperV内部交换机的身份不明的网络
我正在尝试为Windows Server 2012主机上的来宾OS设置HyperV内部交换机。通过虚拟交换机管理器创建新的内部交换机后,可以在“网络连接”下看到虚拟适配器。但是,它被列为“身份不明的网络”。 主机系统仅插入一个已配置了静态IP的NIC。想法是通过Internet连接共享与内部交换机共享Internet。 我能够在Windows Server 2012的另一个盒子上执行相同的操作,而没有任何问题。 请参阅所附的屏幕截图。带有1的后缀来自不起作用的新系统,带有2的后缀来自起作用的旧系统。 请注意,在第一种情况下,但在第二种情况下,内部交换机是如何出现在网络下的。#2服务器已添加了活动目录角色,但我认为这不是(缺少)原因。 网络1 网络2 适配器1 转接器2 ipconfig 1 ipconfig 2

3
在同一服务器上运行websocket服务器和http服务器
我正在使用nginx来提供PHP应用程序的实例,并且同时运行Ratchet应用程序来侦听WebSocket连接。问题是,这两个实例都使用相同的端口(80)。 如何设置服务器,以便同时为我和她提供服务? 编辑:只是回头看到这个问题已经被否决了几次,可以理解的是,我并没有以明确的方式提出这个问题。我对此表示歉意。我确实做了尽职调查。我会尝试澄清我的要求,我可能会误解了websocket协议的某些方面,在这种情况下,请纠正我: 我很清楚,只有一个进程在侦听一个特定的端口,实际上我遇到的问题是整个websocket的事情,据我了解,websocket请求始于HTTP握手,此后便有了机制将该会话“升级”到特定端口。 据我了解,这种升级机制似乎是由Web服务器处理的。那么,如何配置nginx来处理此过程? 总而言之,我担心在80以外的端口上运行websocket服务器的一件事是端口被阻塞的可能性。这种担心是没有根据的吗?关于我应该如何设置的任何建议?

6
试图了解在CentOS中创建静态路由的正确方法,请提供帮助
我一直在尝试了解在CentOS 6.x机器上添加静态路由的正确方法是什么。在某些论坛中,他们说route-dev_name使用相关路由创建一个名为(例如route-eth0)的文件并将其放置在中/etc/sysconfig/network-scripts,在某些论坛中,他们说该文件应命名为static-routes,在两种情况下我都无法设置静态路由。似乎在某些CentOS版本中,它仅在命名文件时起作用,而在某些版本中,仅在命名文件route-dev_name时起作用static-routes..有人可以帮我吗?这是我的路线文件的内容: 192.168.20.0/24 via 192.168.20.253 dev eth0 提前致谢

2
从进程表中删除僵尸进程
我有一个令人讨厌的僵尸进程,它被init采纳,并且不会消失。我读过一种方法,可以创建一个虚拟进程,将僵尸作为该新进程的子进程附加,然后将其杀死,然后将其从进程表中删除。 确切地说,我该怎么办? 是的,我已经阅读了其中大部分内容: 僵尸进程已经死亡,因此无法杀死。 要么 您应该重新启动系统 和 僵尸进程不使用任何资源,您应该让它们成为 不幸的是,许多程序检查进程表以查看实例是否已在运行,并且如果进程表中有一项,则将拒绝启动新实例。 每当我的SSHFS连接断开时重新启动,并带上Sublime,都是很愚蠢的。
8 linux  process  kill  zombie 

2
Nginx + php-fpm-每个php-fpm在运行时处理70-100%cpu
我遇到以下情况: 我们使用8核,8gb ram,2.6 GHz频率的linode-使用nginx + php-fpm-我们获得了非常高的cpu使用情况图(我们不想成为如此糟糕的VPS邻居)... 我们一次在网站上的用户数少于100,因此这种情况也令人难以置信,这是因为我们的CPU使用率很高。 我们使用的是一个非常未知的,可能是cpu密集的php方式的,可疑的,可怕的框架,而不是众所周知的,文档完善,精心设计的其他框架,如wordpress或drupal,其中有很多关于缓存的文档(以及插件)处理缓存)在nginx + php_fpm平台上的php。 因此,我们有大约6个开放的php-fpm进程,它们在运行时分别消耗大量(30+,通常接近99%)的cpu-我丝毫不知道如何阻止他们使用太多的cpu 。我不知道是哪个PHP脚本导致了这些峰值,因为它们一直在发生……通常只有1或2个正在运行-但是当所有6个脚本运行时,我们会最大化所有8个cpus。 我的pool.d / www.conf文件具有以下设置: pm = dynamic pm.max_children = 10 pm.start_servers = 4 pm.min_spare_servers = 2 pm.max_spare_servers = 6 我们进行此^设置是因为,按照我的解释方式,我们的内存实际上是惊人的(htop显示使用了472/7000 + mb,没有交换等),并且我们可以处理更多的进程并中断等待获得的行已处理-但不幸的是,由于每个进程在运行时对我们的cpu来说过于繁琐-我们最终将CPU驱动通过屋顶-因此我们无法处理足够的进程。 问题 -我们到底该怎么做才能减少进程php-fpm cpu的使用,以便我们可以增加该pool conf文件中php-fpm的设置 -而且是的,/ var / log / php5- fpm.log大喊大叫我们要增加孩子并调整/增加最小/最大/启动服务器。但是,这样做会使我们的平均负载达到疯狂,如前所述。我们如何在不必使用缓存的情况下做到这一点或我们有哪些选择? 我的点子?我已经阅读了有关使用cpulimit的信息,以确保没有任何进程花费超过分配的cpu数量-但这会使速度变慢以致无法使用吗?或者这样做,我们可以提高运行多个流程的能力-我还认为可以运行两个池-一个池用于我们的前向网站(客户体验),另一个用于后端(这在一定时间影响我们的前向站点) -正在运行消耗性报告)。 我已经花了几天的时间在这个主题上进行研究,搜索等等,但是这很困难,因为每个人的情况对于他们的系统来说都是如此独特-问题在于这样一个特定的,闻所未闻的,可能写得不好的框架-很难找到解决方案。我们也不能只废弃此框架-我必须找到某种解决方案。 更新:我已经实现了memcache来存储php会话-因为该框架严重依赖于用户会话,并且我们系统的性质是员工经常一次使用多个选项卡-每个选项卡都返回到会话以确认功能/用户数据等...因此,我希望由此带来的效果有所提高-如果您愿意,欢迎对此发表评论-我将在明天达到更高的高峰时段时看看情况如何。

3
木偶:尝试配置木偶客户端以供首次使用,但证书出现问题
我正在尝试配置客户端“ Itai-test”以从称为“ puppetmaster”的人偶服务器接收人偶设置。 在我运行的服务器上: [root@puppetmaster requests]# puppet cert --generate itai-test.domain Error: A Certificate already exists for itai-test.domain [root@puppetmaster requests]# puppet cert --sign itai-test.domain Error: Could not find certificate request for itai-test.domain [root@puppetmaster requests]# 在the客户端上,我运行了: [root@itai-test temp]# puppet agent --server puppetmaster.domain --waitforcert 60 --test Notice: Did not receive certificate Notice: Did …

1
PowerShell DSC组资源-“找不到具有提供的名称的主体”
我正在尝试使用PowerShell DSC将域组添加到本地管理员组。这是代码: Configuration TestSetup { Node localhost { Group Administrators { GroupName = "Administrators" MembersToInclude = "MYDOMAIN\TheAdministratorsGroup" } } } 运行它会导致以下错误: PowerShell provider MSFT_GroupResource failed to execute Test-TargetResource functionality with error message: Could not find a principal with the provided name [mydomain\theadministratorsgroup] + CategoryInfo : InvalidOperation: (:) [], CimException + …

3
是否可以使用Puppet来确保目录中存在多个文件而不定义所有文件?
我有数百个一次性服务器,这些服务器具有需要在目录中显示的不同配置文件。这些文件的副本位于木偶母版上。 在我的一个类中,我有一组默认配置,这些配置总是推送到节点,如下所示: file { "/etc/someprogram/config/000-default": ensure => "present", owner => "root", group => "root", mode => 0764, source => "puppet:///modules/someprogram/000-default", } 我想要的是这样的: $filearray = directory listing of /etc/puppet/modules/someprogram/files/$fqdn with each file as an element into array $filearray.each( file { "/etc/someprogram/config/$filename": ensure => "present", owner => "root", group => "root", mode …

2
2012R2存储空间内存和CPU要求
我正在研究可能使用Server 2012R2中的存储空间来构建NAS。我希望在类似安装程序的“ RAID10”中构建一个相当大的单元(12-14个HDD)(我知道存储空间不支持RAID10,但也类似),并带有用于缓存的SSD。 而且我希望将来再将另一个外部JBOD机箱挂在上面,以获得类似“ RAID5-6”的设置。 我不打算进行解压缩或重复数据删除。 我的问题是,我想要哪种硬件?小型Xeon或Opteron能够处理吗?还是应该为更大的2.4GHZ + Xeon 4核HT或12核Opteron拍摄,甚至要使用双CPU?为了达到最佳性能,系统需要多少内存?我一直在从Microsoft搜索有关Storage Spaces设置的硬件指南,但是我一直找不到任何东西,因此,如果有人知道某些内容,请向我指出正确的方向。 我当时正在考虑使用FreeNAS或其他基于Linux的替代产品来设置这些单元,但是我所在部门的大多数IT专业人员几乎没有Linux经验,并且如果遇到总线问题,他们会选择基于Windows的解决方案,可能。同样,任何人都知道FreeNAS或其他Linux NAS替代产品VS的性能比较。Windows Server 2012R2存储空间?

1
建立Strongswan VPN,但未路由数据包
我正在使用StrongSwan在Amazon EC2实例上的Linux实例和通过其Cisco集中器的远程网络之间建立VPN。我需要将来自Linux实例本身的数据包路由到远程子网中的计算机。 建立连接正常,但没有路由任何数据包。 我认为我需要设置一些特定的路由规则,该怎么做呢? 软件 Linux内核3.5.0-41, Ubuntu 12.10, strongSwan 5.1.1(从源代码构建), iptables-没有规则。 网络 本地 亚马逊弹性IP:56.xxx 面向公众的LAN IP:172.xxx 本地虚拟子网:10.254.0.0/16 本地虚拟IP:10.254.5.174 远程 思科集中器的公共IP:62.xxx 远程子网:10.192.0.0/12 组态 ipsec.conf config setup conn %default keyexchange = ikev1 type = tunnel ikelifetime = 86400 keylife = 28800 keyingtries = %forever esp = 3des-sha ike = 3des-md5-modp1024 forceencaps = …

2
将Docker容器公开到VPC网络
我有一个使用一个容器运行docker的ubuntu服务器。我的vpc中的服务器IP地址是172.31.12.29/20。它具有两个拖桥(docker0 ans lxcbr0)。 我的容器ip地址是172.17.0.2/16。 主机和容器可以ping通自己。 我的vpc中有另一台服务器,其IP地址为172.31.1.233/20。我只想从该服务器访问我的容器,但是我不知道该怎么做。 我的两个服务器可以ping通自己。 我尝试通过将vpc路由表配置为将172.17.0.0/16目标请求路由到172.31.12.29来执行此操作,但是它不起作用。 任何的想法 ?


1
Windows Server 2012分辨率与VGA无关
我有两个Windows虚拟机,Windows Server 2012和Windows Server2008。两者都使用kvm和libvirt。我最近决定要增加屏幕分辨率选项,这需要从默认的“ cirrus”视频卡更改为“ vga”选项。这对于Windows Server 2008 VM来说就像是一种魅力,为我提供了从800x600到2560x1600的多种分辨率选项。但是,这不适用于Windows Server 2012。 这是我的xml模板中与视频卡有关的代码: <video> <model type='vga' vram='9216' heads='1'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/> </video> 我怀疑这是驱动程序问题。我试图弄清楚哪些驱动程序将与KVM的模拟VGA卡兼容,但我发现该卡仅是“带有Bochs VESA扩展的虚拟VGA卡”,并且在搜索中加上“驱动程序”后发现没有任何用处。 在我的Windows 2008 vm中,该驱动程序是一个“标准VGA图形适配器”,它看起来像是Windows的通用驱动程序,它会解释为什么我不需要下载任何新程序就可以使该vga卡在Windows 2008上正常工作。但是,在Windows 2012中该驱动程序只是显示为“ Microsoft Basic显示适配器”,尝试更新驱动程序会在Windows中显示,告诉我一切都是最新的。在此驱动程序下,我只能得到1024x768的分辨率,这甚至比使用cirrus卡(至少达到1280x1024)时的分辨率还要差。 基于此问题,我理解VGA卡的不良行为是由于基本显示适配器的非常基本的功能导致的: 卡在低分辨率上:Windows Server 2012中未识别监视器和显示适配器 据我所知,我需要两件事之一。A)更好的驱动程序,它将为虚拟卡提供更好的分辨率支持。B)具有更高功能的新虚拟卡(KVM可以这样做吗?) 最后一种可能性是C)http://support.microsoft.com/kb/2855505暗示这可能是因为我的GPU不支持Directx9,但我不知道如何进行检查。 任何帮助将不胜感激。


By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.