服务器管理员

系统和网络管理员的问答

1
将中继直接发送到HyperV 2012中的vm
我在HyperV 2012中将OpenBSD设置为VM。对我来说,仅在vm上创建一个接口并让OpenBSD负责设置VLAN会更容易。 是否可以告诉HyperV将所有流量发送到端口(无论是否已标记)? 如果我取消选中“启用虚拟LAN标识”,则似乎HyperV仅向该端口发送未标记的流量。
8 hyper-v  vlan  openbsd 

1
具有RemoteDesktopUsers而不具有“通过远程桌面服务登录”特权的感觉是什么?[关闭]
已关闭。这个问题是基于观点的。它当前不接受答案。 想改善这个问题吗?更新问题,以便通过编辑此帖子以事实和引用的形式回答。 6年前关闭。 最近,Microsoft更改了 Windows Azure Guest OS(Windows 2008,Windows 2008 R2和Windows 2012)中的默认策略。更改之一是现在只有Administrators组成员具有“允许通过远程桌面服务登录”,而组成员RemoteDesktopUsers不再具有特权。 现在有什么意义呢?RemoteDesktopUsers是旨在允许通过远程桌面登录的组,如果撤消了此特权,则该组毫无意义。 具有RemoteDesktopUsers而不具有“通过远程桌面服务登录”特权的感觉是什么?

5
将重复数据删除的文件复制到新的Server 2012驱动器上的最佳方法是什么?
Windows Server 2012计算机上的重复数据删除卷已接近极限。这是一个具有约10TB重复数据的1.3TB驱动器。我们希望将所有这些数据复制到更大的4TB驱动器上。 什么是执行此复制的最佳方法,以使我们仅复制1.3TB的重复数据删除数据,而不是解压缩整个10TB的数据并在另一端重新打包? 编辑:我尝试了标准的资源管理器文件副本和一个Copy-Item,但似乎都没有dedup意识。我也没有完成任何任务,所以我不能肯定地说这种情况。

2
传入文件的轮询
一堆具有唯一文件名的新文件通常会在一个服务器上“出现” 1。(与每天数百GB的新数据一样,解决方案应可扩展到TB。每个文件的大小为几兆字节,最大为几十兆字节。) 有几台计算机处理这些文件。(数十种,解决方案应可扩展到数百种。)应该可以轻松地添加和删​​除新机器。 有些备份文件存储服务器上必须复制每个传入文件以进行归档存储。数据不得丢失,所有传入文件都必须最终交付到备份存储服务器上。 每个传入文件都将被传送到一台计算机上进行处理,并且应将其复制到备份存储服务器。 接收方服务器在发送文件后无需存储文件。 请提供一种可靠的解决方案,以上述方式分发文件。解决方案不得基于Java。最好使用Unix-way解决方案。 服务器基于Ubuntu,位于同一数据中心。所有其他内容均可根据解决方案要求进行调整。 1 请注意,我故意省略了有关文件传输到文件系统的方式的信息。原因是如今,文件是由第三方通过几种不同的传统方式发送的(足够奇怪的是,通过scp和ØMQ)。在文件系统级别削减跨集群接口似乎更容易,但是如果一个或另一种解决方案实际上需要某些特定的传输,则可以将旧式传输升级为该传输。

3
了解RedHat推荐的调整配置文件
我们将在约1000台服务器上推出已调优(和numad)的服务器,其中大多数是NetApp或3Par存储上的VMware服务器。 根据RedHats文档,我们应该选择virtual-guest配置文件。它的作用可以在这里看到:tuned.conf 我们正在将IO调度程序更改为NOOP,因为VMware和NetApp / 3Par都应该为我们做足够的调度。 但是,经过一番调查后,我不确定它们为什么会增加vm.dirty_ratio和kernel.sched_min_granularity_ns。 据我所知,vm.dirty_ratio增加到40%意味着对于内存为20GB的服务器,除非先vm.dirty_writeback_centisecs被击中,否则在任何给定的时间8GB都可能是脏的。在刷新这8GB的空间时,该应用程序的所有IO都将被阻止,直到释放脏页为止。 由于现在我们拥有更大的缓存,增加dirty_ratio可能意味着在峰值时具有更高的写入性能,但是当缓存填满IO时,将再次阻塞更长的时间(几秒钟)。 另一个是为什么他们增加了sched_min_granularity_ns。如果我理解正确,则增加该值将减少每个epoch(sched_latency_ns)的时间片数量,这意味着正在运行的任务将有更多时间来完成其工作。我可以理解这对于线程很少的应用程序来说是一件好事,但是对于例如。apache或其他线程很多的进程会不会适得其反?

3
让清漆从高速缓存中获取旧数据时发送新数据吗?
我正在缓存动态生成的页面(PHP-FPM,NGINX),并在它们前面涂上清漆,效果很好。 但是,一旦达到缓存超时,我将看到: 新客户请求页面 清漆识别缓存超时 客户等待 清漆从后端获取新页面 varnish将新页面交付给客户端(并且还缓存了页面,用于下一个立即获取它的下一个请求) 我想做的是: 客户要求页面 清漆识别超时 清漆将旧页交付给客户 清漆从后端获取新页面并将其放入缓存 以我为例,过时的信息不是一个大问题,尤其是当我们谈论几分钟后的缓存超时时,这并不是一个好地方。 但是,我不想惩罚用户排队等待,而是立即交付东西。有可能吗? 为了说明这一点,这是对配置为缓存一分钟的服务器运行围攻5分钟的示例输出: HTTP/1.1,200, 1.97, 12710,/,1,2013-06-24 00:21:06 ... HTTP/1.1,200, 1.88, 12710,/,1,2013-06-24 00:21:20 ... HTTP/1.1,200, 1.93, 12710,/,1,2013-06-24 00:22:08 ... HTTP/1.1,200, 1.89, 12710,/,1,2013-06-24 00:22:22 ... HTTP/1.1,200, 1.94, 12710,/,1,2013-06-24 00:23:10 ... HTTP/1.1,200, 1.91, 12709,/,1,2013-06-24 00:23:23 ... HTTP/1.1,200, 1.93, 12710,/,1,2013-06-24 00:24:12 ... …


2
没有APT推荐与p
我使用puppet管理一堆Debian服务器,其中包括安装软件包。我在多个系统上安装的一个软件包是nmap,用于验证防火墙规则是否正确设置。在Debian 7.0上,如果启用了APT :: Install-Recommends,那么您会得到一堆废话以及nmap(请参见下文)。 我不希望安装所有包含建议启用nmap的废话。一种解决方案是使用来更新我的apt配置APT::Install-Recommends "0";。但我不想将其设置为默认值。我想推荐的大多数时间都包括在内。推荐的软件包大部分都很好,而且我没有得到很多我不需要的东西。但是有一些软件包带来了我不想要/不需要的东西。 package { 'nmap': ensure => installed, require => Class['apt'], } 使用“ apt”软件包提供程序时,是否有任何方法可以控制是否通过p安装了推荐内容? 我不想弄混aptitude提供商,因为apt和aptitude并不完全兼容。 有推荐 root@fw-01:~# apt-get install nmap Reading package lists... Done Building dependency tree Reading state information... Done ... The following NEW packages will be installed: fonts-droid fonts-liberation ghostscript gnuplot gnuplot-nox groff gsfonts …
8 debian  puppet  apt 

4
Active Directory身份验证负载平衡和故障转移
对于针对Active Directory DC进行身份验证的应用程序,显然最好将它们指向主域DNS记录,而不是将特定DC用于故障转移,负载平衡等。 那些迫使您对DC的IP进行硬编码的应用程序的最佳实践是什么?我们可以对负载均衡器的IP地址进行硬编码,因此,如果一个DC断开,该应用程序仍将能够进行身份验证。有更好的选择吗?

1
如何停止Nginx监听端口80?
我希望nginx停止监听端口80。我只发现有bug的人,但没有关于故意这样做的文档。我不能禁用它,我也阅读: #listen 80; ## listen for ipv4; this line is default and implied 英语不是我的母语,但我理解“暗示”意味着不需要声明,因此即使在注释中,服务器仍会收听80。如何禁用此功能?谢谢。
8 nginx  http 

3
允许的Linux密码字符列表
不幸的是,我从事Linux管理已有很短的时间了,但我仍然不知道在哪里可以找到Linux密码允许使用的字符的完整列表。我的猜测是,这可能是因为根据配置不同,不同系统上的配置可能会有所不同,例如:passwd文件与Open LDAP。使用authz / passwd / shadow文件时,是否有允许的Linux凭据的完整列表?
8 linux  password 

3
在服务器上运行的Wireshark看到许多具有不同告诉的“ ARP谁拥有”
我们看到了一些可疑的网络活动,当我尝试查看它是否是我们服务器中的一台特定服务器时,我运行了Wireshark跟踪。我注意到有很多 ARP数据包在询问who has x.x.x.x,但都被告知告诉不同的地址。在过去,我只看到“ tell”是单个主机-例如DHCP服务器。 从屏幕截图中可以看到,仅要求提供几个IP,但是要告知的系统却相差很大。就像网络上的所有设备都在试图找出谁10.10.0.40(以及其他几个)一样。

2
在没有交换机的情况下通过10Base-T以太网连接两个设备
我正在尝试连接两台设备,其中一台仅能达到10Mbps,并且不支持自动协商。(另一个是黑匣子,虽然可以以10 / 100Mbps的速度连接到我的PC,但我不确定如何确定它是否支持自动协商) 我可以使用开关连接这些设备,它们的通话非常愉快。但是,如果我将设备直接相互连接,则似乎没有数据包穿过该链接。我尝试了四根电缆,一条直通电缆,一条交叉电缆,交换了TX +和TX-电缆的一条直通电缆以及一条交换了TX +和TX-电缆的交叉电缆。我已经尝试了后两种电缆。(以防万一在任何一个设备中都将引脚3和6交换了,我读到这对于使用极化传输的10M可能是个问题)。 如果我将NIC限制为10M并要求它不要自动协商,则可以从PC连接到任一设备。 交换机还可以做些其他事情来使此连接正常工作吗?我还可以尝试在这些设备之间连接电缆吗?


1
为什么Nginx的proxy_intercept_errors指令需要重写才能正常工作?
以下是Nginx服务器配置示例。没有“魔术符”位置块,代理的错误内容将导致Nginx 404页面,而不是提供自定义的错误页面。 删除proxy_intercept_errors指令可为带有正确的http错误代码标头的正确的代理错误页面提供服务。 不管魔术护身符的存在如何,都能正确呈现非代理错误页面。 关于到底发生了什么的任何想法? server { server_name mydomain.com ""; listen 80; root /var/www; error_page 400 401 402 403 404 500 501 502 503 504 /admin/error_page.htm; proxy_intercept_errors on; location /proxy/ { proxy_read_timeout 60s; proxy_set_header Host $host; proxy_pass http://myservers; } location /test404/ { return 404; } location /admin/ { # this …

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.