服务器管理员

系统和网络管理员的问答

3
LDAP / ActiveDirectory BindDN语法
我正在对客户端的基于Linux的硬件防火墙进行故障排除。此硬件防火墙连接到ActiveDirectory以进行单点登录身份验证。 就我所知,ActiveDirectory只是largley的一个变态版本,并且使用相同的BindDN语法-如果我错了,请纠正我。 客户端已将其配置为它们的BindDN-出于隐私原因已替换了实际的字符串,但保留了特殊字符和空格。“ somerandomplace \ fubar fubaz” 对我来说,这似乎不是有效的BindDN语法,并且我以前使用过LDAP,但是当我们单击“测试”按钮来测试此BindDN时,测试成功。当我仅更改BindDN中的一个字符并再次运行测试时,测试将失败。 我正在尝试找出问题所在: A)我不完全了解BindND和相关语法的细微差别 要么 B)设备未正确验证输入,并且错误地将测试标识为成功

3
在RHEL6上使用新的rsyslog模板语法时出错
我正在将rsyslog配置从旧服务器迁移到新服务器,并认为我会借此机会整理一下我们的配置。旧的配置使用了“旧版”模板定义,并且模板上的rsyslog文档建议用新的模板语法替换这些定义,因此这就是我尝试做的事情。 我根本无法使它正常工作,并且尝试启动rsyslog时遇到的错误没有任何意义。因此,似乎我从根本上误解了rsyslog文档,或者RHEL6中包含的rsyslog软件包有些有趣。 这是我要更新的旧模板: $template secureTemplate,"INSERT INTO var_log_secure (received_at, source_ip, source_hostname, logged_at, severity, service, message, severity_int, syslogtag) VALUES ('%timegenerated:::date-rfc3339%', '%fromhost-ip%', '%hostname%', '%timereported:::date-rfc3339%', '%syslogseverity-text%', '%programname%', '%msg%', '%syslogseverity%', '%syslogtag%')",STDSQL 这是我阅读rsyslog文档后使用新语法尝试的同一模板: template(name="secureTemplate" type="string" option.stdsql="on" string="INSERT INTO var_log_secure (received_at, source_ip, source_hostname, logged_at, severity, service, message, severity_int, syslogtag) values ('%timegenerated:::date-rfc3339%', '%fromhost-ip%', '%hostname%', '%timereported:::date-rfc3339%', '%syslogseverity-text%', '%programname%', '%msg%', …
8 rhel6  rsyslog 

2
Virtualbox:通过流浪汉启动时如何连接到显示器?
我已经使用过流浪汉来设置ubuntu 12.10。我实际上如何连接到图形桌面?Virtualbox管理器似乎没有办法。它显示预览,但“显示”图标已禁用。 这有点麻烦,但我可以暂停无业游民,然后使用VirtualBox管理器启动VM,并将其连接到显示器。我宁愿不必这样做,因为它可能会弄乱NFS共享/ IP地址等。

1
共享已挂载的CIF驱动器时,目录显示为文件
我有一个问题,当从Windows计算机访问samba共享(在Ubuntu 12.10上)时,目录显示为文件。 linuxbox文件夹中ls -ll的输出如下: chubby@chubby:/media/blackhole/_Arkiv$ ls -ll total 0 drwxrwxrwx 0 jv users 0 Jun 18 2012 _20 drwxrwxrwx 0 jv users 0 Apr 17 2012 _2006 drwxrwxrwx 0 jv users 0 Apr 17 2012 _2007 drwxrwxrwx 0 jv users 0 May 12 2011 _2008 drwxrwxrwx 0 jv users 0 …
8 samba  cifs 

1
linux-vserver中的Apache无法启动,无法创建套接字
在广泛的研究和测试中,我写了一个值得进行stackexchange的问题,我找到了一个解决方案:libapr1在guest虚拟机内部重建软件包。我以为仍然会发布此信息,因为它可能对其他人有用。 问题 当我libapache2-mod-php5在Wheezy guest虚拟机内安装并尝试启动时,得到以下信息: root@test01:~# /usr/sbin/apache2ctl start [crit] (22)Invalid argument: alloc_listener: failed to get a socket for (null) Syntax error on line 9 of /etc/apache2/ports.conf: Listen setup failed Action 'start' failed. The Apache error log may have more information. root@test01:~# tail /var/log/apache2/error.log root@test01:~# root@test01:~# head -n 9 /etc/apache2/ports.conf|tail -n 1 …

2
未拔出网络电缆Windows ARGH
好的,这让我很疯狂。 服务器将一直处于“未插拔”网络状态,直到重新启动为止。这似乎是随机发生的(凌晨2点,10pm,8:30 am、3pm等),它每24-48小时左右执行一次。环境是具有6个工作站和1个大型Sharp打印机的小型企业。 赢得2008 SBS 64位 没有可以链接到的计划任务。 带有双Broadcom BCM5708C NIC的Dell Poweredge 2900(仅使用一个) 每个Dell网站上的驱动程序都是最新的 电缆已插入。 电缆已更换两次。 该服务器连接的整个交换机已被替换。 该路由器最近已更换。 对于每个实例,我都注意到它崩溃了,因此在事件日志中找不到任何关联。 已关闭自动协商并尝试了几种设置。 从未使用过的NIC已与另一个交换为现用状态(相同的IP和所有内容),然后第一个被禁用。 我确实看到路由器中列出了一些LAN RX错误(大约3%的错误似乎不是源自服务器,但我不能完全排除这种情况)。 我刚刚安装了Wireshark,并将其设置为捕获并保存到日志文件。 Winsock和IP重置,它们什么也不做。

1
Ubuntu服务器:硬盘始终充满
我有一个50GB的VPS 当我运行df时,我得到 Filesystem 1K-blocks Used Available Use% Mounted on /dev/sda1 49982172 46580100 863064 99% / none 507212 172 507040 1% /dev none 511676 4 511672 1% /dev/shm none 511676 76 511600 1% /var/run none 511676 0 511676 0% /var/lock none 511676 0 511676 0% /lib/init/rw 当我从/运行du -h时 ... 20K ./tmp/vmware-root …
8 ubuntu  du  df 

3
如何使Centos保持6.3版?
我有以下几点: 一群运行Centos 6.3的来宾VM 主机运行Centos 6.3。 最近,我创建了一个新的Centos 6.3 VM来进行测试 然yum update一新后安装一个最小服务器 注意到Centos现在是6.4 我想保持版本不变,因为我了解未经测试的更改具有引入不稳定性的能力(我正在学习服务器admin / Centos,以便可以开发自己的应用程序来自动化各种“需求”,其中之一就是下载数据,另一种是对下载的数据进行分析,而另一项需求是基于分析执行某些操作。 我在Dev的阶段Dev -> Test -> Prod就实施我在做什么,所以运行时间和稳定性不是“必要”在这个阶段,但是,我想确保我已经做了所有我所能,确保了当时间到了一定的Prod环境时,-时间/稳定性将是坚实的。因此,我想让来宾和主机的KM保持运行6.3,直到我决定有必要进行升级和/或提供重大利益为止。 几个问题: 执行时如何防止自动升级到服务器OS的版本yum update? 互联网上是否存在“标准”位置,用于查找版本升级中发生的更改? 我是否对服务器版本在稳定性方面的变化感到偏执?
8 centos  yum  stability 

1
“ setspn -s”与“ setspn -a”
根据Setspn概述,不建议使用它Setspn -A来添加SPN记录,建议改为使用它Setspn -S。 据说Setspn -S在添加新SPN之前先检查SPN是否已经存在。Setspn –A不执行此检查。 尽管可以使用Setspn -A添加SPN,但应改用Setspn -S,因为-S将验证没有重复的SPN。 但是,在Windows Server 2012上,我看到了Setspn -S并Setspn -A以相同的方式进行操作:如果存在帐户的SPN记录,则使用-A和-S参数都会失败。 是否有任何之间真正的区别Setspn -S和Setspn -A?


4
Debian-端口80被阻止,但我不知道是什么
我无法让lighttpd监听端口80。 ~# /etc/init.d/lighttpd start Starting web server: lighttpd2013-03-16 23:15:02: (network.c.379) can't bind to port: 80 Address already in use failed! 实际上,我也已经在服务器上安装了apache2(侦听端口80),但是它不是活动的。 我使用了netstat / netstat -npl,但是没有帮助 我如何找出正在使用的端口?
8 debian  port  analysis 

2
BIND9上的二进制区域文件
DNS主区域文件已传输到从设备,但我无法读取该区域文件: > less db.example.com "db.example.com "may be a binary file. See it anyway? 这是在我使用以下命令后发生的: cp -r /usr/local/sbin/* /usr/sbin/. 我安装了绑定V.9.9而不是V.9.6。我希望能够以纯文本格式读取区域文件。

6
使用OU中的用户在Active Directory中创建动态组
我想与来自Active Directory中特定OU的用户创建一个动态组。我可以使用Exchange动态分发列表完美地做到这一点,但是,当然,Ex DDL仅用于邮件。 有什么办法可以创建这个吗?我找到了一些使用System Center来处理此问题的指南,但是System Center不是一个选择。 提前致谢,

3
无法在Ubuntu 12.04上安装Gearman
我正在尝试通过以下命令在我的Ubuntu 12.04计算机上安装Gearman sudo apt-get install gearman-job-server libgearman-dev sudo apt-get install php-pear php5-dev 以上命令正常运行,但是当我运行时 sudo pecl install gearman 它给出如下错误 checking whether to enable gearman support... yes, shared found in /usr checking for gearman_client_set_context in -lgearman... yes checking for gearman_worker_set_server_option in -lgearman... yes checking for gearman_job_error in -lgearman... no configure: error: libgearman …

3
如何使用Powershell在Exchange数据库中获取2年以上的电子邮件列表,并按用户排序?
我们目前正在考虑将电子邮件存档并修订我们的保留政策。最大的问题是(对于法律部门),我们要保存多久?当前,我们的用户有一个很大的邮箱限制,并且过去所有用户都可以按照自己的意愿进行存档。因此,我们有数百GB的数据不在Exchange数据库中,但最终可能会被吸入Archive数据库进行发现。我想做的是能够为法律团队量化如果我们退回1年,2年,3年等将会得到多少。 我在TheDailyAdmin上找到了一个相当简单的Powershell脚本,该脚本可以满足我的大部分需求,但是却将所有内容都融合在一起。我希望能够看到结果,但根据用户进行了排序,以了解Sally拥有2年以上的47MB内存,Charles拥有超过2年的190MB内存,依此类推。 这是我运行的脚本: get-mailboxdatabase | get-mailbox -resultsize unlimited | get-mailboxfolderstatistics -folderscope all -includeoldestandnewestitems | export-csv mailbox_stats.csv 将它们全部记录在文件中效果很好,但我无法确定谁的电子邮件属于谁。我还专门在我的邮箱上运行了它,但是我宁愿不要在每个用户上手动运行它,因为这可能需要一段时间!我不是Powershell专家,但我希望那里的人能更坚定地掌握,并可以帮助我指出正确的命令方向,以帮助我进一步分解。 提前致谢!

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.