服务器管理员

系统和网络管理员的问答

1
Tridion 2009 SP1将HTML片段DCP发布到文件存储
在客户的SDL Tridion 2009 SP1实现中,我希望将一些DCP作为HTML片段发布到文件存储中。这是因为当前的实现在文件存储上使用ASCX组件,我们需要用HTML片段作为输出来替换此功能。 从《 2009 SP1内容交付实施手册》中可以看出,在cd_broker_conf.xml文件的“发布-> Dcp配置”节点中只能使用4种配置设置。这些是: Jsp 天冬氨酸 Xml 文本文件 是否可以在文件存储中存储DCP HTML片段,如果可以,应选择哪个配置设置? 我知道我可以将它们存储为.txt文件,但我更希望它们为.html文件。
8 tridion 

2
Grub2报告物理卷pv0不再在服务器上不可启动
我首先使用lvm 安装了我的ubuntu服务器(11.10 amd64),但没有完全掌握它的概念。我认为部分原因是造成两个磁盘上的分区混乱(对我而言)。我从一开始就使用grub2安装了所有东西,以启动我的Ubuntu,后来我将其更新为Ubuntu Server 12.04,没问题。 情况如下: 到目前为止,我根本无法启动,在grub选项之前似乎没有任何发展(编辑:来自Pavel A.的precision); 我可以使用服务器安装liveCD进行启动,并带有选项Rescue a broken system; 我设置了网络访问权限,但似乎没有/run文件夹(不知道它是否相关,但在某些论坛中似乎不正常); 我构建的设备映射如下: VGA包含sda1[Linux分区] sda2,sda3[ /]和sda5(后者似乎相同sda3,相同的描述符) VGb包含sdc1,sdc2[ /boot]和sdc3[ /home] (两者没有相同的PE或LE,但我希望最终将所有内容都放在同一个VG中) 我对引导环境所做的最后一件事是(干净地)从引导分区中删除较旧的内核(236MB大,已满99%)。 我跑了grub-install(挂载启动后),但出现了各种错误: 无法安装,/dev/sda因为core.img不合适(第一个分区开始于32) 的输出grub-install上/dev/sdc表现出error physical volume pv0 not found 我什至尝试grub-install直接转到/dev/sda5,显然没有错误,但是在启动时也没有成功 我在这里查看了[serverfault]:在探测/安装时Grub2报告未找到物理卷pv0 我在这里查看了[Ubuntu论坛]: 求助] 用liveCD安装内核并修复了grub2我在这里查看了[Ubuntu帮助]:修复了一个损坏的系统 我在这里查看了[ubuntu论坛]:[已解决] 10.10 Maverick-Grub无法识别我的Windows分区 我所做的一切都没有改变卡住启动的情况(我无法对其进行更好的定义:它只是挂了几分钟,几分钟又几分钟)。 我希望我没有遗漏任何重要的细节。 我不知道该怎么办了,特别是如果无法安装grub。我没有丢失任何数据,但是由于它是一台生产(-ish)服务器(即完全是个人服务器),所以我现在强烈感觉需要镜像(我已经设置了备份,但是...在服务器:p上)。 无论如何,如果你们中的任何一个天才都有想法或领导力,那将是很大的帮助。 谢谢 瓦伦丁 编辑:不tail /var/log/syslog产生任何输出(空白),没有创建新的系统日志,我可以看到 Edit2:我使用了引导修复CD(Ubuntu Secure Remix版本),并生成了有关引导状态的以下报告:http : …

2
15分钟后,借记/贷记小键盘终端将从网络断开。发生一个错误后重新连接
我们拥有一个惠普采购网络和大约20个标准的借记/贷记小键盘终端机,如今,每个人几乎都在每个商店都看到它。它们直接连接到LAN,仅与SSL / 443上的支付站点进行通信。中间没有软件或服务器。 问题在于设备通常在首次尝试使用时会给出TCP连接失败。然后,他们将可以正常工作一个小时。但是,如果被允许闲置10-15分钟(大约),他们将抛出一次初始错误。 最初,他们都是来自同一家公司,我们认为这与他们的设置或品牌/型号有关。但是最近,我们使用不同类型的Pinpad从完全不同的供应商处安装了一些新设备……它们具有相同的错误。 我们已经尝试了静态IP地址和DHCP IP地址。我们已将外部付款站点添加到特殊的防火墙规则中,该规则使他们无需进行常规威胁检查即可退出。我们已经在各种Vlan上尝试过它们。我们已经尝试将它们连接到各种类型的区域开关。甚至尝试了一个计划的批处理文件,每3分钟对其执行一次ping操作(自制)。没有任何区别。在网络问题方面,所有设备都与其附近的现金计算机/打印机连接到完全相同的VLAN和区域交换机-我们在其他方面没有任何问题。现金系统运行完整的客户端/服务器/数据库应用程序,并且如果由于该区域的网络连接不良而导致它们出现同样的矛盾问题,我们会很快听到的。 我要解决的最新理论与arp缓存超时有关,但是我才刚刚开始。 希望能得到一些帮助。也欢迎疯狂的想法。 W.

3
短期专用VM的技术
我正在尝试构建一个将运行软件组件的短期(CI和测试版本)的系统,根据我的要求,每个组件都必须驻留在专用主机上,这是强制性的。我正在将该定义也包括半虚拟化选项,因为这似乎会让我头疼。 我在Mac上工作,所以几乎每种技术都失效了,libvirt和quemu等等对我都不起作用。但是我正在计划部署到Debian。因此,只要我可以编写主机及其来宾域的配置脚本,就可以将在Debian上运行的所有内容放回桌面上。 我想要的设置是,我可以用来引导Debian安装程序,这意味着在启动时,机器会自动进行预配置(Chef,Puppet,Babushka,不要介意),并且该预配置的一部分应该构建一个可用于引导容器的模板rootfs。还需要提供容器本身,以便在容器出现时知道要执行的工作,可以执行该工作,然后退出。 简而言之,这是我需要的工作流程: 启动计算机(虚拟或其他),并准备好进行工作。 该工作应由Chef / puppet / babushka / etc安装的脚本执行 进行工作时,应启动虚拟机进行工作。 VM应该完成工作,退出并将其资源释放给父/主机。(重要的是,在合理的硬件上,它至少可以扩展到数百个来宾VM) 我已经尝试过以下内容,并出于以下原因放弃了它们: 对于主机 带有Instalinux(支持LinuxCOE)的预种子Debian微型ISO映像(不好: 根本没有用(“未找到内核模块”(因为Instalinux映像与FTP存储库不同步,显然该解决方案非常脆弱,它也没有太大的余地安装空间,并且无法将已知的SSH密钥,主机密钥等放置到计算机上,这简直是火如虹,最终我会拥有一台正在运行的计算机,但无法访问它) 种子前Debian netinst ISO(不好:与上述问题相同,但至少安装通常会完成,因为ISO和FTP存储库之间没有内核差异。安装后的范围仍然有限。 良好:绝对可靠且可重复,易于在Mac或裸机上的任何VM技术堆栈上使用,可以在任何地方使用,但是我无法对其进行足够的后期安装) 各种构建rootfs并将其编译为可启动硬盘映像的方法(不好:我所能做的工作很少,就像地狱一样,很难安装到真实的机器上,而且构建过程很复杂。 良好: 如果我可以使它工作,这似乎为使用ssh密钥,主机密钥,主机名,从Git安装的软件以及其他任何东西将机器预配置为给定规格提供了最大的范围,但是问题是如何打包进行分发,或编写脚本来娱乐。) 老实说,我不确定人们应该使用什么技术将虚拟机从无到有,带到正在运行,运行和有用的系统中。在我看来,这就像三个步骤:a)操作系统,b)系统配置(用户等),然后c)文件系统更改。 对于来宾(虚拟)计算机: 很多事情,大多数情况下,我认为答案是用创建的只读rootfs debootstrap和LXC容器上的特殊分区,其中包含为此特定实例(作业清单)要完成的工作。插入所有有关构建操作系统,引导,创建用户,从git中签出软件以及进行工作的一般警告。 我真的不确定要使用什么工具,看来问题应该得到很好解决。但是我只是找不到真正开始的地方。 多数人似乎建议主机,我应该选择一种虚拟化技术,将计算机引导至工作状态,然后对其进行快照(libvirt似乎是逻辑上的最爱)。使用快照启动任何后续安装以进行测试或投入生产。 对于来宾计算机,lxc似乎提供了最简单的选项,除了在现有的所有内核中中断容器的后台运行并稍后通过控制台连接到该容器之外,稳定的Debian可用的最新版本的lxc已有18个月以上的历史了。 ,并且缺少许多广泛使用的功能。 通常,我是一名应用程序开发人员,并且我不经常使用服务器级技术(并且我确信SF会将这个问题标记为“过于主观”),但是我确实不确定要使用哪些工具。 最后一句话是,我知道一个类似的堆叠项目(travis-ci.org)正在为此使用Vagrant框。这似乎是一种比较钝的工具,它是大型,慢速,面向红宝石的工具,专门用于对用于关键服务基础架构的测试VM进行小型桌面配置,但我也知道其中一些人,他们比我聪明,所以也许他们只是放弃了。 任何帮助表示赞赏。


2
Tridion 2011 SP1 OData Web服务
遵循安装指南并解压缩webservice.zip之后,复制JDBC驱动程序和配置XML,当我尝试在浏览器中进行访问时,我看到: {"error":"invalid_grant"} 有点挖掘表明这与OAuth有关。有任何想法吗?
8 tridion 

2
/ dev / shm和/ proc强化
我曾经提到过保护/ dev / shm和/ proc的安全,我想知道您如何做到这一点以及它的作用是什么?我认为这涉及对/etc/sysctl.conf的某种编辑。 像这些? kernel.exec-shield = 1 kernel.randomize_va_space = 1

2
使用DeepFreeze在计算机实验室中处理Firefox更新的最有效方法?
我很快将接管我工作所在大学的所有学生计算机实验室计算机上的软件管理职责。Firefox更新往往被证明特别令人讨厌,因为它在每个用户更新后首次启动时都会在其中提供一个包含有关更新信息的选项卡,并且通常在顶部也带有各种通知栏(例如“您要向我们发送匿名使用信息吗。 。”)。由于计算机位于DeepFreeze上,并且由于学生在整个学期中经常使用许多不同的计算机,因此Firefox在每次有人启动时都有效地首次启动。 我知道一种解决方案是登录,打开Firefox,然后将我登录时使用的配置文件复制到默认配置文件模板,但是鉴于每个实验室的配置不同,尤其是考虑到我至少要处理四个不同的操作系统/版本(当前为Windows XP和7,OS X 10.6和10.7),我必须在每个实验中为每个更新重复此过程。有没有一种更快的方法,这样我可以为学生提供最新的软件,而无需他们每次启动时都关闭一堆小屏幕? 当我在讨论主题时(如果需要,我可以将其分解为一个单独的问题),有人在类似环境中有很好的方式处理扩展吗?一些部门具有所需的特定扩展名,并且通常确实需要更新扩展名,特别是为了确保与较新版本的Firefox兼容。
8 firefox 

2
使用NameVirtualHosts并重定向到www时,应如何配置ELB运行状况检查?
我的ELB继续使我的实例停止服务,因为HTTP运行状况检查失败。 我们有一个DNS通配符,并将所有内容重定向到www: vhost.conf: ServerName www.example.com ServerAlias *.example.com RewriteEngine on RewriteCond %{HTTP_HOST} !^www\.example\.com$ [NC] RewriteRule ^ http://www.example.com/$1 [R=301,L] 对于实际的浏览器来说,这可以正常工作,但是对/的HTTP运行状况检查失败,大概是因为它收到302。 是使用TCP运行状况检查的最佳选择,还是有办法使HTTP正常工作?

2
squid代理会覆盖我的主机头,我该怎么办?
我的鱿鱼有以下问题: 一些客户端通过鱿鱼代理同时访问62台服务器。所有服务器均具有相同的主机名(www.example.com),但具有不同的公用IP(123.123.123.2至123.123.123.63)。服务器所有者使用一种DNS轮询。 我只能访问鱿鱼服务器和客户端。仅通过代理IP允许与服务器的连接。 没有代理,我只是发送一个请求以从http // 123.123.123.5 / dataforme加载数据,但是我发送了主机头“ www.example.com”。那像应该的那样工作。 但是现在将squid用作非缓存代理已不再可行。Squid覆盖已发送的请求主机标头。这样,目标服务器不知道要传送什么数据,因为主机头没有正确传输。 我设置 url_rewrite_host_header off 但这没有任何作用。似乎仅在将鱿鱼用作重定向器时才使用此选项。那不是我要做的。 如果没有其他要提取的站点,则以下内容将起作用: header_access Host deny all header_replace Host www.example.com 但是,当我这样做时,每个请求都将获得www.example.com主机标头。这样就无法再访问其他站点。 我能做什么? 在此先感谢您的帮助!
8 squid 

2
httpd_read_user_content和httpd_enable_homedirs有什么区别?
SELinux的apache模块具有两个类似的布尔参数:httpd_read_user_content和httpd_enable_homedirs。 手册页说,前者允许httpd读取用户内容,而后者允许httpd读取主目录。 它们之间有什么区别? 如果要允许httpd读取/home/foo目录中的文件,应将哪个参数设置为true ?

2
10GBASE-T屏蔽电缆交换机到服务器的连接
我第一次尝试进入10吉比特(铜线)领域。同样,我以前从未使用过CAT-5 / 6屏蔽电缆。通过我自己的研究,我了解到长距离网络电缆(例如,配线架和办公室墙壁插座之间)的屏蔽类型和好处。 对于屏蔽跳线(<15英尺)的使用,我不太清楚,尤其是当电缆直接从服务器连接到交换机且交换机之间没有跳线面板时(即没有将电缆接地)。当我购买几台Dell PowerConnect 8164交换机,将它们安装在服务器机架的顶部(面向背面),并在服务器中安装Intel X540-T2 NIC时,将是这种情况。 这是我要弄清楚的: 与常规的Cat-6绞线跳线相比,使用Cat-6A有什么好处? 使用屏蔽(例如S / FTP)电缆是否有任何好处?我知道这与EMI和其他一些环境因素有关,但是我无法测量。 将屏蔽电缆直接从服务器连接到交换机时,一侧或两侧都必须支持一些其他电气要求吗? 谢谢!

2
清漆用尽开放端口,大量SYN_SENT连接
最近,我们的Varnish(3x)-> Apache(3x)设置遇到了问题,导致SYN_SENT连接数量激增。 高峰本身是由于到达站点的新流量(不是任何类型的DDOS)造成的,并且似乎我们的Varnish机器在将流量转发到后端服务器时遇到问题(Apache流量下降与清漆的峰值相关),从而使可用端口池拥塞SYN_SENT。 在Apache(15s)上启用了保持活动状态。 故障在哪一边?流量很大,但绝不会导致此类设置(3台Varnish前端计算机,3台后端Apache服务器)停顿。 请帮忙。 通过防火墙的Munin屏幕截图在这里。 漆 ~$ netstat -an|awk '/tcp/ {print $6}'|sort|uniq -c 9 CLOSE_WAIT 12 CLOSING 718 ESTABLISHED 39 FIN_WAIT1 1714 FIN_WAIT2 76 LAST_ACK 12 LISTEN 256 SYN_RECV 6124 TIME_WAIT /etc/sysctl.conf(消失) net.ipv4.netfilter.ip_conntrack_max = 262144 net.ipv4.netfilter.ip_conntrack_tcp_timeout_syn_recv = 60 net.ipv4.ip_local_port_range = 1024 65536 net.core.rmem_max = 16777216 net.core.wmem_max = 16777216 …


1
文件夹权限,用户对象上的红色x
在文件服务器的共享文件夹上,对于“安全性”选项卡下的域用户名对象,该图标带有红色的x。 没有症状,用户具有完全访问权限,其名称图标上只有一个红色的x。 为什么是这样? 为了澄清起见,登录Windows 2008 R2文件服务器,浏览到用户共享文件夹,右键单击该文件夹,单击属性,然后单击安全性选项卡。代表用户域名的对象在图标的右下角带有一个小的红色x,看起来像一个人。除了我,没有其他症状想知道为什么红色x在那里。 更新:当您查看工作站的权限时,它仅在文件服务器上不显示x

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.