服务器管理员

系统和网络管理员的问答

3
是否可以将FreeNAS作为Auth Server(SMB或LDAP),文件服务器以及Ubuntu作为“ Client”(Kerberos auth-pam)?
当然,我想将FreeNAS服务器配置为身份验证服务器(用户FreeNAS本地用户要身份验证到ubuntu客户端)和NAS服务器。我有Ubuntu作为客户端,它们通过DHCP / PXE引导,因此我可以快速配置它们。 我将在上面发布一个进程列表,[OK]表示该进程正在运行,[TODO],您知道... 结构过程: [确定]客户请求提供IP ... [OK]我的防火墙答案是文件名“ pxelinuz.0”和我的FreeNAS的IP,该人提供TFTP,NFS和SMB。 [确定]客户端加载vmlinuz和initrd.lz,然后根据需要从NFS开始加载squashfs。 [ TODO ]我的FreeNAS应该通过SMB为LDAP或Active Directory DC提供服务,但是我不知道FreeNAS是否可以实现(我的问题之一)... [ TODO ]客户端必须通过FreeNAS的NFS或SMB挂载/ home。 [ TODO ]客户端应连接到FreeNAS并获取用户列表,以便他们可以登录。 我的目标是创建一个网络,在该网络中,我可以插入不同的计算机,并允许用户在需要时使用其个人计算机登录,访问其“主”文件,而始终无需在硬盘驱动器上更改操作系统。 PS:我可以轻松编辑squashf,我已经为此编写了脚本。

2
简单的Windows + Linux服务器配置?厨师/人偶/ Ansible等[关闭]
按照目前的情况,这个问题不适合我们的问答形式。我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意调查或扩展讨论。如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 7年前关闭。 我主要是一名开发人员,兼职开发人员;并在这里和那里管理我的项目的服务器。 我想自动为我的项目配置Web /应用程序/数据库服务器 我同时管理Windows和Linux服务器(VPS,云服务器和专用服务器) 我已经简要地研究了调查过的厨师/木偶/ Ansible;我想找到一些东西: 很容易学习和理解。我不想花数周的时间来理解一项复杂的技术。 理想情况下,不需要服务器(“主服务器”)来保存配置 支持Windows和Linux服务器的配置 随附适当的文档以开始 是否有人对哪种工具最合适有任何建议? 谢谢
8 puppet  chef 

1
如何在不使用vconfig命令的情况下添加VLAN?[关闭]
按照目前的情况,这个问题不适合我们的问答形式。我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意调查或扩展讨论。如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 7年前关闭。 有什么方法可以在不使用vconfig的情况下创建vlan接口?我只有KVM控制台和中继端口连接到计算机,所以我无法使用apt,因为我无法访问互联网。我在/ etc / network / interfaces中定义了VLAN,但是由于没有创建VLAN接口,所以它不起作用。谢谢。
8 linux  debian  vlan 

5
如何自动化滑流?
多年以来,我一直使用整合式Windows安装。这很好用,但准备工作却很繁琐: 1-使用我们拥有的最新集成版本安装Windows(自动安装) 2-检查Windowsupdate以查看新增功能,并记下 3-下载每个可用的新更新 4-转到第2步,直到没有新的更新可用为止5-将它们整合到我们拥有的最新版本中(我已经使这一步骤自动化了) 我想要一种使部分或全部自动化的方法。 也许一个程序能够知道安装了哪些更新(已经看过一个,我不记得是哪个,而且我知道PowerShell可以做到这一点)...并能够下载它们?还是从本地磁盘获取它们?因此,步骤变为: 1-使用我们拥有的最新整合版本安装Windows(自动安装) 2-使用Windowsupdate直到没有新更新可用(任何方式可以自动化?) 3-使用魔术程序 4-整合 编辑:我的需求是Windows 7和2008,但目标是通用,因为其他人可能还有其他需求。

1
DirectAccess客户端无法连接
我在工作场所的Windows Server 2012上设置了DirectAccess服务器。我正在使用Windows 8 Enterprise客户端连接到它。它可以通过移动连接正常工作,但在家连接时失败。我将防火墙/路由器排除在外,因为将笔记本电脑直接连接到电缆调制解调器时问题仍然存在。 我不确定从哪里开始调试它,有人有指针吗?Teredo和IPHTTPS接口都已启用(尽管服务器位于NAT之后,并且我们只有1个公共IP,我知道IPHTTPS是将要使用的唯一协议)。 IPHTTPS隧道似乎也已连接: netsh接口httpstunnel显示接口 接口IPHTTPSInterface(组策略)参数 -------------------------------------------------- ---------- 角色:客户 网址:https://已编辑:443 / IPHTTPS 上一个错误代码:0x0 接口状态:IPHTTPS接口处于活动状态 但是DirectAccess链接无法激活-get-daconnectionstatus循环 状态:错误 子状态:CouldNotContactDirectAccessServer 和 状态:错误 子状态:RemoteNetworkAuthenticationFailure 任何有关如何对此进行攻击的建议,我们将不胜感激!

2
将公共IP隧道传输到远程计算机
我有一个Linux服务器一有5个公共IP地址块,8.8.8.122/29。当前,8.8.8.122已分配给eth0,并且8.8.8.123已分配给eth0:1。 我在NAT后面的远程位置有另一台Linux机器B。我想在两者之间建立一个隧道,以便B可以将IP地址8.8.8.123用作其主要IP地址。 OpenVPN可能是答案,但是我还不太清楚如何设置(topology subnet或者topology p2p可能合适。或者我应该使用以太网桥接吗?)。此时,安全性和加密不是什么大问题,因此GRE也可以-机器B将来自已知的IP地址,并可以基于该IP地址进行身份验证。 我怎样才能做到这一点?有人可以建议在这种情况下可以使用的OpenVPN配置或其他方法吗?理想情况下,它还能够处理多个客户端(例如,与其他计算机共享所有四个备用IP),而不必让这些客户端使用其无权使用的IP。

3
使用tmpfs +一个非常大的/ tmp交换分区而不是常规文件系统?
我有Linux服务器,并且有一个备用500GB磁盘分区。我想格式化它并将其用于/ tmp。服务器偶尔会执行一些大型数据处理任务,因此/ tmp可能会保留GB的临时数据。 然后我有了一个主意,可以改为将其添加为交换分区,然后将/ tmp挂载到tmpfs。这个想法合理吗? 服务器具有6GB的RAM,因此在大多数情况下,/ tmp上的数据仅在RAM中,具有明显的速度优势。问题是,如果说/ tmp上有10-20GB的数据,系统将如何执行?与仅将/ tmp挂载到ext4分区相比,性能如何?感谢帮助。 编辑:很明显,当tmpfs的使用达到RAM限制时,系统将开始换出内存。但是Linux是否足够聪明,可以交换tmpfs数据并将“常规”数据保留在RAM中?如果是,那么我认为它的行为可能合理。否则,整个系统将受到严重影响。
8 linux  swap  tmp  tmpfs 


3
/ dev / mapper / VolGroup-lv_root还没有剩余空间吗?
我们有一台centos机器,并且mysql无法启动,并且由于空间不足而无法启动。以下是df-h结果。在这种情况下最好的办法是什么?添加更多硬盘? Filesystem Size Used Avail Use% Mounted on /dev/mapper/VolGroup-lv_root 47G 45G 0 100% / tmpfs 3.9G 0 3.9G 0% /dev/shm /dev/xvda1 485M 33M 428M 7% /boot /dev/mapper/VolGroup-lv_home 44G 180M 42G 1% /home

2
Symantec Endpoint Protection(SEP / SEPM)流量管理
我的组织在Symantec Endpoint Protection(SEP)(约2万个客户端)中部署了大型部署,并且在ESX VM中运行了一个SEPM实例。在可能的情况下,我们确实有许多远程客户端被指定为组更新提供程序(GUP)。 我们的系统管理员已经报告了SEP软件没有任何本地方法来限制其对网络带宽的使用。它需要向每个客户端发送“完整的”定义更新,大小约为数百兆字节。我们发现SEPM实际上将接受1000个客户端检入请求,并将以可能的最大数据速率发送所有客户端更新。 我们需要某种方式来减少SEPM用于本地更新客户端的带宽量,以便其网络连接上有用于管理流量的空间(远程,检查SEP控制台等)。 到目前为止,为了减轻整个网络的洪灾,我们从外部(在VM和交换级别)限制了SEPM流量,这可以防止头端网络出现拥塞。但是,这不能保证管理流量的带宽。 我们希望在OS或应用程序级别上进行一些更改以限制流量,而无需在数百个办公室中部署一些重量级的QoS。理想情况下,我们希望能够限制每个客户端用于SEP更新的流量。 如果您有任何实现此目标的想法,请告诉我。

3
IIS 7.5无法写入配置文件
我在Win Server 2008 R2上有关于IIS 7.5的错误,每当我尝试更改任何站点绑定或启动应用程序池时,都会出现以下错误: Filename: \\?\C:\Windows\system32\inetsrv\config\applicationHost.config Error: Cannot write configuration file 应用程序池作为网络服务运行。没有任何正在运行的站点受到影响,但是无法更改其配置 2012年5月10日更新 重新启动可以解决此问题,但是我很好奇最初是由什么原因引起的。 2013年9月4 日更新服务器不再生产。

1
重写Nginx的try_files
我正在尝试将非常简单的重写从以前的nginx版本转换为当前的重写,如下所示: location / { if ( !-f $request_filename ) { rewrite ^/([a-z]*)$ /index.php?action=$1; rewrite ^/([a-z]*)/(.*)$ /index.php?action=$1&item=$2; } } 这就是我所走的路。显示了索引页面,但是应该像上面那样重写的任何页面都抛出404: server { listen 80 default; root /var/www; index index.php; server_name _; location / { try_files $uri $uri/ /index.php?action=$uri&item=$args; } location ~ \.php$ { fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; include fastcgi_params; } } …
8 nginx 

1
HTTP,TCP,UDP和无连接
最近我对HTTP有点困惑。 据我了解,TCP可以运行面向连接或无连接的一些事实。虽然TCP是面向连接的,而UDP是无连接的,但当消息本身可以放入一条消息时,将使用UDP。 题: 如果HTTP使用TCP,并且TCP为多个消息交换提供可靠的连接,而HTTP被称为无连接,那么这怎么可能呢? TCP是面向连接的吗?那么HTTP如何无连接呢?
8 http  tcp  tcpip  udp 

4
如何配置我的内部DNS来解析外部资源
我的AD设置中有一个内部DNS。我有一个托管DNS的公共资源(通常在某个数据中心的某个地方) 有时,在我们的内部网络上,我需要获取公共资源-例如www.ourcompany.com,因为我们的内部DNS中没有www记录,所以我无法解析该名称。 如何配置我的DNS以将无法识别的名称转发到公共DNS。 更新:根据评论,是的,我有一个“水平分割”的dns(当时似乎是个好主意)。此AD设置不到24小时,可以在需要时重做-(尽管我会而不是)


By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.