服务器管理员

系统和网络管理员的问答

2
为什么cron.weekly不运行?
当我注意到我在Debian6服务器上的/etc/cron.weekly中放置的备份脚本没有执行时,我在其中放置了这个小脚本,以查看是否每周执行一次cronjob: #!/bin/bash echo 'CRON RAN' > /var/log/cron-weekly-runcheck.log 保存为 -rwxr-xr-x 1 root root 64 Jul 15 02:14 /etc/cron.weekly/runcheck.sh 今天检查时,应该创建的日志文件不存在。 crontab如下所示(据我所知,它应该是默认的debian6 crontab): SHELL=/bin/sh PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # m h dom mon dow user command 17 * * * * root cd / && run-parts --report /etc/cron.hourly 25 6 * * * root test -x …

1
上载的绑定接口:scp有效,而不是rsync
我需要在特定界面上上传文件。这不能通过iptables设置,因为我的脚本在多个接口上输出。 这工作正常: scp -oBindAddress=192.168.100.1 ... 但 rsync --address=192.168.100.1 仍在eth0(192.168.10.1)上发送 我怎么能强制rsync使用192.168.100.1? 任何的想法 ?
8 rsync  scp  bindings 

2
以与直接写入相同的效果/行为写入正在运行的进程的标准输入
这篇文章仅部分回答了我的问题。我的问题是在/ proc文件系统上使用进程的FD写入正在运行的进程的stdin不会产生相同的效果。 问题: 启动nc以侦听端口10000(此过程称为“进一步的nc 1”) nc -l 10000 启动另一个nc将字符发送到正在监听的nc(这将是nc 2) nc localhost 10000 在nc 2上写入标准输入 echo "some chars here" >> /proc/[PID-nc-2]/fd/0 问题:“一些字符在这里”无法到达正在收听的nc(nc 1),但在nc 2的控制台上却显示了。 问题:为什么并且有可能使其工作?
8 linux  stdin 

1
通过慢速或不稳定的网络链接可靠地传输文件
我需要通过低质量的宽带链接将许多文件传输到服务器。文件很大,每个文件传输大约需要30分钟。 我使用的是scp,但有时会挂起-传输不会因错误而失败,它会继续运行,但是不会再传输任何数据。 因此,我正在寻找一种“故障安全”的上传解决方案,即使该链接在几分钟内失败或不可靠,该解决方案仍将有效。 我的想法是: 将大文件分成小部分 上载零件,超时并在失败时重试 问题: 有一个现成的工具可以实现这个想法吗?(没有特别需要的可能是ftp或其他任何东西) 有没有一种方法可以检测scp何时挂起?((即它仍在运行,但不传输数据)
8 ssh  scp  upload  failsafe 

3
vmware esxi 5,无法创建快照并合并失败,如何删除旧的或合并重做日志?
我有一个看上去运行良好的VM,但是当VMWare DR(或我)尝试创建快照时,它失败了,当我查看VM的摘要页面时,它的顶部有一个警告,表明该磁盘需要合并。 因此,我转到虚拟机的快照管理器并选择合并(在快照管理器中,实际上没有列出快照)。如果失败并显示此错误: 该虚拟机在其快照树的单个分支中有255个或更多的重做日志。已达到支持的最大限制,将不允许创建新的快照。要创建新快照,请删除旧快照或合并重做日志。 如果我浏览数据存储(具有足够的可用空间,2 TB,并且该虚拟机低于40gb),实际上在vm文件夹中,我确实看到了一堆文件,编号一直到0255: myvm-000255-ctk.vmdk myvm-000255-delta.vmdk myvm-000255.vmdk 我如何清理所有这些?有SSH命令行命令,还是可以安全地删除某些文件?谢谢!

1
错误2006:MySQL服务器消失了
我正在使用uWSGI和nginx在CentOS服务器上运行Python Pyramid应用程序。我使用SQLAlchemy作为ORM,使用MySQLdb作为API,并使用MySQL作为数据库。该站点尚未上线,因此唯一的访问量是我和公司的其他一些员工。我们购买了一些数据来填充数据库,因此最大(也是最经常查询)的表是〜150,000行。 昨天我快速连续打开了网站的四个新标签,然后又收到了502错误的网关错误。我查看了uWSGI日志,发现了以下内容: sqlalchemy.exc.OperationalError: (OperationalError) (2006, 'MySQL server has gone away') 'SELECT ge... 重要说明: 此错误不是由于MySQL的wait_timeout。去过也做过。 我想知道问题是否是由同时处理并发请求引起的。我让自己成为一个穷人的负荷测试仪: for i in {1..10}; do (curl -o /dev/null http://domain.com &); done; 可以肯定的是,在这十个请求中,至少有一个会引发2006年错误,而且有时还会更多。有时错误会变得更加陌生,例如: sqlalchemy.exc.NoSuchColumnError: "Could not locate column in row for column 'table.id'" 当该列最明确存在并且在所有其他相同请求上均能正常工作时。或者,这一个: sqlalchemy.exc.ResourceClosedError: This result object does not return rows. It has been …
8 mysql  python  uwsgi 

2
重命名Exchange 2010 SP2服务器的步骤
当我命名一个Exchange服务器时,我犯了一个不幸的错误,我msex0当然认为这是“ MicroSoft EXchange”的缩写。有问题的服务器正在运行Windows Server 2008 R2,带有所有最新更新。现在它可以正常工作,但是我真的想更改名称以从名称中删除“ sex”,可能更改为诸如exchange0之类的东西。 我在Exchange中找不到完整的步骤列表或更改主机名的指南。如果有帮助,我的Windows实例将在VMWare中进行虚拟化。


2
MySQL慢写
插入下表最多需要70秒才能完成: CREATE TABLE IF NOT EXISTS `productsCategories` ( `categoriesId` int(11) NOT NULL, `productsId` int(11) NOT NULL, PRIMARY KEY (`categoriesId`,`productsId`), KEY `categoriesId` (`categoriesId`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8; 该表中大约有100,000行,它占用了7MB磁盘空间。 MySQL中是否有一些设置可以提高写入性能? 我的my.cnf文件如下: log-slow-queries="/var/log/mysql/slow-query.log" long_query_time=1 log-queries-not-using-indexes innodb_buffer_pool_size=4G innodb_log_buffer_size=4M innodb_flush_log_at_trx_commit=2 innodb_thread_concurrency=8 innodb_flush_method=O_DIRECT query_cache_size = 6G key_buffer_size = 284M query_cache_limit = 1024M thread_cache_size = 128 table_cache …
8 mysql  innodb 

1
Apache2中的*:80和_default_:80有什么区别?
我试图了解以下两个术语之间的区别: *:80 _default_:80 在Apache配置文件中。我对这里的文档不清楚,并且我在这里只能找到的唯一一个邮件列表对话也没有引起任何争议(对我来说是可以理解的)。 我有一堆这样声明的基于名称的虚拟主机: <VirtualHost *:80> ServerName example.com ... 并且我希望有一个条目在所有这些都不匹配时触发,即当请求传入时没有虚拟主机名,或者具有未声明的虚拟主机名。我应该使用*:80还是_default_:80?

1
隔离网络上的单个NTP服务器
我在隔离的网络上有两台Linux机器(A和B)。它们必须是时间同步的。机器A断续供电,并且必须服务时间,因为它已连接到权威时间源(GPS)。仅当机器A通​​电时,机器B才通电,但它是嵌入式linux设备,其电源状态会经常变化。这两台机器都无法访问其他系统。这是一个封闭的网络。 我知道这对于NTP来说是一个很高的要求,因为NTP通常希望与几台服务器建立联系。我无法在机器B上正常工作。机器A与GPS同步很好,机器B可以到达机器A甚至进行时间查询,但是机器A不被信任(也许是单独的吗?)。在机器A稳定运行一个小时后,情况突然改变,机器B正常工作。但是,当机器A停机(进而机器B停机)时,机器B再次无法找到良好的时间同步。 这是一些ntpdate信息。请注意,即使机器A的层数为1,操作也会失败,最后输出相同。 10.10.10.1:服务器掉落:地层太高 服务器10.10.10.1,端口123 阶层16,精度-19,飞跃11,信任000 refid [10.10.10.1],延迟0.02614,色散0.00000 传输4,在过滤器4中 参考时间:00000000.00000000 2036年2月7日星期四6:28:16.000 原始时间戳记:d3a9bdc4.27ebb350 2012年7月12日,星期四21:19:00.155 传输时间戳记:bc17c803.b42dfffe星期六,2000年1月1日0:25:39.703 滤波延迟:0.02625 0.02614 0.02618 0.02625 0.00000 0.00000 0.00000 0.00000 滤镜偏移量:39544160 39544160 39544160 39544160 0.000000 0.000000 0.000000 0.000000 延迟0.02614,分散0.00000 抵消395441600.451568 1月1日00:25:39 ntpdate [677]:找不到适合同步的服务器 我的猜测是机器A只是不相信自己的服务时间。在51分钟(可能不更早发生,我不知道)的正常运行时间并将其时钟与GPS同步之后,机器A开始正确提供时间,机器B便开始计时。我需要早点做。像,如果可能的话,在几秒钟内。 通过以下配置(以及大量的等待),它最终成功了。 机器A ntp.conf: 服务器127.127.28.0更喜欢真正的minpoll 4 maxpoll 4 软糖127.127.28.0阶层1时间1 0.420刷新GPS 机器B ntp.conf: 服务器10.10.10.1更喜欢真正的minpoll 4 maxpoll …
8 linux  time  ntp 

5
nginx关闭某些图片上的连接
有问题nginx。在客户端完成下载之前,它将关闭连接。看起来像: $ wget -O /dev/null http://www.site.com/images/theme/front/clean.jpg --2012-07-11 21:37:03-- http://www.site.com/images/theme/front/clean.jpg Resolving www.site.com (www.site.com)... 123.234.123.234 Connecting to www.site.com (www.site.com)|123.234.123.234|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 90707 (89K) [image/jpeg] Saving to: `/dev/null' 26% [===============> ] 24,291 --.-K/s in 8.7s 2012-07-11 21:37:12 (2.74 KB/s) - Connection closed at byte 24291. Retrying. …

2
NPM没有安装依赖项?
无法让NPM npm install -d在具有定义package.json文件的项目目录中安装依赖项。 这是我的package.json:https : //gist.github.com/3068312 在清除项目根目录的节点模块文件夹(rm -rf node_modules)后,我npm install -d在项目根目录中运行并受到欢迎: (ssh) /vagrant git:master ❯ npm install -d npm info it worked if it ends with ok npm info using npm@1.1.4 npm info using node@v0.6.12 npm info preinstall redeye@0.0.1 npm http GET https://registry.npmjs.org/sinon npm http GET https://registry.npmjs.org/underscore npm http …
8 ubuntu  node.js 

5
haproxy-在TCP模式下传递原始/远程IP
我已经设置了带有keepalived的haproxy,以实现percona群集的负载平衡和ip故障转移,并且由于它工作得很好,我想对另一个服务/守护程序使用相同的lb /故障转移。 我已经通过以下方式配置了haproxy: listen my_service 0.0.0.0:4567 mode tcp balance leastconn option tcpka contimeout 500000 clitimeout 500000 srvtimeout 500000 server host1 xxx.xxx.xxx.xx1:4567 check port 4567 inter 5000 rise 3 fall 3 server host2 xxx.xxx.xxx.xx2:4567 check port 4567 inter 5000 rise 3 fall 3 负载平衡工作正常,但是服务看到的是负载平衡器的IP,而不是客户端的实际IP。在http模式下,让haproxy传递到远程IP是很容易的,但是在tcp模式下该如何做呢?由于需要负载均衡的服务的性质,这一点至关重要。 谢谢!维托

1
max_binlog_size和日志箱大小
我的全盘有问题 -rw-rw---- 1 mysql mysql 1073741982 2012-07-03 18:14 mysql-bin.000034 -rw-rw---- 1 mysql mysql 1073741890 2012-07-04 14:39 mysql-bin.000035 -rw-rw---- 1 mysql mysql 1073741988 2012-07-05 09:16 mysql-bin.000036 -rw-rw---- 1 mysql mysql 1073741964 2012-07-06 00:04 mysql-bin.000037 -rw-rw---- 1 mysql mysql 1073741974 2012-07-06 21:45 mysql-bin.000038 -rw-rw---- 1 mysql mysql 1073741923 2012-07-07 19:05 mysql-bin.000039 -rw-rw---- …

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.