服务器管理员

系统和网络管理员的问答

1
在Centos6上禁用IPV6
我想在刚刚在Xen中设置的新Centos6虚拟服务器中禁用IPV6。我已经按照此处的说明进行操作,然后重新启动/重新启动了网络。 更新:遵循以下内容,这似乎奏效了,但现在还没有获取ipv4地址? eth0 Link encap:Ethernet HWaddr 9A:F0:43:47:04:F1 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:941 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:89952 (87.8 KiB) TX bytes:0 (0.0 b) Interrupt:14

3
如何防止访问未安装的挂载点
好的,我在fstab中有这个 //windows_mashine/Backup /backups cifs credentials=/root/.credentials,rw,_netdev,iocharset=utf8,uid=1000 0 0 我的cron中有rsnapshot,可将/ etc /和/ usr / local /以及其他一些文件备份到/ backups 最近,我发现当其他mashine关闭并且无法将/ backups挂载时,rsnapshot备份到物理文件夹/ backups,因此它占用了分区/空间。如何避免这种情况? 我可以防止未挂载时对/ backups的任何写入(rsnapshot以root身份运行,因为它需要备份一些系统文件)

1
IE9和Apache SSL nokeepalive设置
目前,我正在将Apache 2.2.3和CentOS 5.4用于我的PHP应用程序(PHP在5.3.7上运行),并且该应用程序在HTTPS上运行并且具有Root CA证书。 问题是我们一直在使用IE9(仅IE9)遇到一些奇怪的问题。IE9浏览器向我们的服务器提交HTTPS请求时,有时没有HTTPS响应。我注意到的是IE9将刷新页面。更具体地说,提到的页面是登录页面。因此,当我输入用户名和密码并提交表单,但没有响应时,IE9似乎又重新加载了相同的登录页面。(使用空白的用户名和密码) 从应用程序级别进行跟踪时,我确实注意到我已经收到了用户名和密码,并且该应用程序无任何错误地结束了。 最让人头疼的是它不能每次都被复制。有时我们可以登录而没有任何问题,但是有时它会遇到上述问题。 现在,我们公司拥有网络团队,开发人员和其他团队。我们的Apache在负载均衡器下运行。网络人员声称他们从不更改任何设置,唯一的更改是我们的应用程序。但是从开发人员的角度来看,更改与登录过程无关。 从我的角度来看,好像用户单击了提交,应用程序(apache)就通过发送HTML(HTTPS响应)来完成它的工作,但是HTML在网络中以某种方式消失了。我是否怀疑与连接保持活动有关?可能是IE9浏览器代理以不同的方式处理它,并且它以某种方式认为连接失败并重新加载页面以进行重试? 但是无论如何,我已经注意到Apache中用于SSL连接的以下设置: SetEnvIf User-Agent“ 。MSIE 。 ” \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0强制响应-1.0 不确定如何设置排除IE9及更高版本的方式?当我进行搜索时,以上设置是为了解决IE与Apache连接时的一些长期存在的问题。但是由于IE9相当新,所以问题可能已经解决,我们需要更新设置吗? 希望有人可以对此有所启发。

2
更改QEMU-KVM虚拟机的引导设备
我正在尝试更改VM的启动设备。我进入/etc/libvirt/qemu并设置了VM的XML文件<boot dev='cdrom' />。尽管如此,它还是尝试从硬盘驱动器而不是从cdrom启动。 我知道我已经在CD-ROM虚拟设备上加载了ISO映像。 我这样做不正确吗?我尝试完全关闭VM,然后将其重新启动却无济于事。也许我需要以某种方式重新加载设置? 编辑: 根据@Selivanov的要求: $ libvirtd --version libvirtd (libvirt) 0.8.7 和XML文件: <domain type='kvm'> <name>nimmy.example.com</name> <uuid>(SNIP)</uuid> <memory>524288</memory> <currentMemory>524288</currentMemory> <vcpu>1</vcpu> <os> <type arch='x86_64' machine='rhel6.1.0'>hvm</type> <boot dev='cdrom'/> </os> <features> <acpi/> <apic/> <pae/> </features> <clock offset='utc'/> <on_poweroff>destroy</on_poweroff> <on_reboot>restart</on_reboot> <on_crash>restart</on_crash> <devices> <emulator>/usr/libexec/qemu-kvm</emulator> <disk type='file' device='disk'> <driver name='qemu' type='raw' cache='none'/> <source file='/var/lib/libvirt/images/nimmy.img'/> <target …

1
ext3_dx_add_entry:目录索引已满
背景:我正在CentOS 5.3上运行lighttpd 1.4.28-1来提供静态资产。 信号:最近,有时会变慢。我在内核日志中得到以下错误/var/log/messages: proftpd[5145]: (::ffff:xx[::ffff:xx]) - FTP session opened. proftpd[5145]: (::ffff:xx[::ffff:xx]) - Preparing to chroot to directory 'xx' EXT3-fs warning (device dm-3): ext3_dx_add_entry: Directory index full! Sep 16 15:30:34 xx last message repeated 489 times 索引节点信息: df -i Filesystem Inodes IUsed IFree IUse% Mounted on /dev/mapper/ddf1_p3 77037568 9996012 67041556 …


1
在运行的Linux机器上创建交换文件
由于托管公司计划淘汰不太可靠的共享托管服务器,因此我们公司的网站刚刚从共享主机迁移到VDS。 VDS仅具有256MB的RAM,并承载几个站点,除了一个站点以外,其他所有站点都是非常简单的静态站点,只有几页,并且每天总共接待不到20-30位访问者。 我们的主站点运行某种程度上是OSCommerce的定制版本,该站点的流量也很少(很少有10个以上的并发用户),但确实需要MySQL。不幸的是,由于移动mysqld由于内存不足而不断崩溃。我已经对Apache配置进行了一些编辑(以减少线程数)以减轻负载,但这只是回避了实际问题。 服务器没有交换空间,但是它确实比我们需要的磁盘空间大得多,因此我正在考虑将其中一些空间用于交换。我知道这并不能完全提高性能,但是我们可以接受。 如何在服务器运行时创建交换文件并启用它?操作系统是CentOS 5.5(最终版),而Linux不是我的母语。 更新:对于任何可能对结果感到疑惑的人,由于实现了Quanta所描述的交换文件,服务器不仅稳定,而且没有mysqld崩溃,它实际上比以前更快地处理页面。性能上的提高与我的预期相反,但我很高兴在这种情况下犯错了。
8 centos5  swap  vds 



3
确定root用户的ulimit
我们相信我们已经增加了root用户的最大打开文件描述符。这是通过将以下行添加到/etc/security/limits.conf来完成的: * - nofile 2048 我们认为已经确认增加了root用户的限制,因为我们可以告诉(此处未描述)我们的应用程序(solr-由root运行)已打开1098个文件。但是,我们无法确定root用户可以打开多少个文件。我们希望该命令能够正常工作,但似乎并非如此: $ sudo -u root -s "ulimit -Sn" 1024 有任何想法吗?谢谢!
8 linux  solr  ulimit 

2
rsync:如何仅在最顶层目录中排除Dotfile?
当bash与下执行备份rsync,我想排除顶级目录中的所有点文件和隐藏目录,但不是那些另有目标目录。例如: /copyme.c /.dontcopythisfile /.dontcopythisdirectory/or_its_contents /directory/.butcopymetoo rsync -a --include=".includeme" --exclude=".*" . DEST无法在子目录中复制所需的点文件,但是诸如此类的变体--exclude="./.*"也会失败。 有什么建议吗?这是否需要过滤规则而不是简单规则--exclude?
8 regex  bash  rsync 

4
如何在Debian上创建一个随机密钥,加密的交换分区,将其称为“ by-uuid”?
明智的做法是,如果在GNU / Linux系统上实现了任何类型的块设备加密,也要对交换分区进行加密,因为任何解密的数据都可以随时以明文形式写入交换。 在debian手册页上查看“ crypttab”,我看到了一个在启动时创建随机密钥交换分区的示例,因此随着引导的进行,密钥是随机设置的,并且只有系统本身知道: # Encrypted swap device cswap /dev/sda6 /dev/urandom cipher=aes-cbc-essiv:sha256,hash=ripemd160,size=256,swap 在此示例中,交换设备由常规dev路径引用,即 /dev/sda6 例如,如果插入了USB驱动器,则绝对设备路径可能会更改,并在启动时重新分配。如果用户/dev/sda6碰巧是一个与预期不同的分区,并且随后被随机交换数据覆盖,则用户将非常不高兴! 因此,解决方案似乎是:使用UUID代替设备路径(因为UUID不应更改),替换/dev/sda6为/dev/disk/by-uuid/<whatever the uuid of dev/sda6 is> 但是……这就是问题所在:每次cryptsetup在引导时重新创建加密的交换分区时,都会为其生成一个新的UUID!h! 因此,我们需要以某种方式保留此加密文件系统的UUID。我认为cryptsetup可以通过其--offset开关来做到这一点,从而允许保留LUKS标头和UUID。 我找到了以下URL:https : //wiki.archlinux.org/index.php/System_Encryption_with_LUKS#Using_UUIDs_with_encrypted_swap_partitions 有谁知道如何在Debian OS上实现针对Arch Linux所述的解决方案?该文档中引用的初始化脚本似乎在Debian OS上不存在 谢谢! 编辑 一个人可以使用以下命令使用ecryptfs达到相同的目的(加密的交换空间): ecryptfs-setup-swap 避免困扰设备加密的问题。看看这个AskUbuntu查询

2
为Postfix“ smtpd_recipient_restrictions”设置的最佳参数
我们已经从另一个ISP继承了DNS,现在我们的邮件服务器每分钟被大约1000封电子邮件轰炸,其中99.99%只是垃圾邮件。我们正试图优化过滤/拒绝垃圾邮件,但运气不好。 您认为最佳设置是smtpd_recipient_restrictions什么? 系统配置:Ubuntu + Amavis + Postfix + MySQL + Fail2Ban-Postfix 任何建议都欢迎! UDPATE,2012年8月8日 在按照以下方式更改posftix配置并配置Potrgey服务时,垃圾邮件级别下降了10倍 smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_hostname, reject_invalid_hostname, reject_non_fqdn_sender, reject_unknown_sender_domain, reject_non_fqdn_recipient, reject_unknown_recipient_domain, check_policy_service inet:127.0.0.1:10023, reject_rbl_client zen.spamhaus.org, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_pipelining, reject_unauth_destination


2
通过公共IP地址传递给pfSense
我的数据中心中有一台服务器,该服务器具有多个公共路由的IP地址,现在正在运行ESXi进行管理。 以前,我在创建网络的主机下运行了一些VM: inet [x.x.x.210] -- Host OS |-- .211 -- VM 1 \-- .212 -- VM 2 现在,我想在pfSense和VMware下执行以下操作: inet lan [x.x.x.210] -- (NAT) -- [192.168.1.1] |-- .211 -- VM1 |-- .2 -- VM3 \-- .212 -- VM2 \-- .3 -- VM4 其中VM3和VM4正在获得pfSense NAT转换的专用IP,而VM1和VM2仍在同一适配器上通过,但是现在获得了自己的公共IP。 我在导航pfSense的界面以找出应该如何完成时遇到了麻烦。优先地,我希望仍通过DHCP分发公共IP,以便一旦pfSense支持它就可以添加IPv6隧道。另外,仍然能够将pfSense用作防火墙也是最好的(否则会破坏目的)

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.