服务器管理员

系统和网络管理员的问答

2
使用中间的Apache Proxy重写302 App Server重定向URL
我有一个奇怪的设置。看起来像这样: Browser ----------> HTTPs Proxy ------> Apache HTTP -----> Tomcat AJP HTTPS HTTP AJP 在HTTPS代理(一个非常笨的代理)上,出现了一个类似于https://proxy.domain.com/app的URL。然后使用HTTP像http://apache.domain.com/app一样将其通过隧道传输到Apache(传入主机proxy.domain.com)。然后,Apache使用AJP协议在本地将请求隧道传输到ajp:// localhost:8009 / app /。 有时,应用服务器希望重定向请求的路径。例如,将/ app /重定向到/ app / webapp。因此,它将302发送回apache,以重定向路径-可能类似于ajp:// localhost:8009 / app / webapp。然后,Apache将重定向URL重写为http://proxy.domain.com/app/webapp。HTTPS代理很笨,因此它不会分析重定向并将http更改为https。 因此,我想弄清楚是否可以配置Apache重新编写302重定向URL,以将用户发送到https。 这是我到目前为止在Apache的https.conf中拥有的配置: ProxyPreserveHost on RewriteEngine on RewriteRule ^/app$ /app/ [PT] ProxyPass /app ajp://localhost:8009/app 我尝试使用ProxyPassReverse,但无法弄清楚如何强制使用https而不是http重写302重定向URL。 有什么想法吗?

3
HP接入点从非IP地址发送多播数据包
我不是我们正常的网络专家...我刚刚被征召来解决这个问题,所以请多多包涵。 我们有一个相当大的网络(约4,000台设备?),主要由HP Procurve设备组成。在过去的几周中,我们不时收到一些广播风暴,这些风暴几乎阻止了所有其他流量通过网络发送。我将Wireshark设置为进行5MB转储,今天早上我在其中发现了其中的一些内容。 您可以下载数据包捕获。乐趣始于数据包#23968。看似格式错误的NBNS数据包一遍又一遍地重复。但是,这不只是一个直线循环。源(143.226.8.185)和目标(143.226.44.79)IP地址保持不变,但源MAC地址会更改。第一个数据包似乎来自网络上一些无关紧要的设备,并被发送到多播地址01:00:5e:7f:ff:fa。之后的所有数据包都来自我们HP无线访问点的MAC地址,并被发送到其他多播地址01:00:5e:62:2c:4f。 这是第一个数据包: No. Time Source Destination Protocol Info 23968 122.229240 143.226.8.185 143.226.44.79 NBNS Unknown operation (10) unknown Illegal NetBIOS name (1st character not between A and Z in first-level encoding) unknown Illegal NetBIOS name (1st character not between A and Z in first-level encoding) unknown Illegal NetBIOS …
8 networking  hp 

3
寻找适用于Windows的NTP服务器软件[关闭]
按照目前的情况,这个问题不适合我们的问答形式。我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意调查或扩展讨论。如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 7年前关闭。 我正在寻找用于Windows Server 2003/2008的NTP服务器,最好是免费的。我们已经尝试了内置的Windows Time Server,但是我们的测试确实表明它不是很准确,我们看到时差可以达到500毫秒。我们可以为我们的应用程序允许的最大时间差为〜100ms。 现在我们已经在Windows上使用了Meinberg NTPd。它工作得很好,但有一个大问题:如果客户端和服务器之间存在网络连接问题,则ntp服务器处于紧急状态。在重新启动ntp服务之前,不会给客户端新的时间。这是一个大问题,给我们带来了麻烦。几个月来一直运行良好,直到出现我们没有注意到的网络问题为止,我们只是在一周的时间差已经达到30秒之后才注意到它。在客户身上。 因此,请为Windows建议一些替代的NTP服务器。我使用过Google,但得到了许多无关的搜索结果。 编辑: 到目前为止,ntpd Windows版本非常准确,我想坚持下去。唯一的问题是网络断开后的“紧急状态”。也许有些人知道这是什么原因以及如何解决。另外,我忘了提到我们有这样的服务器/客户端设置: Server1-> Server2-> Server3-> Client1-> Client2-> Client3 因此,Server2从Server1获取时间,Server3从Server2获取时间,客户端从Server3获取时间。另外,有些客户端直接连接到Server2。所有服务器和客户端必须具有完全相同的时间(约100毫秒内),这一点很重要 现在Server3及其客户端出现网络问题。服务器运行Windows的ntpd端口,该端口充当NTP服务器和客户端。客户端将Dimension4作为NTP客户端。网络出现问题后,D4中的错误消息是这样的(在我的头上,没有确切的错误消息): 服务器响应:服务器处于紧急状态(无法同步时钟) 我通读了ntpd文档,唯一提到的“恐慌”是时差为10000秒,这将导致退出ntpd服务器,但事实并非如此。另外,还有一个“ -g”命令行开关可禁用紧急出口,但默认情况下已设置。 有什么想法可能导致恐慌状态以及下次如何消除它?
8 ntp 


4
来自Apache的SSL连接错误
我正在Ubuntu 10.04上的Apache / 2.2.14上运行一个(自签名)SSL证书站点,但是各种浏览器在尝试进行一半连接时给出错误。刚才看到了来自Chrome的短暂错误: "Error 126 (net::ERR_SSL_BAD_RECORD_MAC_ALERT): Unknown error." 单击刷新,问题消失了一段时间。 wget也是: $ wget --no-check-certificate https://dev.foo.com/deps/ --2010-09-08 19:30:26-- https://dev.foo.com/deps/ Resolving dev.foo.com... 184.72.53.220 Connecting to dev.foo.com|184.72.53.220|:443... connected. OpenSSL: error:0407006A:rsa routines:RSA_padding_check_PKCS1_type_1:block type is not 01 OpenSSL: error:04067072:rsa routines:RSA_EAY_PUBLIC_DECRYPT:padding check failed OpenSSL: error:1408D07B:SSL routines:SSL3_GET_KEY_EXCHANGE:bad signature Unable to establish SSL connection. 立即再次运行它,它的工作原理是: $ wget --no-check-certificate …


1
Apache,Trac和LDAP-如何将它们粘合在一起?
我正在尝试设置Trac以通过Debian(Lenny)服务器上的LDAP插件授权用户。 LDAP似乎工作正常,我可以通过以下方式成功查询: ldapsearch -vLx -h 127.0.0.1 -b "dc=example, dc=com" "(sn=mysurname)" 并且,如果我有意破坏了我的Apache LDAP地址设置,我会在/var/log/apache2/error.log中看到错误。 2010-08-27 17:19:38,909 Trac[api] WARNING: LDAP error: No such object (dc=examplefoo,dc=com) 当我访问http://example.com:8022/trac并单击登录按钮时,会弹出身份验证窗口(再次确认LDAP正在启动),但是,当我输入正确的用户名/密码时,我只会得到Trac网站页面: Trac Error Authentication information not available. Please refer to the installation documentation. TracGuide — The Trac User and Administration Guide 日志同样无济于事(忽略svn错误,我知道): 2010-09-01 14:25:30,553 Trac[api] DEBUG: NEEDS UP?: …
8 apache-2.2  ldap  trac 

4
我如何使用Minitel终端作为Linux哑终端
我最近购买了美国版的阿尔卡特Minitel终端。我认为这是1B版本。图片在这里: http://www.catpa.ws/pics/minitel2.jpg http://www.catpa.ws/pics/minitel3.jpg 我尝试将空调制解调器连接到背面的25针端口,并将其插入运行agetty的linux盒中,但是我无法显示任何已连接的迹象。我使用Google翻译将本文档翻译成英文:http : //mirabellug.org/wikini/upload/Documentations_minitel.pdf 据我所知,您可以通过键入Fcnt-T A将其退出videotex模式,然后使用Fcnt-T E关闭本地回波,然后使用Fcnt-P 4将其设置为4800波特。我想Fcnt指的是我的终端上的“ CTRL”键。但是我想我做错了,因为它看起来好像不能识别键击,因为“ Fcnt-T A”只是将字母A打印到屏幕上,而不是您期望的功能键组合去做。 有没有人将这些minitel终端用作linux终端,如果可以,请您分享一下如何配置minitel以使其作为终端运行吗?25针插头甚至是正确使用的端口吗?我在网上阅读了一些内容,表明您应该使用5针DIN插头,对吗?如果是这样,那25针插头是做什么用的?如果我应该使用DIN插头,有人知道引脚排列以便可以连接电缆吗?
8 linux  serial 


4
为什么Linux上的共享库是可执行的?
我只是好奇。 bash-3.00$ ldd libmylibrary.so ldd: warning: you do not have execution permission for `libmylibrary.so' 仅使用+ r,一切似乎都可以正常工作。我注意到/ usr / lib中的大多数.so确实设置了+ x ... 为什么共享库应该设置可执行位?如果我不设置它会发生什么?
8 linux 

8
简单的Web服务器监视(运行)
关于监视Web服务器是否已在Linux上运行的软件的任何技巧?它应该可以在不了解URL的情况下运行。并且它必须具有在网站出现故障时发送电子邮件警报的功能。为自己编写脚本应该不难,但是如果已经有了一些不错的东西,那似乎毫无意义。 请注意,我将监视内部服务器,因此该工具必须是在同一网络上的计算机上运行的工具,而不是基于外部Web的服务。 并请注意,小型和简单的解决方案是首选。 更新:我最终创建了一个我目前正在使用的小python脚本,可以在此处找到。

5
Nginx + Apache尾部斜杠重定向[关闭]
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 5年前关闭。 我有一个Nginx在80端口上运行的服务器,正在作为要Apache 2.2侦听的代理127.0.0.1:8080 当我访问http://hostname/subfolder/它时效果很好。 当我访问http://hostname/subfolder它时,会将我重定向到http://hostname:8080/subfolder/错误的地方。 据我看到了错误的重定向被Apache返回,但UseCanonicalName并UseCanonicalPhysicalProxy都设置为Off 关于如何解决该问题的任何想法?

2
Ubuntu登录页面:显示指定用户列表的位置
使用Ubuntu 10.04.1 Desktop(最新) 引导过程完成后,GDM将显示图形登录屏幕以及可以登录的用户列表。单击名称将要求输入其密码。 我想修改该列表,仅显示受限的用户列表。 (例如,其他用户仍然可以通过终端访问或“ su”登录(例如在Control-F4之后),但其登录名不应出现在Gnome登录页面上)。 请让我知道在哪里可以找到该文件(?)。我想从终端窗口(而不是图形环境)执行更改,例如在执行ssh之后。
8 ubuntu  login  gnome 

2
希望用FSArchiver或Clonezilla替换Ghost,有关功能的几个问题
我在一家PC维修公司工作,我们正在研究建立一台具有外部可访问SATA托架的专用计算机,以克隆硬盘驱动器作为安全网,以防万一在维修过程中出现问题。目前,我们在任何工作站上都​​使用SATA / PATA转USB桥,称为MagicBridge和Norton Ghost,但我们希望摆脱Ghost。 我们有一台装有大型RAID5阵列的计算机,当前已安装Windows Server 2008 Standard,但是可以用* nix取代。我对Clonezilla有一些经验,但是FSArchiver也似乎是一个合适的替代品。 我的首席技术人员想知道我选择的解决方案(可能是Clonezilla或FSArchiver,但我愿意接受免费的建议)是否能够: 在不抱怨的情况下从RAID1镜像克隆降级的RAID,例如单个驱动器 产生易于挂载的映像(他希望它们可以在Windows中挂载,但是如果没有其他简便的方法,* nix应该可以)类似于Ghost Explorer,因此可以还原单个文件并能够执行裸机恢复。 我谨此致歉,但我想在解释中做到彻底。 感谢您的任何建议或技巧:) 编辑:我刚刚发现Clonezilla有一个解决方法,用于克隆RADI1驱动器 EDIT2:找到了我两个问题的答案,显然我不是在对自己的搜索词组进行排序,可以删除这个问题吗?

2
您可以设置最小的Linux磁盘缓冲区大小吗?
我有一台比较旧的Linux计算机,内存为2GB,没有交换,并且运行良好,该系统使用所有未使用的内存进行缓存,效果很好。 但是,当我几乎要强调内存(例如,已分配的> 1950MB)时,它会缓慢地进行爬网。我怀疑这是因为没有剩余的磁盘缓冲区。我知道OOM杀手将很快生效,但通常不会到达目的地-它变得如此缓慢,以至于加载射击达到30-40,没有进程取得任何进展(因此没有分配更多的内存),并且我必须重新启动它。 当我尝试杀死一个进程以使机器响应时,例如通过转到控制台(通过Alt-F1,登录并执行“ killall badprocess”),它通常可以工作,除了我必须等待从用户名/密码到出现提示为止的约10分钟-始终在磁盘活动期间进行。 再说一次,没有交换,所以它没有交换-只是因为没有可用的缓冲区而rash动。 我将有100MB左右的空间专门用于磁盘缓冲区,这会更早地触发OOM杀手(毕竟,程序的内存更少),但是另一方面,它会使机器始终保持响应状态。 有没有办法做到这一点?我还没有找到执行此类操作的/ proc / kernel或/ sys / vm条目。
8 linux  cache 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.