服务器管理员

系统和网络管理员的问答

2
Windows 2003上的Mercurial浏览器在显示存储库之前需要进行几次刷新
尝试浏览我的Mercurial存储库时,通常需要刷新几次才能显示存储库列表。配置如下: Windows Server 2003(由http://www.server4you.com/托管的专用计算机。 网站具有使用自签名SSL的匿名密码保护。 水银1.5.3 Python 2.6.5 适用于Windows的Python 32扩展214 py2.6 isapi-wsgi 0.4.2 使用标准的hgwebdir_wspi.py文件(遵循以下副本),通过ISAPI提供信息库。 另外,在执行克隆/推送/等操作之前,我必须先浏览存储库,否则本地计算机上的hg无法找到该站点。 我应该怎么做才能开始追踪这个问题? hgwebdir_wsgi.py # Configuration file location hgweb_config = r'C:\Public\Mercurial\WebSite\hgweb.config' # Global settings for IIS path translation path_strip = 0 # Strip this many path elements off (when using url rewrite) path_prefix = 0 # This …

2
应用程序池替代方案startMode =“ AlwaysRunning”
如果某个Web应用程序要求使用其应用程序池对其自身进行设置,则可以在applicationHost.config中将其配置为: <add name="AppPool" managedRuntimeVersion="v4.0" startMode="AlwaysRunning" /> 仅每分钟从服务器请求一个页面是否会达到相同的结果?还是将startMode设置为该值还具有其他含义?
8 iis-7 

2
互联网延迟地图
我希望看到一个延迟图,该图显示了世界各地不同目的地之间实现的最低延迟。例如,丹麦和印度之间的延迟最低。例如,这可以用于计划在何处放置用于在线游戏的服务器场。

2
Apache2和logrotate:是否需要delaycompress?
目前,我正在查看Apache日志变得越来越大的文件大小。在我的logrotate配置中,我已delaycompress启用。Apache是​​否真的需要这样做(如logrotate文档所述,某些程序仍在旧文件中写入),或者禁用它是否安全delaycompress? 这是我的logrotate配置: /var/log/apache2/*.log { weekly missingok rotate 26 compress delaycompress notifempty create 640 root adm sharedscripts postrotate if [ -f /var/run/apache2.pid ]; then /etc/init.d/apache2 restart > /dev/null fi endscript }

2
Linux SCP定义目标端口
如何为目标IP指定端口?当我这样做时,scp -p 0000它仍然尝试连接端口22,而不是我指定的端口。 scp svn_backup.tgz user@xxx.xxx.xx.xxx:/path/to/new/svn/
8 linux  scp 

2
postfix需要60-90ms的时间将电子邮件排队-正常吗?
将个别电子邮件提交到本地Postfix服务器时,我们看到一些(也许是?)奇怪的延迟。 为了帮助诊断问题,我编写了一个小测试程序,该程序发送5封电子邮件: get smtp 1ms ( 1 ms) email 0 677ms (676 ms) email 1 802ms (125 ms) email 2 890ms ( 88 ms) email 3 973ms ( 83 ms) email 4 1088ms (115 ms) 减去第一封电子邮件中的握手时间,每封电子邮件大约90毫秒。这些计时还与其他人使用不同的代码路径编写的另一个测试应用程序所证实,因此它似乎与服务器相关。 我打开了详细的日志记录,可以看到延迟在消息结束\r\n\r\n和接收之间: [16:31:29.95] [SEND] \r\n.\r\n [16:31:30.05] [RECV] 250 2.0.0 Ok: queued as B128E1E063\r\n [16:31:30.08] [SEND] …
8 postfix  queue 

6
192.168.122.1是有效的IP吗?
据我了解,网络如下 Class A: 10.0.0.1 - 10.255.255.254 Class B: 172.16.0.1 - 172.16.255.254 Class C: 192.168.0.1 - 192.168.0.254 但是,然后我在ifconfig virbr0Linux计算机上查看: virbr0 Link encap:Ethernet HWaddr 42:40:99:CB:02:7F inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:16 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 …


5
解决apache无法启动的最佳方法?
最近,我们获得了一个备份服务器,以将所有数据镜像到主服务器故障的情况下。 我已经通过rsync更新了所有站点数据,并更新了所有apache配置和数据库。两台机器都在Ubuntu 9上(主服务器上为9.04,备份服务器上为9.10)。 因此,目前看来大部分内容都已同步(仍然需要弄清楚用户同步),我尝试启动Apache。我懂了 * Starting web server apache2 [fail] 没有其他迹象表明可能是什么问题。 我知道我没有足够的信息来期待你们的解决方案,所以我只想知道我可以从这里去进一步调查这个问题。会有任何错误记录吗? 谢谢!

2
无法成功运行Sharepoint Foundation 2010首次配置
我试图使用Power Shell运行非GUI版本的配置向导,因为我想设置config 和 admin数据库名称。GUI向导并没有为您提供所有可能的配置选项(即使它也没有这样做)。 我运行以下命令: New-SPConfigurationDatabase -DatabaseName "Sharepoint2010Config" -DatabaseServer "developer.mydomain.pri" -AdministrationContentDatabaseName "Sharepoint2010Admin" -DatabaseCredentials (Get-Credential) -Passphrase (ConvertTo-SecureString "%h4r3p0int" -AsPlainText -Force) 当然,所有这些都在同一行。我将它们分成几行以使其更易于阅读。当我运行此命令时,出现以下错误: New-SPConfigurationDatabase : Cannot connect to database master at SQL server a t developer.mydomain.pri. The database might not exist, or the current user does not have permission to connect to it. …

9
用于远程SVN管理的简单Web前端?[关闭]
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 5年前关闭。 我们运行一个SVN存储库。我们的一些更高级的用户需要能够执行某些SVN管理,而无需依赖系统管理员。 他们需要能够执行诸如创建SVN存储库,删除SVN存储库以及执行“ svnadmin dump”和“ svnadmin load”之类的命令。 我们希望避免在这些FreeBSD机器上进行SSH访问,而是希望通过Web UI提供服务接口。 我正在寻找一个使用Perl或PHP的简单脚本(或少量脚本)。我找到了svnadmin(来自Jochen Hoenicke)或svnadmin.pl(来自doug munsinger),但是希望找到具有更大用户群的东西或其他人推荐的东西。 看起来Trac允许SVN管理,但是可能附带了我们需要的更多功能。


3
将文件系统格式从xfs更改为ext4,而不会丢失数据
我在笔记本电脑上运行了一个新鲜的Lucid Lynx(Ubuntu 10.04)。我将文件系统定义为: 安装点/ ext4(46 Gb) jfs上的挂载点/ home(63 GB) 交换为3 Gb 我整夜离开机器去做一些任务,没有交流电源。第二天早上,我发现它处于待命状态,任务已完成,但是文件系统无法访问。它给了我I / O错误 看来jfs和Standby有问题。 无论如何,为了避免麻烦,我想将此挂载点从jfs格式移至ext4。 我可以做到这一点而又不会丢失数据,也不需要在完成转换之前将数据放置在临时位置吗? 遗憾的是,但是我回想起Windows时代,我们将FAT16更改为FAT32或将FAT32更改为NTFS,而不必丢失数据。我希望这在Linux上可用。 更新 / home文件系统是xfs而不是jfs,并且由于某种原因该文件系统似乎存在错误,我不得不重新安装操作系统两次,直到整个/ 但是,结论是,似乎没有办法进行转换
8 linux  ubuntu  xfs  ext4  jfs 

2
大型公司如何为没有管理权限的用户处理软件更新?
我刚刚开始为一家中小型公司提供IT支持。也许不超过150个用户。 现在,每个用户都拥有自己计算机的管理权限。这样,他们就可以安装更新或其他任何想要的东西。 我已经厌倦了使用用户计算机的麻烦,因为他们的计算机上充斥着他们自己的垃圾。因此,我首先想到的是取消对他们计算机的管理权限。这也将具有其他优势,例如,可以防止网络上的大量偷渡式恶意软件等。 出现用户无法安装更新的问题。(尽管我发现大多数人还是会忽略这些) 大型公司如何处理所有客户端计算机上的软件更新? 编辑:Windows环境。大多数服务器是Windows Server 2003 Enterprise。客户端都是Windows。赢得XP,Vista和7。

6
找出每月通过WHM或SSH进行多少DNS查询?
可能吗?我们可以完全控制我们的DNS服务器和实际指向的服务器。我们想迁移到Ultra DNS,因此对当前正在获取的DNS查询感兴趣,但我们需要知道一个月内可能收到的查询数量。 这可能找出来吗?跟踪开始之前,我需要启动服务吗?还是使用shell访问数据?

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.