服务器管理员

系统和网络管理员的问答

1
FTP / SFTP / FTPS代理
问候,我有一系列外部FTP站点,我需要这些站点允许防火墙后面的用户访问以进行日常工作。我们不允许直接访问Internet,我们代理所有内容,因此被迫在网络外围设置一台计算机,并迫使我们的用户将远程桌面插入该计算机以与这些不同的客户端站点进行交互。 问题是在我的一生中,我似乎找不到任何可以正常处理所有3种类型的FTP连接的东西。FTP代理是可能的,但是我还没有看到似乎可以优雅地处理FTPS和SFTP以及单一解决方案(最好是开放式解决方案)的任何东西。我可以很容易地通过netcat代理SFTP,但是FTPS是一个棘手的问题,在Google上我花了很多钱。
linux  proxy  ftp  sftp  ftps 

1
jboss前面的httpd和ejbca证书生成
我试图在jboss服务器前设置httpd,并使用x.509证书进行客户端身份验证。我已经按照本教程使用openssl创建了自己的CA,服务器和客户端证书,并且可以使用。现在,我尝试使用ejbca工具而不是openssl生成证书,但是失败了。我生成的证书配置错误,因为当我尝试使用它们时,我在apache和jboss之间收到ssl握手错误,并且在apache日志中可以看到 [Mon Jan 07 14:51:28 2013] [debug] ssl_engine_kernel.c(1874): OpenSSL: Loop: SSLv3 read server hello A [Mon Jan 07 14:51:28 2013] [debug] ssl_engine_kernel.c(1321): [client 10.55.160.194] Certificate Verification: depth: 2, subject: /CN=DEXXISCA/O=DEXXIS/C=FR, issuer: /CN=DEXXISCA/O=DEXXIS/C=FR [Mon Jan 07 14:51:28 2013] [debug] ssl_engine_kernel.c(1321): [client 10.55.160.194] Certificate Verification: depth: 1, subject: /CN=DEXXIS-RND-CA/O=DEXXIS/C=FR, issuer: /CN=DEXXISCA/O=DEXXIS/C=FR [Mon …
httpd  jboss 


1
如何在Powershell 4.0中启用或禁用ClusteredScheduledTask
对此页面的引用:http : //technet.microsoft.com/en-us/library/jj649815.aspx 我发现ClusteredScheduledTasks在没有GUI界面的情况下很难处理。 例如,它们具有Disable-ScheduledTask cmdlet。我可以针对ClusteredScheduleTask运行它吗?如果不是,启用或禁用集群调度任务的过程是什么? 是真的有很多人在使用ScheduledClusteredTasks的Windows功能,还是获得了一些第三方实用程序?

2
将集合从TFS2010移至另一个TFS2010
我们已经按照http://msdn.microsoft.com/en-us/library/ms404869(v=vs.100).aspx的每个步骤将TFS2010上的集合移动到另一个TFS2010服务器。一切都成功显示,但是当我们打开Visual Studio并查看项目历史记录时,我们看到某些用户的名字就像“未知身份(.........)”。另外,我们在TFS管理控制台上查看了组成员身份,其中缺少一些组,用户等。

1
从机器访问网络共享
我和我的同事正在尝试设置两个节点“集群”,其中每个节点都需要访问第一个节点上的文件。为了简单起见(这是一个开发环境),他创建了一个网络共享,其中共享了第一台计算机上的整个X驱动器(每个人>所有权限)。因此,最终,我可以通过访问进入文件\\xxx.xxx.xxx.xxx\X\filename.txt。 但是,有趣的是,虽然我可以使用IP地址或本地主机从其自身访问第一台计算机,但不能使用我给它提供的名称(在两台计算机上都使用hosts文件解决)来访问它。\\my.machine.name\X\filename.txt给我一个登录对话框(我无法使用本地帐户或域帐户登录)。但是,其他计算机可以使用\\my.machine.name\X\filename.txt,并且可以正常访问共享。这非常令人困惑,我还无法弄清楚是什么原因造成的。 这两个盒子都是Windows2012。我正在使用的帐户是本地帐户(在两台计算机上-相同的帐户名)。IP是静态的。两台计算机都在VMWare的vCloud中运行,并且在同一vapp中。任何见识,甚至调试它的好方法,将不胜感激。

1
带有安全管理器的Tomcat启动-CentOS
我之前已经看过这个主题,并且给出的解决方案有效。 但是,它不符合我的需要,因为它通过设置以下catalina.policy来授予对每个目录的读取访问权限: grant { permission java.security.AllPermission; }; 因此,我的问题是:有一种方法可以识别正在请求的文件或资源,但是当我取消此授权时被拒绝? 以下日志可能会有所帮助,并在删除给定的Grant时显示: java.security.AccessControlException:访问被拒绝(java.security.SecurityPermission getProperty.package.definition)在java.security.AccessControlContext.checkPermission(AccessControlContext.java:323)在java.security.AccessController.checkPermission(AccessController.java:546)在org.apache.catalina.security.SecurityConfig.setSecurityProperty(SecurityConfig.java:117)在java.security.Security.getProperty(Security.java:725)在java.lang.SecurityManager.checkPermission(SecurityManager.java:532)在位于org.apache.catalina.startup.Embedded.setSecurityProtection(Embedded.java:990)的org.apache.catalina.security.SecurityConfig.setPackageDefinition(SecurityConfig.java:106)在org.apache.catalina.startup.Embedded。(Embedded .java:130),位于org.apache.catalina.startup.Embedded(Embedded.java:115)在org.apache.catalina.startup.Catalina。(Catalina.java:58)在sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)在sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)在java.lang.Class.newInstance0(Class.java:355)在java.lang.reflect.Constructor.newInstance(Constructor.java:513)在java.lang.Class.newInstance0(Class.java:355)上reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:225)的.newInstance(Class.java:308)org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:410)的.newInstance(Class.java:308)java.lang.Class.newInstance0上java.lang.reflect.Constructor.newInstance(Constructor.java:513)上的sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)上的NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) (Class.java:355)在org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:225)在java.lang.Class.newInstance(Class.java:308)在org.apache.catalina.startup。 Bootstrap.main(Bootstrap.java:410)java.lang.Class.newInstance0上java.lang.reflect.Constructor.newInstance(Constructor.java:513)上的sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)上的NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) (Class.java:355)在org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:225)在java.lang.Class.newInstance(Class.java:308)在org.apache.catalina.startup Bootstrap.main(Bootstrap.java:410)308),位于org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:225),位于org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:410)308),位于org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:225),位于org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:410) 先感谢您!

1
如何在20个用户的服务器中运行我们的软件
我们将购买一台服务器,我们需要它能够在服务器中运行某些会计软件,并为每个远程连接的用户建立会话以打开自己的桌面,并允许他们同时运行所有会计软件客户端做他们的工作。我想知道我们可以在Windows Server 2012中使用哪些技术和软件,以及建立这样的东西需要什么? 谢谢

1
rsyslog无法启动:找不到
启动rsyslog时,我得到以下信息: /etc/init.d/rsyslog: 1: /etc/default/rsyslog: imudp: not found /etc/init.d/rsyslog: 2: /etc/default/rsyslog: 127.0.0.1: not found /etc/init.d/rsyslog: 3: /etc/default/rsyslog: 514: not found 我的/ etc / default / rsyslog文件: $ModLoad imudp $UDPServerAddress 127.0.0.1 $UDPServerRun 514

2
mysql用户-MySQL服务器权限
刚在最新的Ubuntu上安装了mysql,我想访问/ var / lib / mysql目录似乎为该用户设置了权限:mysql-MySQL Server,但我没有密码。我该怎么做才能访问该目录?
-1 ubuntu  mysql 

2
设置虚拟机管理程序托管SW RAID的裸机虚拟化系统
[我对运行“裸机”虚拟化硬件是完全陌生的,所以请带我进入TFM,以便可以进行升级。] 我希望做的是设置某种裸机虚拟服务器,但是管理程序负责运行软件RAID5。 我希望将所有6个主板SATA端口使用2GB磁盘进行RAID,从而获得10 TB RAID5卷。希望那时我可以将设备切成薄片,然后分发给不同的VM实例。 显然这里存在引导程序问题,因为没有更多磁盘端口供管理程序使用,但我一直在想,可以使用可引导的只读USB记忆棒来进行初始管理程序启动?那么在首次启动后,系统管理程序是否可能将RAID5卷的分区用于其自己的操作系统? 这样的事情有可能吗?有多少种方法可以做到?有什么好的文章,博客,还有什么可以吸引我的?

2
php-cgi每隔几个小时就安静地死去
php-cgi -v PHP 5.2.11-pl1-gentoo (cgi-fcgi) (built: Dec 21 2009 09:10:29) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies 系统信息 dev-lang/php-5.2.11-r1 gentoo 10.1 更新:我只是用最少的USE标志编译了PHP。现在看起来更好。让我们再等一会。
-1 php  gentoo  fcgi 

2
在共享服务器上设置django
我想学习如何使用django,但是我对服务器没有任何经验(不知道如何使用apache ..),并且入门时遇到麻烦。如果我只能访问共享服务器上的主目录,应该如何进行?我该如何选择并设置mod_python,mod_wsgi等?我的httpd.conf文件在哪里? 如果您可以用普通的英语解释,但请注意相关的技术术语,这将对您有所帮助。 非常感谢。


2
仅同一域:smtp; 5.1.0-未知地址错误530-'SMTP验证是必需的[关闭]
将netwave.be域从WebHost4Life移到Arvixe后,我遇到一个非常奇怪的问题。 我配置了几个电子邮件地址,例如steven@netwave.be和sandra@netwave.be。 对于POP3,我可以使用由Arvixe托管的邮件服务器mail.netwave.be。 但是,对于SMTP,我必须使用 relay.skynet.be。天网(Belgacom)是比利时最大的互联网提供商之一,它阻止向外部邮件服务器发送smtp请求。因此多年来,我一直在使用relay.skynet.be通过steven@netwave.be作为发件人发送消息。工作完美。 将我的域名移至Arvixe后,情况就不再如此。 我可以向人们发送电子邮件,没问题。我也收到了电子邮件,所以我怀疑也可以。 但是我无法从域中的一个用户向另一用户发送电子邮件。 例如,如果我将邮件从steven@netwave.be发送到sandra@netwave.be,则relay.skynet.be会很好地接收邮件。几秒钟后,我收到“交货状态通知(失败)”邮件,其中包含: 报告MTA:dns;mailrelay012.isp.belgacom.be 最终收件人:rfc822; sandra@netwave.be 行动:失败 状态:5.0.0(永久失败)远程MTA:dns;[69.72.141.4] 诊断代码:smtp; 5.1.0-未知地址错误530-“需要SMTP身份验证。” (投放尝试:0) 就像我说的那样,只有发件人和收件人都是Arvixe托管的域的地址时,情况才如此。 我有与Arvixe完全无关的服务器帐户。我可以使用这些帐户使用relay.skynet.be将邮件发送到steven@netwave.be。同样,我可以使用relay.skynet.be将邮件从steven@netwave.be发送到这些帐户。但不是从一个Arvixe帐户转移到另一个帐户。 我希望我已经清楚地概述了问题,并且有人可以帮助我。

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.