Unix & Linux

Linux,FreeBSD和其他类似Un * x的操作系统用户的问答

2
通过IBM IMM2安装CentOS 7
我正在尝试使用带有Java客户端功能的远程控制单用户模式在具有IMM2(集成管理模块2)的IBM服务器上远程安装CentOS 7(使用官方下载页面上的“所有ISO”)。IBM服务器计算机是一台全新的计算机,没有安装操作系统。硬件还可以。 安装卡在此: 然后我失去了与服务器的连接(错误:查看器已终止。原因:连接已终止),java applet崩溃了(错误:对等读取标头关闭了套接字。)并且已卸载ISO。 如果我建立了远程连接,则系统仍然停留在上图中所示的内容上,因此我尝试将终端更改为tty2,它可以工作,但是我可以做(根据我到目前为止的想法)给诸如“ mount”,“ dmesg”,“ anaconda”之类的命令(dmesg显示很多错误;我不知道anaconda应用程序做什么)并更改目录-“ cd”。 我试图找到一种在文本模式下安装CentOS的方法(就像我知道可以在ArchLinux和DSL中那样),因为我认为它与加载视频模块或类似的东西有关,但是我找不到一个使用CentOS的方法... 我试图以与CentOS 7相同的方式在该服务器上安装“ Damn Small Linux”(DSL)发行版,并且可以正常工作。 我试图修改CentOS引导程序命令以强制它采用另一个网络接口(服务器有2个网络接口处于活动状态,我怀疑它杀死了其中的一个,这就是为什么我失去连接的原因)请您能帮我吗找到一种方法在这种情况下使CentOS 7安装工作?除了使用装有DVD / USB棒并装有系统的物理机进行实际行程外,您还有其他解决方案吗? PS:我刚刚发现在tty4上我得到了不断出现的错误: (我现在要重新启动...)我真的希望有人可以帮助我,或者可以给我提示或新的想法!谢谢!

1
设置gnome终端或其他仿真器的行数
我知道这里存在stty,它允许在虚拟控制台(例如tty1)中设置行数。但是,这似乎不适用于gnome-terminal或xterm。因此,问题是,无论窗口大小如何,如何限制终端仿真器中的行数?换句话说,如果stty rows 20在tty1中可以看到输出开始累积到第20行(而不是机器上的默认行34),那么如何使用终端仿真器实现相同的目的?

1
hp DL 380 G5上的CentOS与RedHat
hp 列出了以下内容的下载: » Red Hat Enterprise Linux 5 Server (x86) » Red Hat Enterprise Linux 5 Server (x86-64) » Red Hat Enterprise Linux 6 Server (x86) » Red Hat Enterprise Linux 6 Server (x86-64) 但只有 » CentOS 5 由于据我所知,CentOS基本上是重新包装的RHEL,是否有任何理由我不能在hp DL 380 G5上运行CentOS 6.4 x86_64,包括运行用于EL 6的管理rpm?(我遇到了有关CentOS 6.2的问题,但有一些问题,但不是6.4。)(管理rpm有点关键,因为它们使我能够通过脚本保持对RAID阵列工作方式的了解,这就是我的意思。我过去。) 谁能在G5上以6.4 64位确认成功/故障?

1
linux用户的附加组的作用[关闭]
我想知道主要组与Linux中用户的附加组之间的区别 例如,通过将用户添加到某些组中,他是否可以获得某些特权? 此外,当我尝试为用户更改主要组时,请键入以下命令: sudo usermod -g maingroup user 然后,通过键入命令id,我仍然将原始组作为gid,那正常吗? 谢谢大家
1 linux  ubuntu 

3
CentOS 7-无法启动OpenVPN访问服务器
我一直在尝试在CentOS 7 VPS上安装OpenVPN访问服务器。但是,我遇到了许多问题。 最初,我遵循此DigitalOcean指南,但是在使用该指南遇到问题之后,后来我发现我打算安装Access Server。我找到了此 CentOS 6.5的DigitalOcean指南,并将其调整为适用于CentOS 7。 我开始怀疑,是否遵循这两个不同指南的说明是造成我问题的原因。我可以通过命令行启动该服务,但不能通过Web界面启动它。 $ sudo systemctl status openvpn@server.service openvpn@server.service - OpenVPN Robust And Highly Flexible Tunneling Application On server Loaded: loaded (/usr/lib/systemd/system/openvpn@.service; enabled) Active: active (running) since Thu 2015-03-05 08:12:53 EST; 3s ago Process: 1738 ExecStart=/usr/sbin/openvpn --daemon --writepid /var/run/openvpn/%i.pid --cd /etc/openvpn/ --config %i.conf (code=exited, …

1
从文本文件中的行访问子字符串并将其存储
我有一个这样的文本文件 chr1:16840617-16840780 RNU1-1 (2 columns are tab separated) chr3:142139047-142139211 RNU1-100P ............ ............ 我想遍历文本文件的行并将第1列和第2列保存在sep变量中,如下所示: OLDIFS=$IFS; IFS=$'\n'; for line in $(cat test.txt);do LOC="save location";NAME="save name";done 保存名称和位置后,我必须执行几个步骤才能获得所需的输出,但是到目前为止,我想存储它们。
1 linux  for 

2
/ etc / fstab中的“默认”选项是否包括“ acl”选项?
我正在CentOS 7上使用ACL,并注意到/应用了ACL 的分区()已安装了defaults选件。 据我所知,ACL需要acl在挂载中启用该选项,并且defaults= rw, suid, dev, exec, auto, nouser, async。 是否defaults包括acl现在(如果是),从哪个发行版开始? 编辑:刚刚发现XFS具有对ACL的本机支持,并且XFS是CentOS 7中的标准文件系统,它解释了所有内容。 编辑2:但是,我刚刚测试了在没有显式acl挂载选项的ext4文件系统中,即使在重新引导后,仍维护了ACL 。这是为什么?
1 rhel  mount  acl 

1
如何将分区扩展到VPS中所有未分配的空间?
我租了一个使用10GB SSD(Debian 7)的VPS,昨天我升级到了使用20GB磁盘的“第二层”计划。但是,“一键升级”过程没有按我预期的那样工作,他们所做的是将我的数据移至更大的驱动器而没有实际扩展分区。所以现在我有10GB的未分配空间。 我在这个VPS上确实有5个网站,上面有邮件帐户和爵士乐,我很害怕弄乱任何东西,所以我打电话给他们支持,他们出价80欧元为我做这份工作,我觉得这是不可接受的,因为我认为升级时已将其包括在内。他们去年的旧报价过去只是一键式工作,但借口是“ SSD有所不同,因此取决于用户”。 无论如何,我如何才能真正做到这一点而又不会搞砸,有可能在“实时”系统上做到这一点? 我知道几个命令,所以在这里我可以找到: root@vpsxxxxxx:~# df -h Filesystem Size Used Avail Use% Mounted on rootfs 9.9G 7.6G 1.8G 81% / udev 10M 0 10M 0% /dev tmpfs 388M 200K 388M 1% /run /dev/vda1 9.9G 7.6G 1.8G 81% / tmpfs 5.0M 0 5.0M 0% /run/lock tmpfs 775M 0 …

1
UberSVN和TortoiseSVN,有关版本号的问题
我在OpenSuSE服务器上安装了Subversion系统的UberSVN平台。它具有Subversion 1.7.9。 我之前安装了Tortoise客户端1.7.11,它运行良好,但是今天我发现了这一点: “我们很自豪地宣布TortoiseSVN 1.7.11已发布。它与Subversion 1.7.8关联。” Tortoise使用与服务器上安装的版本不同的版本是否存在一些问题(1.7.8 Tortoise与1.7.9 Subversion)? 现在,我将Tortoise更新到新版本,可以正常更新到1.7.13了吗? “我们很自豪地宣布TortoiseSVN 1.7.13已发布。它与Subversion 1.7.10相关联”(我认为是)。 或者我可以更新到1.8.0: 我们很自豪地宣布TortoiseSVN 1.8.0已发布。它与Subversion 1.8.0“链接(我认为没有)。 我会在UberSVN的论坛上写文章,但现在似乎已经废了一段时间。

1
使用电子邮件设置简单的自动化系统
对我来说,尝试建立一个简单的自动化系统非常困难。使用脚本,我想使用电子邮件执行远程任务。脚本概述: 发送带有标题为“ Pattern1(数字)”的空正文电子邮件 阅读最近的50个电子邮件标题。 查找与“ Pattern2(数字)”匹配的最新标题。 将该标头中的数字保存(回显)到文件中。 等5分钟 循环到1。 我正在尝试使用尽可能少的程序。目前,有Mutt用于发送和检索电子邮件。和grepmail(带有grepm脚本)用于搜索电子邮件。 我可以使用Mutt和grepmail吗?作为非系统管理员,我感到困惑。Mutt不适用于脚本编写。进行此设置的最简单方法是什么?
1 email  imap 

1
什么是热插拔?
许多问题被标记为:热插拔 。但是,在:标签信息中找不到Wiki。 我读过这个: 模块化的USB驱动程序由内核中的通用/ sbin / hotplug支持加载,该支持也可用于其他热插拔设备(例如CardBus卡)。 因此,我们可以说热插拔负责自动加载/卸载模块吗?
1 hot-plug 

1
Tmux:如何使用此键绑定?[关闭]
我只是下载了dotfiles(https://github.com/skwp/dotfiles),却不了解tmux配置: # Create splits and vertical splits bind-key v split-window -h -p 50 -c "#{pane_current_path}" bind-key ^V split-window -h -p 50 -c "#{pane_current_path}" bind-key s split-window -p 50 -c "#{pane_current_path}" bind-key ^S split-window -p 50 -c "#{pane_current_path}" v在tmux会话中,按任意位置都不会拆分窗口。我还要按什么?
1 tmux 

1
如何更改默认的vim冒号命令?
我知道如何重新映射.vimrc中的键,但这不是我想要的。我想更改一个冒号命令;具体来说,我想更改或删除:X(即大写的“ X”)。我总是在尝试键入时输入它:x(小写)。 这让我抓狂了15年了。我的手不会停止每天做10次错字。我必须更改或删除该命令。
1 vim 

2
如何将tmux整个缓冲区复制到剪贴板?
我现在可以通过运行以下命令capture-pane -S -3000并使用以下键盘绑定来做到这一点: bind C-y run "tmux save-buffer - | clip" 这需要我记住输入capture-pane -S -3000和按下Ctrl+B,Ctrl+Y。 我想一步一步做到: bind C-y capture-pane -S -3000; run "tmux save-buffer - | clip" 但这行不通。 理想情况下,如果tmux询问我要从缓冲区复制多少行,那就很好了。举个例子: bind C-y capture-pane -S -ASK_HOW_MANY_LINE_TO_INPUT; run "tmux save-buffer - | clip" 然后,如果按Ctrl+B,Ctrl+Y我将输入3000并按Enter键以获取最后的3000行。
1 tmux 

1
默认TCP KeepAlive设置
TCP KeepAlive(套接字选项SO_KEEPALIVE)由三个选项控制:机制触发的时间,探测间隔和失败的探测数,之后声明连接中断。 它们的默认值为: tcp_keepalive_time = 7200 tcp_keepalive_intvl = 75 tcp_keepalive_probes = 9 在1¼分钟后发送探针听起来很合理,在9次失败的探针之后声明失败也可以,但是最初的2小时背后的想法是什么? 甚至tcp(7)说 请注意,底层的连接跟踪机制和应用程序超时可能要短得多。 启用keepalive的要点是防止任何有状态的网络元素丢弃状态信息,但是此类元素往往会在几分钟内断开连接。对于某些受速率限制的服务器,curl短时间--keepalive-time似乎可以显着提高下载的可靠性。 那么为什么默认值这么长?

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.