服务器管理员

系统和网络管理员的问答

1
安装KB3200970和KB3202790更新后的DNS问题
在一周前运行Windows更新后,我注意到了这些问题。O这个问题在这里说明。发生的情况是,当我打开链接(或新标签页等)时,很可能第一个请求将给我Chrome错误页面,但没有URL的DNS条目,但是刷新后它就可以解决。 如果在页面上请求其他域(例如,作为嵌入式图像),则它们也很有可能失败,从而导致在许多情况下最终检索到的页面是带有文本的纯白色页面。再刷新一次,大多数问题就完全消失了。 它似乎是在系统范围内发生的,这是我可以轻松“看到”它的唯一方法是通过Chrome或Firefox。在使用Wi-fi时,手机上似乎根本没有出现该问题。我不知道是什么突然导致了这一点-我已经运行了几次恶意软件扫描,但仍未修复,我尝试使用Google的公共DNS和OpenDNS都没有解决(在前一种情况下,我经常得到在Google上搜索时出现DNS错误)。 解决这个问题的任何帮助将非常感激。

1
可以用一个图形卡/两个头对系统进行多座吗?
我想使用Ubuntu Xenial 16.04设置多座配置。 经过一些研究,看来现在的方法是通过“ loginctl”调用进行系统化。(例如,在这里看到)。 在因为我目前不需要材料(手头只有一个键盘)而深入研究本教程之前,我想知道是否有可能仅使用一张具有两个输出,HDMI和DVI。看来需要两张卡,但我想确定。 谢谢

1
为什么我创建的Amazon IAM用户尝试登录时会显示“我们找不到具有该电子邮件地址的帐户”?
在Amazon IAM管理控制台中,我创建了一个新的IAM用户,并为该用户分配了权限和密码。 但是,当尝试通过位于https://console.aws.amazon.com/console/home的Amazon AWS登录页面尝试使用该新IAM用户登录时,会发生错误: There was a problem We can not find an account with that email address 为什么我的IAM用户无法成功登录?

5
将JDK 8设置为Debian 8上的默认Java
我正在尝试将Java SDK 8工具(从debian backports仓库安装)设置为默认工具。 # update-java-alternatives --list java-1.7.0-openjdk-amd64 1071 /usr/lib/jvm/java-1.7.0-openjdk-amd64 java-1.8.0-openjdk-amd64 1069 /usr/lib/jvm/java-1.8.0-openjdk-amd64 # update-java-alternatives --set /usr/lib/jvm/java-1.8.0-openjdk-amd64 update-alternatives: error: no alternatives for mozilla-javaplugin.so update-java-alternatives: plugin alternative does not exist: /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so 嗡嗡声,除了该错误(根据/ubuntu/141791/is-there-a-way-to-update-all-java-related-,我认为这只是警告)替代方案,如果没有,我不知道如何解决这个问题,因为没有IcedTea的插件用于jdk8,我可以看到),这应该做的伎俩,对不对? 但是许多Java工具仍然指向Java 7: # update-alternatives --get-selections | grep java appletviewer manual /usr/lib/jvm/java-8-openjdk-amd64/bin/appletviewer extcheck auto /usr/lib/jvm/java-7-openjdk-amd64/bin/extcheck idlj auto /usr/lib/jvm/java-7-openjdk-amd64/bin/idlj jar auto …
8 linux  debian  java 

1
在Neo4j中使用LetsEncrypt证书
如何将LetsEncrypt生成的证书文件与Neo4j实例一起使用?LetsEncrypt生成的文件为: 证书 链 全链 私钥 到目前为止,我一直尝试通过OpenSSL进行转换,但没有使用PEM到DER的转换。Neo4j抱怨启动时找不到证书。问题是如何将LetsEncrypt证书转换为Neo4j可以使用的证书。 设置详细信息: 证书/var/lib/neo4j/certificates/以名称neo4j.{cert,key},权限600(由)拥有neo4j:nogroup。所有这些似乎都是根据文档。 在配置中,我有以下这一行来指定证书路径: dbms.directories.certificates=/var/lib/neo4j/certificates 在配置中,我还启用了通过HTTPS的远程访问: dbms.connector.https.address=0.0.0.0:7473 重新启动Neo4j时,出现以下错误消息: WARN Illegal character 0x16 in state=START for buffer HeapByteBuffer@5a260174[p=1,l=193,c=8192,r=192]={\x16<<< SEVERAL_LINES_OF_HEX_JIBBERISH_HERE } WARN badMessage: 400 Illegal character 0x16 for HttpChannelOverHttp@5d682358{r=0,c=false,a=IDLE,uri=-}

2
如何在不重启服务器的情况下添加新的永久磁盘?
我在GCP上有一个正在运行的实例,想在其中添加另一个持久磁盘。但是它不会出现。 这是n1-standard-1具有10 GB存储空间(名为s03)的实例。我创建了另一个存储disk-1并将其装入。然后我创建了disk-2。 可悲的是新的不会出现在这里ls /dev/disk/by-id的文档中提到的位置。 我重新启动系统并检查了日志,但是找不到任何问题,为什么disk-2不会出现。有任何想法吗?

1
如何使用Puppet或MCollective部署滚动式OS升级和重启?
我正在寻找对我的基础架构进行定期滚动升级的最佳方法。 通常,这涉及到在每台主机上一次执行一次: sudo yum update -y && sudo reboot 但是,我达到了可扩展性的极限。 我只想一次在每个角色中一次重新引导一个节点,所以,例如,我不会同时删除所有的负载平衡器或数据库集群成员。 理想情况下,我想执行以下操作: for role in $(< roles_list.txt) ; do mco package update_all_and_reboot \ --batch 1 --batch-sleep 90 \ -C $role -F environment=test done 但是,这似乎并不存在。我不确定使用“ shell”代理是否是最佳方法? mco shell run 'yum update -y && reboot' \ --batch 1 --batch-sleep 90 但是,我只是在寻找错误的工具来完成这项工作吗?有什么更好的方法来管理这种滚动重启,但是我可以以某种方式链接到我分配给Puppet的角色,这样我就不会因为一次不删除任何重要信息而感到自在,但我仍然可以做一些并行更新和重启?

3
通过分区不同大小的磁盘来提高可靠性?
我知道ZFS更喜欢所有具有相同大小的磁盘。但是,如果我有两个大小不同的磁盘(1TB和1.5TB),我希望具有一定的冗余性,但不能进行镜像。因此,我将两个磁盘分成5个分区,每个分区大约500GB,并创建一个“ raidz”池... zfs很高兴。它的设置实际上增加了可靠性吗?想法是,如果磁盘没有完全崩溃,而只有一部分发生故障,我仍然可以访问数据吗?
8 zfs  redundancy 


2
在rsync中,如何排除所有与模式匹配的目录?
在rsync中,我试图排除与模式匹配的子目录。但是,我无法使其正常工作。我遵循了在此处和在Google上找到的几个示例。但是,我没有得到正确的结果。这是我命令的选项: -avh --exclude 'branch*' --stats --delete --link-dest=$LNK 我的源目录结构是 /root /branch1 /branch2 /branch3 /other /stillAnother /etc 这是备份脚本的一部分。$ LNK是到前一天的rsync目标的链接。 我不想要/ root / branch1,/ root / branch2,/ root / branch3。或要同步的内容。但是,他们是。 这是我已经尝试过的排除位: --exclude=branch* --exclude='branch*' --exclude '/branch*' --exclude /branch* 感谢您的帮助/咨询。 编辑-解决“可能重复”标志 这个问题是关于目录的已知列表。我需要排除遵循模式的所有目录,即使这些目录尚不存在。即从我的示例,/branch*可以添加其他名称的目录。我需要使脚本适应未来的需要,并在添加与模式匹配的目录时避免编辑脚本,因为这些目录可能是临时的。
8 linux  rsync 

4
阻止用户将具有特定扩展名的文件保存在特定目录中
背景 无法摆脱服务器管理员权限的用户往往会忘记,将数据库备份(.bak)保存C:并填充驱动器时,地狱将彻底失败。 题 是否可以阻止服务器管理员用户将某些类型的文件保存在目录中C:?仍应允许它们在上保存任何其他文件类型C:,并且它们对所有其他驱动器的权限应保持不变。 另类 如果不可能只禁止某些文件类型,那么是否每次有人尝试将.bak文件保存在某些目录中时至少显示一个弹出警告C:? 其他注意事项 由于各种原因,这些用户必须保留其服务器管理员特权。 我不在乎是否使用文件级权限,脚本或GPO。欢迎所有可行的解决方案。

4
找到负责schannel ldap错误的客户端
ldap客户端在我们网络中的某个地方查询我们的AD服务器时没有正确的CA信息。这会在域控制器的事件日志中引发(我认为无用)系统严重(源:schannel)事件ID 36887: 收到以下致命警报:46。 如何找到配置错误的客户端?

2
DSC与“常规”脚本相比有什么不同/更好?
我在ITPro.tv上观看了有关PowerShell期望状态配置DSC的视频。他们介绍了它,并有效地运行了脚本。但是,这也是他们第一次(真正)引入脚本,因此我没有理解DSC和常规脚本之间的区别。我以前做过一些常规的脚本编写工作,也许他们只是没有一个很好的例子。似乎常规脚本可以安装角色/功能并复制一些文件就可以了。与脚本相比,我没有看到DSC的好处。除了一台机器能够轮询某种变化外,从理论上讲它们在实践中没有涉及。 DSC与传统脚本相比有什么好处?例如“安装角色,复制文件”? 使用PowerShell,您可以连接到远程计算机并告诉它们执行操作,因此这并非DSC所独有。 使用DSC,似乎您正在进行某种编译以生成mof文件,然后在脚本执行后从外壳运行它,这似乎是不必要的步骤。 在MSDN概述读起来就像PowerShell的概述,我看不出与众不同之处。

2
如何摆脱“您是否信任此打印机”消息框并通过GPO添加我的打印机?
工作站:Windows 7(x64)[打印机的安装目标] 伺服器:Windows Server 2012 R2(x64)[Active Directory,列印伺服器] 我一直在ash头,试图通过组策略安装此打印机!出于某种原因,我根本无法将此打印机与GPO一起部署。我试图通过了设置它来部署Computer Configuration->Policies->Windows Settings->Deployed Printers,以及Computer Configuration->Preferences->Control Panel Settings->Printers和User Configuration->Preferences->Control Panel Settings->Printers。我还尝试通过“打印服务器管理”控制台通过用户和/或计算机目标添加它。我尝试了所有方式,但没有任何效果。我遵循了一堆教程,并观看了一堆视频,只是为了确保我没有错过任何东西,但这实际上是一个简单的任务(从理论上来说)……这是行不通的。 在尝试调试问题时,我发现如果我去\\myserver\打印机并双击打印机,它将尝试安装打印机,然后提示我安装带有UAC类型提示的驱动程序。 我已经尽力想让该消息框停止弹出。我对其进行了研究,发现如果我要编辑Point and Print Restrictions位于Computer Configuration->Policies->Administrative Templates->Printers和处的GPO ,User Configuration->Policies->Administrative Templates->Control Panel->Printers可以尝试将策略设置为Disabled或,Enabled然后选择Do not show warning or elevation prompt策略设置底部列出的两个安全提示。 好吧,那也是半身像... 我确实发现,如果尝试通过转到unc并输入我的管理员凭据来手动安装打印机,它将从服务器下载驱动程序并安装打印机(如预期的那样)。如果用户尝试删除打印机并且以某种方式成功完成操作,那么他们注销并重新启动GPO就会立即执行我想要的操作,然后重新添加打印机。但是它要求我在每台PC上第一次手动添加它。 测试完之后,然后从GPO中删除打印机,然后注销并再次登录。我可以运行该命令printui /s /t2以打开一个GUI,该GUI使我可以轻松删除已安装的驱动程序,以将PC恢复到其原始状态(要求管理员凭据)。我还了解到的另一件事是打印机存储在位于的注册表中HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Connections。当我尝试删除打印机时,它告诉我不能删除该打印机时,我只是转到该注册表项,然后删除了要删除的打印机的GUID密钥。然后刚刚重新启动了后台打印程序服务,它的繁荣就消失了。这无助于我到达所需的位置,但在调试问题期间有助于卸下打印机。 我在某处读到,也许原因是某种类型的Windows安全更新更改了某些内容。之所以发布它,是因为有一篇文章显示了如果您能够拥有一台打印机,那么如何拥有整个网络。当用户连接到打印机并下载驱动程序时,它会安装注入的软件并在机器上运行,等等。 我的主要目标是能够使用我正在使用的GPO在该OU中将该打印机部署到一组用户。但是,我尝试执行的所有操作都要求管理员登录(至少是第一次)。有谁知道为什么我的打印机无法通过GPO自动添加自身,以及如何获得“您是否信任此打印机”的信息?消息消失?

1
ansible运行全局变量
我想使用ansible创建服务器集群。 在一个主要剧本中,我包括一些子剧本。 - include: playbook_commandserver.yml - include: playbook_agent.yml 在playbook_commandserver.yml中,创建命令服务器(在AWS上)。然后,我触发一个角色,该角色使用该set_fact模块记住命令服务器的dns名称: - name: Get hostname of command server shell: /usr/bin/host $(/usr/bin/curl -s http://ipecho.net/plain) | /usr/bin/awk '{print $5}' | /usr/bin/awk -F 'aws.com' '{print $1"aws.com"}' register: cs - name: Set hostname of command server as fact set_fact: commandserver="{{ cs.stdout }}" 该commandserver事实是在同一操作可用,但不是在同一个剧本..更何况是在playbook_agent.yml,这是包含,算账。正是在这里,我需要访问该commandserver-fact。 那么如何设置/存储一个对完整的ansible运行有效的变量? 我发现了这一点:https : …

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.