服务器管理员

系统和网络管理员的问答

3
lsof在我的服务器上运行非常慢
我正在其中一台Linux服务器中运行lsof,以检查/tmp/incoming_data.txtext3系统中的一个文件()是否被其他程序打开。我的服务器上有很多TCP连接。奇怪的是,'sudo lsof'的执行需要大约两分钟的时间才能完成,并且在这两分钟之内使用了99.x%的CPU。 我使用的命令是sudo lsof /tmp/incoming_data.txt。我尝试了“ 定影器 ”,它需要大约相同数量的CPU和执行时间。有什么我可以解决的问题吗?
8 linux  lsof 

1
dd if = / dev / zero of = / EMPTY bs = 1M是什么
通常,我会在创建“无业游民”框时看到此命令 sudo dd if=/dev/zero of=/EMPTY bs=1M 对我来说,它似乎是一次将许多NULL字符复制到FS根1MB处的名为EMPTY的文件中。我的问题是,一旦删除文件,此操作如何优化磁盘上的空间使用情况。

4
如何设置由S3(或类似版本)支持的SFTP服务器
我需要设置一个本质上具有很大容量的SFTP服务器。我需要向我们的合作伙伴之一提供SFTP登录详细信息到服务器,他们将在其中上传数百万个文件,总计数百TB。然后,我将有选择性,很少读取这些文件。这是唯一的实际要求,任何技术选择都可以争夺。 最简单的方法是让某种EC2实例运行SFTP服务器,以便将上传的任何内容直接发送到S3,或者某种过程在上传时发现新文件,然后将其复制到S3,并将其从磁盘中删除。 这是最好的方法吗?是否有其他方法可以使服务器实质上具有“无限且神奇地增长的磁盘空间”? 谢谢你的帮助!丹尼尔

2
如何挂载数字海洋的dd图像?
我使用以下命令创建了dd/ 的图片dev/vda: ssh root@1.2.3.4“ dd if = / dev / vda” | dd of = / home / backup / vda.img 而且无法将其安装在我将其传输到的本地Ubuntu服务器上。 我得到这个dmesg | tail: [763158.222159] EXT4-fs error (device loop0): ext4_map_blocks:504: inode #8:block 10541546: comm mount: lblock 23018 mapped to illegal pblock (length 1) [763158.222299] jbd2_journal_bmap: journal block not found …
8 image  dd 

1
停止不必要的服务运行不是一个好主意
我有一个Debian专用服务器。我正在尝试保护它的安全,我认为一种不错的方法是关闭不需要的服务,例如FTP。 我建议在部署时运行以下内容: service ntp stop update-rc.d -f ntp remove service vsftpd stop update-rc.d -f vsftpd remove service xinetd stop update-rc.d -f xinetd remove 我是新来的。通常这样做是否被认为是较差的安全性,并使用来将其锁定在服务上iptables,还是完全建议删除服务并最终更安全?

1
具有子域设置的Haproxy设置
希望有人可以帮助确认这是否可行?我正在尝试将3个子域流量路由到同一haproxy主机; 这是我的设置 具有一个接口ip 10.10.10.100和dns名称haproxy01.mydomain.com的haproxy 3条与之相关的CNAME记录;sub1.mydomain.com,sub2.mydomain.com和sub3.mydomain.com 所有传入流量都用于端口443。 可以说,有两个后端应用程序服务器在三个端口8081、8082、8083上接受流量。 用于8081的sub1.mydomain.com用于8082的sub2.mydomain.com和用于8083的sub3.mydomain.com 该应用程序仅需要为端口8081的流量提供SSL传递,所以我认为我必须为其使用tcp模式,而针对8082和8083的其他流量也应使用SSL,但可以在Haproxy处将其终止,但是对于测试,我使用了所有TCP模式。 我的配置部分实现了以下内容; #Application Setup frontend mytraffic bind *:443 mode tcp acl host_sub1 hdr(host) -i sub1.mydomain.com acl host_sub2 hdr(host) -i sub2.mydomain.com acl host_sub3 hdr(host) -i sub3.mydomain.com use_backend sub1_nodes if host_sub1 use_backend sub2_nodes if host_sub2 use_backend sub3_nodes if host_sub3 option tcplog backend sub1_nodes mode …


2
今晚的安全更新后,SQL Server Windows身份验证失败:登录来自不受信任的域
我们有以下设置: 一个域控制器(DC,Server 2003 R2 Standard x64) 一台SQL Server(SQL,Server 2008 R2 Standard x64) 一些客户。 所有计算机都在同一域中。所有正在使用的用户帐户都是域帐户。SQL会为每个SQL Server 2005、2008、2008R2、2012和2014运行一个实例。 自从今晚(重新启动DC以安装自动Windows安全更新)以来,通过Windows身份验证访问SQL 2005、2008和2008R2实例不再正常工作: 当访问这些实例之一时 来自一位客户 使用Windows身份验证 发生以下错误(这是2008R2消息,2005/2008消息类似): 登录失败。该登录名来自不受信任的域,不能与Windows身份验证一起使用。(Microsoft SQL Server,错误:18452) 显然,消息文本不适用,因为只有一个域。 现在令人惊讶的是:用户登录SQL(启动RDP sesson甚至只是运行runas /user:MYDOMAIN\someuser cmd并保持窗口打开)后,该用户就可以从所有客户端访问所有SQL Server实例,而不会出现任何问题,直到使用该用户的凭据已关闭。 这意味着我可以通过对SQL上的所有用户执行一次以上的runas命令(并使窗口保持打开状态)来解决此问题,但是显然,某些东西已经严重损坏。我怀疑今晚DC上的安全更新与它有关(因为这是唯一更改的事情),但我宁愿避免卸载并重新启动其中的每个更新(已安装12个更新,并且DC确实旧且缓慢)。 有没有人曾经遇到过这个问题,并且知道如何永久修复它?还有其他想法(除了接下来几天要成为Kerberos专家以外)?

2
我可以检测SSL客户端是否不支持服务器名称指示,并在这种情况下提供标准的HTTP网站吗?
我将需要使用SSL SNI,但是不幸的是,根据最近的Cloudflare博客文章,只有90%的网络支持它。我如何(例如使用nginx)检测客户端是否支持SNI并提供/重定向到网站的HTTP版本?这可能吗?使用SNI怎么能不丢失10%的流量?假设我没有有效的证书就无法将HTTPS流量重定向到HTTP,这样的请求是不可能的,这是否正确? 谢谢。
8 tls 

2
在PowerShell中访问已映射的网络驱动器
我正在VMWare Workstation中运行Windows Server 2012安装。我已启用共享文件夹,因此驱动器Z:已映射到\\vmware-host。我可以在资源管理器中正确访问此驱动器(可以Z:在“普通”`cmd内部访问),并且可以正确打开文件。 我打开PowerShell并尝试这样做cd Z:,但出现以下错误: cd:找不到路径“ Z:\”,因为它不存在。 为什么PowerShell无法找到已经映射的网络驱动器? 我用Google搜索了一下,找到了New-PSDrive命令。我执行以下操作: New-PSDrive -Name 'Z' -PSProvider FileSystem -Root 'Z:\' 但我仍然收到与上述相同的错误。我需要做什么才能访问PowerShell中的VMWare共享文件夹。

3
为什么DHCP服务器需要静态IP地址?
我正在尝试使用VM进行各种网络设置。在Windows Server上设置DHCP角色时,它需要一个静态IP。从技术的角度来看,我很难理解为什么这样做是必要的。 我对DHCP的理解是,客户端在网络上广播DHCP发现请求,网络上的任何设备都可以响应。DHCP服务器因此需要一个IP地址,但是为什么该IP需要是静态的呢?只要有 IP 地址,DHCP服务器就可以在其他位置获取其地址,并且仍然可以响应广播。 例如 服务器A,服务器B和客户端X均连接到同一交换机 服务器A为10.0.0.1,服务于10.0.0.X / 24 服务器A配置为仅通过MAC过滤将IP提供给服务器B 服务器B从服务器A获得其IP ,因此它位于10.0.0.X / 24上 服务器B服务10.0.1.X / 24 客户端X连接,并从服务器B获取IP 当然,一旦客户端X从服务器B获得IP ,它就不能直接与服务器B联系,因为它们位于不同的子网中。但这不是问题-DHCP请求(最初)是广播,因此交换机上的每个人都会收到它。 忽略管理的观点,为什么我不能 具有静态IP的主DHCP服务器,仅服务于其他DHCP服务器 “辅助” DHCP服务器的地址范围 从“辅助” DHCP服务器获得的客户端地址范围 DHCP服务器必须具有静态IP 是否有技术原因?

3
自动安装Debian Backports内核
我设置了以下固定方式: Package: linux-image-amd64 Pin: release a=wheezy-backports Pin-Priority: 1001 Package: * Pin: release a=wheezy-backports Pin-Priority: 499 我收到以下错误: $ sudo apt-get install linux-image-amd64 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if …

2
HAProxy切换到出现500个错误和/或服务器关闭时进行备份
我在只有2个后端服务器的前面设置了HAProxy,并进行了特殊配置:任何请求都应发送到服务器A;但是,如果服务器A返回5xx错误代码,则所有请求都应转到备份服务器B。当A返回“启动”时,所有请求都应转到A。 我正在尝试此配置: backend example_cluster balance roundrobin option httpclose option forwardfor option httpchk HEAD /ping.html HTTP/1.0\r\nHost:www.example.com http-check disable-on-404 default-server error-limit 1 on-error mark-down redirect scheme https if !{ ssl_fc } server node1 1.2.3.4:80 check observe layer7 server node_back 5.6.7.8:443 backup ssl verify none 但这不起作用有两个原因: 即使node1(A)已启动,所有请求也都路由到服务器node_back(B)。 似乎没有对服务器A执行任何httpcheck;或更好,在syslog中,我看不到有关服务器A关闭的任何错误。 如果删除“ option httpchk”行以及该行下面的两行;并且我还删除了服务器A中的“观察层7”;HAProxy通过将所有请求路由到节点A来工作。但是,显然,当服务器A返回500时,HAProxy不会切换到B。因此,我假设问题可能出在选项httpchk配置中。

2
思科DNS篡改或发夹?
我具有以下配置:CISCO 881,IOS 15.2(4)M6。在WAN接口上,从我们的ISP配置了86.34.156.48/29子网。路由器后面是2个Web服务器。NAT:86.34.156.51 <> 10.10.10.100(专用IP,server1)。如果我使用服务器的外部IP(86.34.156.51)配置BIND DNS服务器A记录,则外部世界永远不会从我的DNS服务器获得响应(我不知道那里会发生什么,也许路由器会进行DNS篡改或其他操作)类似(这是一个问题)),并确保DNS服务器已配置并正常工作(我使用TCPdump捕获了IP数据包)。但是,如果我使用服务器专用IP(10.10.10.100)配置DNS服务器A记录,则数据包总是到达了正确的目的地(使用服务器外部IP,也可能是DNS篡改)。 我能做什么??? +-----+ | | an other host somewhere on internet(C) | | +-----+ | | : : internet : | +-----+ | | ISP's router | | black box, without acces +-----+ | | 86.34.456.48/29 +-----+ | | CISCO 881, | | IOS 15.2(4)M6 …

2
Windows 2012 RDS Server是否已设置了许可模式?
我有一个令人困惑的情况。我正在为我们的环境设置2012 RDS许可服务器。我正在检查RD许可诊断程序,以确保一切正常,并且不断出现此错误:“未配置远程桌面会话主机服务器的许可模式。” 并将“许可模式”设置为“未配置”。令人烦恼的是,我已经多次设置了它,但仍然会说“未配置”。有什么我想念的吗? 谢谢

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.