服务器管理员

系统和网络管理员的问答

1
广告副本DC促销摊位
我最近继承了与我合作的一家小型初创公司的基础架构职责。我的传统角色是发展,所以请忍受... 我希望从右脚开始,并在Active Directory中启动并运行Active Directory。我已按照Microsoft TechNet上的指南在Azure VPN中安装AD林,并且具有以下结构 为我的本地网络配置为站点到站点VPN的Azure VPN,它显示为正确连接。 子网:192.168.5.0/24 HQNET 子网:192.169.1.0/24站点到站点VPN网关 子网:192.169.2.0/24 Auth 子网:192.169.3.0/24 Apps 子网:192.169.4.0/24数据 子网:192.169.6.0/24中 我在Auth子网IP 192.169.2.4的A1标准VM上具有Server 2012 R2。AD Install非常出色,启动了新的林,一切似乎都运行良好。该VM是使用Username1 / Password1创建的,在安装AD后会自动添加为Domain Admin / Enterprise Admin。 我在同一Auth子网-IP 192.169.2.5中启动了第二个Server 2012 R2 A1标准VM,以进行复制,并使用Username2 / Password2创建了该VM。然后,我将此虚拟机加入到使用第一个DC创建的域中。加入域后,我尝试将该虚拟机提升为副本DC。它要求提供凭据以执行此操作,我提供DOMAIN \ Username1:Password1作为凭据。 在升级过程中,AD到达父AD VM上的“正在创建NTDS设置对象”这一步骤,安装在此步骤停止。根据此处的文章:Active Directory安装停在“创建NTDS设置对象”上,这是由于域凭据与本地凭据相同吗?或者我没有将域凭据提供给安装。 我多次删除并重新创建了VM,尝试执行安装。我尝试以域管理员身份登录VM2,然后执行升级。我也尝试了在升级过程中提供域凭据的几乎所有方法(Username1 @ domain:Password1,DOMAIN \ Username1:Password1,domain.com \ Username1:Password1),无论安装挂起了什么。每次我都仔细按照文章中的步骤从VM1的林中删除VM2之前,都尝试再次升级。 我相信我错过了一步,或者没有看到我缺少的一小部分,但是我的经验不足。 将DC2提升为副本DC时我缺少什么?

9
无法连接到系统事件通知服务
几个最终用户尝试登录到他们的Windows 7计算机,他们收到一条消息,“无法连接到Windows通知服务”,它变成黑屏,并且从不实际加载其桌面。这已经进行了6个月以上。 如果我将该用户提升为本地管理员,则他们可以登录,但无法使用Aero Desktop Theme。计算机也需要几分钟才能启动到桌面,并且显示以下错误: 我已经尝试了一些帖子来解决该问题。这是我尝试不成功的一些步骤。 进来的脑垃圾 然 netsh winsock reset 禁用所有非Windows服务 使用禁用所有启动应用程序 msconfig 卸载Symantec Antivirus 我以为这与Nvidia驱动程序有关(戴尔笔记本电脑),但是我只有两个人拥有Intel Graphics。 安全模式下的靴子干净,快速。 机器都在同一个OU中。将问题机器移至具​​有不同GP的OU并运行GPUPDATE。没变。 从30分钟到2天,问题将自行消失。 重新安装了NIC /音频/视频驱动程序 我\Driver\WUDFRd failed to load for the device USB\VID_0A5C&PID_5800&MI_01\7&66de6c9&0&0001几乎在所有有问题的笔记本电脑上都看到了该事件。我认为这是智能卡读取器。 重建WMI存储库 然netsh catalogue reset和winsock reset 尝试过的修补程序KB2590550 然 SFC /scannow 今天,用户说他们重新启动后有更新,但这不能解释最近六个月的情况。 我在ntbtlog上看到了这个。这几个驱动程序未加载,但是日志反复将其重复50次以上: Did not load driver @oem77.inf,%staccel%;ShoreTel Desktop Sharing Accelerator …

1
如何使用Powershell修改现有的计划任务?
我正在研究一些使用Powershell来更新执行各种应用程序的现有计划任务的发布自动化脚本。在我的脚本中,我可以设置应用程序的“路径”和“工作目录”,但似乎没有将更改保存回任务。 function CreateOrUpdateTaskRunner { param ( [Parameter(Mandatory = $TRUE, Position = 1)][string]$PackageName, [Parameter(Mandatory = $TRUE, Position = 2)][Version]$Version, [Parameter(Mandatory = $TRUE, Position = 3)][string]$ReleaseDirectory ) $taskScheduler = New-Object -ComObject Schedule.Service $taskScheduler.Connect("localhost") $taskFolder = $taskScheduler.GetFolder('\') foreach ($task in $taskFolder.GetTasks(0)) { # Check each action to see if it references the current …

4
Cygwin启动错误/ usr / bin / id:找不到组ID的名称
我在工作中使用cygwin来快速访问unix工具并作为ssh终端。我最近安装了一些新的Cygwin软件包,现在当我尝试打开终端时,它非常慢,并出现以下错误: /usr/bin/id: cannot find name for group ID 10519 我不确定该错误意味着什么,但是现在打开cygwin终端所需的时间比过去要长得多。

2
SAN上是否有“强制性”可用空间?
我不是SAN的专家,我在这里写这篇文章是为了寻求一些有关我们所遇到的持续不断的,令人发指的问题的线索,而我们的供应商似乎无法解决这些问题。 我们拥有一个带有16 x 2 Tb磁盘的ENHANCE ES3160P4 SAN,该磁盘已为我们的视频监控系统提供。供应商已将SAN配置为在RAID 5阵列中使用14个磁盘,其中2个磁盘是全局备用磁盘。RAID通常分为两个大小相等的虚拟磁盘,它们跨整个RAID空间。每个结果都超过12 Tb。每个虚拟磁盘对应于一个LUN,该LUN附加到单个视频服务器,该服务器连续存储视频数据,并允许用户在需要时检索记录。LUN使用NTFS格式化,并通过iSCSI附加到Windows Server 2012视频服务器。视频服务器往往会充分利用其拥有的可用空间。 使用此配置,SAN的磁盘会出现故障,并且每次SAN都无法恢复RAID时,因为与此同时另一个磁盘发生了故障。在过去的几个月中,我们丢失了RAID大约4次。 这个问题似乎不是由不良的SAN样本引起的,因为我们拥有配置类似类型的其他三台计算机,它们似乎也存在相同的问题。只有一个没有问题,但目前未得到充分利用。 经过几个月的未知测试和检查后,供应商最终说众所周知,SAN不应100%使用,否则它将在物理上快速降级,并表示要解决此问题,应创建虚拟磁盘保留RAID中可用总空间的10-15%。 我在网上搜索了问题,但没有找到具体的说法。在我看来,创建跨越整个RAID的虚拟磁盘,然后使用不足的LUN(即允许Windows有可用空间并避免碎片),将是更合理的选择。如果不是这样,我不明白为什么ENHANCE SAN可以创建跨越整个RAID的虚拟磁盘(如果众所周知),因此必须保留一些可用空间,以及为什么供应商会在一开始就这样配置系统...但这是另一点。 最后,我们要解决这种情况。任何建议都可以接受。如上所述,我不是SAN专家,但是在遇到了许多问题之后,我想真正了解供应商是否知道发生了什么,因为我们再也无法接受这种情况了。 提前谢谢了!问候 编辑:磁盘类型 从答案来看,它似乎是相关的信息,我补充说磁盘都是Western Digital型号WD2001FYYG-01SL3。

2
Windows Server 2012-通过Web访问从外部地址访问RDS
我有一个很奇怪的问题。我正在天蓝色地设置RDS服务器以进行概念验证。我发现,如果我使用通过azure(xxxx.cloudapp.net/RDWeb)提供的外部URL进行Web访问,则可以很好地登录,甚至在任务栏中看到小的弹出窗口也可以表示我已经连接了,但是该页面显示没有可用的remoteapps-好像还没有发布过。 如果我修改主机文件以将外部IP地址视为具有内部dns名称(xxx.domain.local等),然后使用该地址访问RDWeb,则它可以正常工作。我可以访问remoteapp目录,选择一个应用程序并运行它,没有任何问题。 我已经尝试了所有我能想到的一切,包括设置了以前未安装的rds网关,但是没有任何区别。有人有见识吗?

2
我如何知道我已被负载平衡到哪个服务器?
我想测试位于负载均衡器后面的两台服务器之间的单向同步的一些配置更改(这就是Rackspace Cloud基础设施FYI)。我遇到的问题是,我无法确定已将负载均衡到哪个服务器,因为给出的IP始终是负载均衡器的IP。 是否有一种简单(甚至不是很简单)的方法来告诉我实际上已定向到哪个服务器。理想情况下,我希望使用浏览器中的内容,因为这意味着非技术团队的成员也可以相对轻松地报告问题,但是最好的解决方法构想也应受到赞赏。 附加信息:两台服务器都运行Apache,并且负载平衡器已配置了会话持久性。


5
Apache SSL错误:找不到私钥
我在Ubuntu 14.04上运行apache并尝试实现SSL。任何帮助将不胜感激。 default-ssl.conf具有: SSLCertificateFile /etc/apache2/ssl/domain.crt SSLCertificateKeyFile /etc/apache2/ssl/domain.csr 当我重新启动apache时,/ var / log / apache2 / error.log中的错误消息是: [Sun Feb 01 19:31:06.443226 2015] [ssl:error] [pid 30927] AH02203: Init: Private key not found [Sun Feb 01 19:31:06.443408 2015] [ssl:error] [pid 30927] SSL Library Error: error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag [Sun Feb 01 19:31:06.443424 2015] [ssl:error] …

1
一年过渡时ESXi 100%CPU上的Windows服务器
我们在ESXi服务器上运行许多Windows Server 2008 R2 SP1服务器。在2014年到2015年的年终过渡期间,CPU达到100%,并且计算机挂起。 该解决方案似乎是来自Microsoft的修补程序(KB2800231)。但是,仅列出的下载全部用于Vista(Windows 6.0),我们的服务器是6.1。不用说,当尝试运行MSU时,会出现错误,表明我们的操作系统不受支持。 修补程序网页(http://support2.microsoft.com/kb/2800213/en-us)指示应该有2008 R2的下载,但尚不清楚。 有谁知道此问题的更高版本修复程序,或者可以在哪里下载正确的MSU?


3
Server 2012 R2 Active Directory域SRV dns记录突然消失
我有一个最近配置的测试域。突然之间,只有具有缓存凭据的用户才能登录。该域包括两个域控制器,这两个域控制器都是相互复制的全局编录。 在调查了该问题之后,我发现所有_mcdcs域记录都在两个DNS服务器上完全消失了。由于无法解析诸如_ldap和_kerberos之类的SRV记录,因此无法定位域控制器。 我不太确定这是怎么发生的...清除DNS缓存或DNS清除会导致这种情况吗? 此时,我需要以某种方式还原记录。我查看了另一个域的设置,看起来它们可以手动重新创建...但是我注意到某些DNS记录中似乎包含SID名称...而且我不知道需要使用什么标识符用于重新创建它们。 有没有一个更好的过程可以用来摆脱这种情况?


2
Gmail SPF失败,基于客户端IP
Gmail无法通过基于客户端IP的SPF检查。这些是相关的标头: Received-SPF: fail (google.com: domain of johndoe@example.com does not designate 164.77.240.58 as permitted sender) client-ip=164.77.240.58; Received: from johndoe (unknown [164.77.240.58]) by mail.example.com (Postfix) with ESMTP id 993643FE2D 客户端IP(164.77.240.58)是johndoe计算机的IP。SPF记录中包含发件人IP(mail.example.com的IP)。 为什么Gmail失败基于客户端IP而不是发件人IP?SPF应该是这样工作的吗?
8 spf  gmail 

7
如何禁用每30分钟执行一次的自动预定的Puppet运行?
目标 目的是禁用每30分钟发生一次的自动Puppet-agent运行。可以更改间隔,但是应该完全禁用自动Puppet-agent运行。 尝试一次 根据此文档,应该可以通过配置以下内容来禁用自动Puppet-agent运行: /etc/puppet/puppet.conf [agent] daemonize=false 结果是 Notice: Run of Puppet configuration client already in progress; skipping (/var/lib/puppet/state/agent_catalog_run.lock exists) 如果木偶以默认的30分钟运行间隔手动运行。 尝试两次 user@hostname:~$ sudo puppet agent --disable 结果是 user@hostname:~$ sudo puppet agent -t Notice: Skipping run of Puppet configuration client; administratively disabled (Reason: 'reason not specified'); Use 'puppet agent --enable' …

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.