服务器管理员

系统和网络管理员的问答

2
PC“塔式”中的服务器机架与服务器
我的一个朋友告诉我,他在这家公司实习的公司没有服务器机架,因为冷却只会占用过多的能量,因此效果不佳。该公司当时使用“普通” PC塔来容纳其服务器。那些塔放在某种重型架子上。 冷却服务器机架比使用塔架需要更多的能量吗?


3
您如何备份40多台Centos5.5服务器?
我们很尴尬地问这个问题。很抱歉,我们缺乏UNIX专业知识。我们已经继承了40多个centos 5.5服务器,并且不知道如何备份它们。我们需要低级克隆类型的映像,以便在必须更换HD等时可以从头开始还原服务器。 我们已经使用了“ dd”命令,但是我们假设只有当您要将一个本地磁盘备份到另一个而不是将40台服务器备份到连接了外部USB HD的一台服务器时,此命令才有效。 所有40台服务器均具有一对镜像磁盘(不知道其硬件或软件RAID)。大多数只使用了100MB。服务器正在运行apache,zend,tomcat,mysql等。理想情况下,我们不想关闭它们以进行备份(但可以)。 我们假设标准unix命令(例如tar,cpio,rsync,scp等)没有用,因为它们仅复制文件,不分区,所有属性,组等,即不会产生可以简单地重新映像为文件的结果。新的HD,以使服务器从死里复生。 我们有一个大型的SAN,一个备用的Windows框和一个备用的Unix框,但是它们仅对网络中的一层可见。我们有一个未使用的Dell DL2000 monster磁带机,但是没有软件或文档。我们有一个symantec备份执行程序的副本,但是我们没有Unix客户端许可证的预算。(公司的资金为负数)。 我们需要能够远程启动备份,因为我们只能在紧急情况下亲自访问服务器(即还原) 谷歌搜索返回一些应用程序来执行此操作,例如clonezilla-看起来难以安装且具有侵入性。Mondo,似乎只有在本地计算机上才支持备份。Amanda可能是一种选择,但看起来需要几天/几周的时间来学习和设置? Centos内置了什么功能,还是我们必须走安装,学习和配置一组备份软件的路线? 有任何想法吗?这一定是一个非常标准的问题,护目镜无法给出明显的答案。
8 centos  backup 

1
tracert使NETBIOS在Win7上起作用的原因是什么?
这真的很奇怪-我对此有一个解决方法(请继续阅读),但是我很想知道它为什么起作用。 我的VPN设置可以与WinServer2003服务器和Vista客户端一起正常工作。 然后,我设置一个新的Win7框来访问同一服务器。服务器正在运行WINS。 两个客户端都可以正常使用VPN,并通过IP4地址在服务器端ping计算机。 但是只有Vista客户端才能通过NETBIOS地址(计算机名称)来ping通计算机。Win7客户端刚刚返回“找不到主机”。 据我所知,客户端配置相同。 偶然地,在摆弄时,我发现如果我在Win7客户端上运行tracert-在服务器端跟踪到任何计算机的路由,则NETBIOS可以正常工作。 例如(这是从Win7框上的cygwin命令行输入的,带有已编辑的密码等): $ rasdial "vpnName" Dave passWord Connecting to vpnName. Verifying username and password... Registering your computer on the network... Successfully connected to vpnName. Command completed successfully. Dave@QUIET ~ $ ping henshaw Ping request could not find host henshaw. Please check the name and …

4
公共云和私有云之间的确切技术区别是什么?
我现在试图弄清楚公共云和私有云之间确切的技术区别是什么。我想我可以找到一篇描述其工作原理的文章,但到目前为止还没有运气。每一篇文章似乎都在说些别的话。 我知道在公共云中,多个用户位于同一台物理计算机上,因此在处理私有数据时非常不安全。我知道私有云更安全,但我不确定为什么。是因为私有云具有类似于虚拟专用网络的功能吗?还是因为其他用户不在物理计算机上?
8 cloud 

2
AWS VPC-为什么根本没有专用子网?
在Amazon VPC中,VPC创建向导允许创建一个“公共子网”,或者让该向导创建“公共子网”和“私有子网”。最初,出于安全原因,公用和专用子网选项似乎不错,它允许将Web服务器放置在公用子网中,而将数据库服务器放置在专用子网中。 但是我此后才知道,除非您将Amazon ElasticIP与EC2实例相关联,否则无法从Internet访问公共子网中的EC2实例。因此,似乎只有一个公共子网配置,就可以选择不将ElasticIP与数据库服务器关联,并最终获得相同的安全性。 谁能解释一下公共+私有子网配置的优势?此配置的优势更多是与自动缩放有关,还是只有一个公共子网实际上安全性较低?

4
在AWS上,我是否必须打开EC2实例的防火墙以及安全组中的端口?
如果我将SSH端口从22更改为23453,则无法再使用ssh。 更详细地讲,我在Amazon Web Services上使用Red Hat EC2实例。这是我全新安装的第二个更改(第一个更改是添加非root用户)。 我可以使用Git Bash和本地.ssh / config文件进行ssh操作,我在/ etc / ssh / sshd_config中编辑当前显示的行 #Port 23453 说 Port 23453 然后重新启动sshd sudo service sshd restart 然后,在我的.ssh / config文件中添加一行“端口23453” Host foo Hostname my-ec2-public-DNS Port 23453 IdentityFile my ssl key 如果我打开另一个Git Bash shell(不关闭我现有的连接)并尝试ssh进入我的实例(使用ssh foo),则会看到以下错误: ssh: connect to host my-ec2-public-DNS port 23453: Bad …

3
如何使用GPO禁用“重新启动计算机以完成更新安装”弹出窗口?
我有一些位于站点上且永久登录的信息亭计算机,并通过WSUS接收FEP的更新。这很好用,但偶尔会在右下角显示此对话框: 我以为通过将No auto-restart with logged on users for scheduled automatic updates installationsGPO 设置为“启用”,这些将不会出现,但似乎仍会出现。这是我正在应用的Windows Update GPO的屏幕截图: 我想念什么?如何关闭这些通知?

3
ProxyPreserveHost上的各个proxypass规则
我的Web主机上有两个proxypass规则,一个指向用于缓存目的的本地清漆实例,我希望启用ProxyPreserveHost,另一个指向第三方托管的站点,而我希望禁用ProxyPreserveHost。无论如何,我可以按规则/通过方式执行此操作吗?

2
“ cat / proc / net / dev”和“ ip -s链接”显示不同的统计信息。哪一个在说谎?
我注意到/proc/net/deveth3有1753 drops。ip -s link显示0 dropped。为什么有区别?不同的数据来自哪里?哪一个是正确的? 我删除了多余的数据。 # uname -a Linux example09 2.6.32-5-amd64 #1 SMP Thu Mar 22 17:26:33 UTC 2012 x86_64 GNU/Linux # lsb_release -a Distributor ID: Debian Description: Debian GNU/Linux 6.0.4 (squeeze) Release: 6.0.4 Codename: squeeze # cat /proc/net/dev Inter-| Receive | Transmit face |bytes packets errs drop fifo …
8 linux  networking  ip 

3
为什么网站向不同的浏览器提供不同的SSL证书?[关闭]
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 4年前关闭。 上的SSL证书menswearireland.com,并在www.menswearireland.com上Safari浏览器,浏览器,SeaMonkey的,K-Meleon的,QtWeb,火狐和Opera工作正常。但是,Internet Explorer声称存在错误: 本网站提供的安全证书不是由受信任的证书颁发机构颁发的。本网站出示的安全证书是针对其他网站的地址发行的。 安全证书问题可能表明您试图欺骗您或拦截您发送到服务器的任何数据。 Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.0; Trident/5.0) 其他网站托管在同一管服务器未显示错误:achill-fieldschool.com与www.achill-fieldschool.comIE浏览器工作正常,即使据我可以告诉证书设置相同。 我究竟做错了什么? 这是运行Plesk的LAMPP服务器。 看起来服务器正在向不同的客户端显示不同的证书。对于一些客户就说明做出来的的RapidSSL证书www.menswearireland.com与menswearireland.com作为一个有效的替代名称。对于其他客户,它显示出发给的Parallels Panel证书Parallels Panel。以下是一些不同的在线SSL检查器的结果:多数人说很好,而其中两个显示错误。 三位在线检查员说这是有效的 Comodo SSL Check显示为有效 DigiCert SSL Check显示为有效 SSL Shopper SSL Check显示为有效 通用名称: www.menswearireland.com SAN: www.menswearireland.com,menswearireland.com 有效期从2012年10月2日到2013年11月4日 序列号: 559425(0x88941) 签名算法: sha1WithRSAEncryption 颁发者: RapidSSL CA 另一个在线检查器似乎看到了完全不同的证书 GeoCerts SSL Check显示为无效 通用名称: …

2
虚拟化的pfSense 2.0.1是否会影响Hyper-V主机连接?阿普?
设置 我在Hyper-V中将pfSense 2.0.1(64bit-amd映像)设置为主机。如其他博客所述,我必须执行“ ifconfig down deX”,“ ifconfig up deX”来使网络正常运行。 该服务器(运行Windows 2008 R2的HP)配备了两个物理NIC。 主机中未配置第一个物理NIC(端口1)(仅作为Hyper-V交换机,请参阅下文)。 第二个物理NIC(端口2)配置有用于远程管理的网络(标准C类网络)。我认为两个NIC都连接到同一交换机,并且VLAN = default(物理布线是由我的托管服务提供商完成的)。 在Hyper-V中,定义了以下虚拟网络: internal:虚拟机内部网络,用于VM之间的通信(连接Windows服务器的“ LAN”)。 Internet:虚拟网络用作pfSense的WAN连接。该网络已分配给服务器的第一个物理NIC(端口1)。虚拟网络专用于Hyper-V,并且不与主机共享。 在我的设置中,我将pfSense用作面向Internet的两个虚拟机(Windows服务器)的防火墙,这些虚拟机也运行在同一Hyper-V主机上。 Windows盒使用pfSense作为默认网关,并且我已通过pfSense防火墙成功将Windows更新下载到所有虚拟机–运行流畅。 为了重定向进入的服务,pfSense设置了1-1 NAT,以将ISP的IP地址映射到Windows框上的内部172.16.0.0/16地址。 问题 我遇到的问题是,在管理网络(端口2)上成功使用RDP连接后,该连接将终止,并且所有网络连接都将丢失到服务器和VM。在问题发生之前,我做了两次配置更改。 将管理IP地址从端口1移动到端口2。此更改已通过在一个小时后在新接口(如上所述的端口2)上重新连接RDP来成功验证。 在pfSense中的虚拟IP上进行了一些配置(1-1 NAT所需)。 几分钟后,与机器的连接断开。 令我感到困惑的是,Hyper-V应该不会管理网络连接(端口2),因为它没有与Hyper-V集成。但是,似乎从pfSense传播了错误(在端口1上使用NIC)。 今天早些时候,当仅使用一个NIC(Hyper-V / pfSense与主机之间共享的端口1)时,我们也遇到了类似的问题。然后我们遇到的问题是,当pfSense停止时,我们可以对主机执行ping操作,而当再次启动时,ping会停止工作(我们所知道的没有IP冲突)。 pfSense是从ISO安装的,“ MAC地址欺骗”默认为= off。 由于问题接缝在两个物理端口之间传播,因此我猜测这可能与ARP无法正常工作有关。 任何对此的见解评论都非常感谢。 / J

1
SQL Server Express服务未启动
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 7年前关闭。 我昨天购买了第一台VPS,并在上面安装了Microsoft SQL Server 2012 Express。 然后,我重新启动了VPS。但是SQL Server服务没有启动。我尝试手动启动它,但无法启动: 问题是什么?怎么解决呢? PS:这是我的第一个服务器管理,我是新手,如果您需要任何其他详细信息,请发表评论。我将更新问题。 更新1:这是事件查看器中的一些日志详细信息,我认为它们对于解决此问题可能有用: FCB :: Open失败:无法打开文件1的文件e:\ sql11_main_t.obj.x86release \ sql \ mkmastr \ databases \ objfre \ i386 \ MSDBData.mdf。OS错误:3(系统找不到指定的路径。 )。 资源数据库内部版本为11.00.3000。这仅是参考消息。无需用户操作。 FileMgr :: StartLogFiles:操作系统错误2(系统找不到指定的文件。)在创建或打开文件'e:\ sql11_main_t.obj.x86release \ sql \ mkmastr \ databases \ objfre \ i386 \ MSDBLog.ldf'时发生。诊断并纠正操作系统错误,然后重试该操作。 启动数据库“模型”。 FCB …

1
无法从HP P400删除逻辑驱动器/阵列
这是我在此的头一篇博文。预先感谢您对此事的任何帮助。 我正在尝试从Smart Array P400中删除逻辑驱动器(逻辑驱动器2)和阵列(阵列“ B”)。主机是运行64位Red Hat Enterprise Linux Server 5.7(Tikanga)的DL580 G5。我无法使用hpacucli或cpqacuxe删除阵列。我相信是因为“操作系统状态:已锁定”。驻留在该阵列上的文件系统已被卸载。我不想重启主机。有什么办法可以“释放”此逻辑驱动器,以便删除阵列?请注意,我不需要将数据保留在逻辑驱动器2上。我打算从计算机上物理删除驱动器,并用更大的驱动器替换它们。 我正在使用Red Hat 5.7附带的cciss内核模块。 以下是有关主机和P400配置的一些信息: [root@gort ~]# cat /etc/redhat-release Red Hat Enterprise Linux Server release 5.7 (Tikanga) [root@gort ~]# uname -a Linux gort 2.6.18-274.el5 #1 SMP Fri Jul 8 17:36:59 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux [root@gort ~]# rpm -qa …


By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.