服务器管理员

系统和网络管理员的问答

3
如何在centos中的系统启动时自动运行脚本
我已经成功安装了TeamCity ib CentOS 6.2 Minimal。我一直试图在系统启动时自动运行脚本: /opt/TeamCity/bin/teamcity-server.sh start 我已经四处搜寻,尝试了各种方法,但所有方法似乎都失败了。大多数方法都指向将启动脚本添加到rc.local文件之一: /etc/rc.d/rc.local /etc/rc.local rc.local的内容包含以下行: /opt/TeamCity/bin/teamcity-server.sh start 没有一个将启动teamcity服务器 如果我手动运行脚本没有问题。 似乎很简单,但是我如何让Shell脚本自动运行?

1
HP DL380 G7 + Smart Array P410i + sysbench-> RAID 10性能不佳
我正在运行的系统具有较低的IO利用率: 惠普DL380G7(24gb RAM) 具有512mb电池支持的写缓存的Smart Array p410i RAID10中的6个SAS 10k rpm 146gb驱动器 Debian Squeze linux,ext4 + LVM,hpacucli已安装 iostat(cciss / c0d1 = raid10阵列,dm-7 = 60G用于测试的lvm分区): 设备:rrqm / s wrqm / sr / sw / s rMB / s wMB / s avgrq-sz avgqu-sz等待svctm%util cciss / c0d0 0,00 101,20 0,00 6,20 0,00 0,42 138,58 …

2
域控制器在2个月内处于离线状态,现在无法同步
简洁版本 设置了域控制器,然后使脱机时间超过了逻辑删除限制。现在,我无法再次复制它。 相关错误消息 在dc2上(关于exchange和dc1都存在相同的错误消息): The kerberos client received a KRB_AP_ERR_MODIFIED error from the server host/exchange.mydomain.local. The target name used was exchange$@MDOMAIN.LOCAL. This indicates that the password used to encrypt the kerberos service ticket is different than that on the target server. Commonly, this is due to identically named machine accounts …

4
您如何对Linux进行集中式补丁管理?
已锁定。该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。它目前不接受新的答案或互动。 我正在运行一个小型(但正在不断增长)的Linux环境,其中包含不超过10台Linux服务器。 该环境由CentOS 5和6以及Oracle Linux 5和6 Boxen组成。所有这些都通过其适当的yum存储库分别进行了修补。 谁能建议一种集中管理这些服务器的补丁程序的方法?我听说Puppet通常用于执行此操作,但我自己从未使用过它,因此有兴趣听取其他系统管理员的意见。
8 linux 

2
如何在AWS EC2内运行OVA + OVF设备?
GitHub Enterprise作为开放式虚拟化设备和文件提供;它打算放到现有的虚拟化设置中,例如VMWare,VirtualBox等。 我想在AWS EC2云中运行它(Github当前不提供AMI)。 我已经阅读了该主题,并且似乎AWS EC2的VMImport工具当前仅支持Windows VM。 我想知道是否存在将OVA / OVF设备导出到EC2实例中的逐步指南,因此我可以为其创建AMI并从那里开始吗?我已经尝试遵循本指南,但老实说,我不知道如何遵循步骤1-3;GHE只给我有限的ssh访问实例的权限,我不确定要查找什么或如何查找它。GHE似乎在Ubuntu基本发行版中提供。 (我仍然是初学者级别的linux sysadmin;我来自Windows开发背景,但是非常有能力快速学习。)

1
将内部CA部署到linux客户端
我有大量运行RedHat Enterprise Linux 5和6的工作站。我想将新的内部CA(活动目录)部署到这些机器上。我可以将证书手动导入Firefox 10,没有任何问题,但似乎找不到在文件系统上存储.cer文件的位置,以便FireFox和Google Chrome使用它。这两个浏览器都使用受信任的CA的中心位置吗? 如果没有,我会选择一种更自动化的方法来让FireFox接受我的CA。 我尝试过的东西 使用Mozilla提供的certutil-但这似乎只处理客户端证书,除非我弄错了。 修改/etc/pki/tls/ca-bundle.crt包含在ca-certificates包装中。Firefox似乎不支持该文件。

3
memcache.so的问题
我被要求启动其他人建立的网站。这是一个需要运行Memcached的Wordpress商店站点,我一直在使Memcached和memcache php插件在本地服务器上运行时遇到麻烦。在安装memcached和memcache PHP插件之前,我会收到此错误: Fatal error: Class 'Memcache' not found in [Path]wp-content/object-cache.php on line 350 现在,我已经安装了memcached和memcache PHP插件(通过Homebrew),我得到了一个“未收到数据”页面,并在我的Apache错误日志中得到以下错误: dyld: lazy symbol binding failed: Symbol not found: _mmc_queue_pop Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20090626/memcache.so Expected in: flat namespace dyld: Symbol not found: _mmc_queue_pop Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20090626/memcache.so Expected in: flat namespace [Sat May 05 16:38:27 2012] [notice] …
8 php  mac  memcached  memcache  lion 

5
从域管理员保护NTFS卷上的文件
我们是一家小型公司,具有2008R2域,在该域​​上我们有一个具有多个共享卷的文件服务器。我们在域管理员角色中拥有许多IT员工,因为实际上我们全天24小时不间断地待命。但是,最近已经成为公司政策的一个问题,即某些文件夹或文件(薪水数据,性能评估,会计信息)应该是机密的,包括来自IT人员的信息。这也包括备份(磁带和磁盘)上的数据。 到目前为止我们发生的事情: * EFS-但是我们必须设置一个PKI,这对于我们公司的规模来说有点过大 * TrueCrypt-但这会杀死并发访问和搜索能力 *从ACL中删除域管理员-但这非常容易(单击一下)即可绕过 *放弃使用Domain Admins组,并更明确地委派权限-但这又有点过大,出于审核原因,我们希望减少对共享帐户(例如,MYDOMAIN \ Administrator)的需求 我确定这不是一个新问题,并且很好奇其他有这种要求的人如何处理它?有没有我们尚未考虑的选择? 谢谢!


1
如何使用ebs根设备访问Windows EC2实例上的实例存储?
我已经创建了一个AMI,但是我想将实例存储用于一些我想运行的科学程序。他们基本上是从磁盘上读取一堆东西,然后将它们写回到磁盘上,然后汇总这些结果。它必须在Windows上,因为这是编写这些程序的平台。我不需要文件持久化,我也不在乎是否会丢失文件,因此我想为此使用实例存储,并且不会产生任何I / O费用。 因此,我启动了AMI,但是当我进行远程访问时,我只会看到我的EBS根设备。如何安装可用的实例(临时)存储?



8
剥开没有ripcord的Cat5电缆
我需要打几根电缆。通常,我会使用包含裂索的5类电缆。ripcord用于拉出外部绝缘层,而不会意外切断电缆的单股线。 我必须打线的电缆无法更换,也不包含拉线。剥除绝缘层以免意外切割单股的最佳方法是什么?


1
vCPU是与1个Socket相同还是一个Core?
目前,我有一个带有2(vCPU)处理器的Hyper-v VPS。我想安装限制为1个套接字或4个核心(以较小者为准)的SQL Server Express 2012。 我的问题: vCPU是作为单个内核还是作为插槽?还是完全不同的东西?
8 vps  sql  vcpu 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.