服务器管理员

系统和网络管理员的问答

2
为什么代理足够时需要nat?[关闭]
按照目前的情况,这个问题不适合我们的问答形式。我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意调查或扩展讨论。如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 8年前关闭。 我的机器在本地局域网中连接。要连接到Internet,流量将通过代理服务器。我对代理服务器的理解是,它代表原始请求发送者发送请求。因此,当服务器答复时,它将答复发送给代理,以为它是客户端。然后,代理将答复转发到我的机器。 以网络地址转换为例。您的请求通过nat路由器进行。然后,nat路由器为您提供一个公共IP地址,并将此映射存储在其表中。答复(来自服务器)被发送到此分配的公共地址。哪台nat路由器将从表中解析为您的本地ip地址,并将答复转发给您的计算机。 我的问题是,当代理服务器本身能够介导流量并为您提供访问互联网的权限时,为什么不需要?

3
如何在Windows Server 2012核心上安装dotNet Framework 3.51?
在Windows Server 2008 R2核心上,我使用dism.exe和功能名称:“ NetFx3-ServerCore”,该功能在Server 2012(Windows Server 8)上不可用。 在Server 2012 Core上使用标准3.51安装程序会告诉我:“必须使用角色管理工具来安装或配置Microsoft .NET Framework 3.5” 在(Server 2012的)GUI版本中,我可以执行此操作,并且它会从Microsoft.com下载一个程序包,但是如何在Core上执行此操作?

4
使用rsync移动文件夹时如何删除空的源目录?
rsync通过mv以下选项,可以非常传统地将其诱骗到移动文件夹中: rsync -axvvES --remove-source-files source_directory /destination/ 但是,我似乎无法做到的一件事是删除原始目录。该--remove-source-files标志就这样做了,除去了源文件,但也除去了源目录。我希望也有一个--remove-source-directories标志,但没有。 我该如何处理? 我想我只能rm -fr在搬家后发出一个,但是我宁愿将程序全部放在一个过程中,而不要引入潜在的错误。
8 bash  shell  rsync  zsh 

2
在大型安装中修改内核共享内存设置
sysctl.conf狮子上文件的位置在哪里?在Snow Leopard中,/etc/sysctl.conf但现在该文件夹不再包含它。在Spotlight中搜索文件不会产生任何结果。 共享内存设置是否已移至其他conf文件?它叫什么名字? 编辑 我正在尝试修改计算机的内核共享内存设置。当找不到sysctl.conf正确位置的文件时,我使用推荐的设置创建了自己的文件,并将其放入/etc目录中。但是,运行sysctl -a仍然显示出旧的内存设置正确。 如何在狮子安装上修改这些设置?

2
需要实时UDP回显服务器IP和端口
我需要使用回显服务器测试UDP程序。我已经在LAN中测试了此应用程序,但是现在我需要它在Internet中对其进行测试。 是否存在并在全球范围内可以直接在应用程序中直接使用的免费知名的ECHO服务器? 请帮助,谢谢。 编辑 我已经有一个基于Java的Echo Server程序,该程序在桌面上运行并使用Wifi连接手机。现在,我想检查该应用程序的Internet,因此我需要IP作为一些实时服务器的端口,就像某些IP提供的DayTime服务一样。
8 testing  udp  echo 

3
Sysinternals ADInsight是否可以替代?
我一直在使用Sysinternals的ADInsight来跟踪工作站上的Active Directory调用,但是该应用程序已失败。 无论应用程序是否处于捕获模式,以前在Active Directory事件中进行跟踪和记录的位置现在都保持空白。我已经以管理员身份运行,重新启动,下载了新版本;这些动作都没有使程序恢复到功能状态。 Sysinternals论坛希望不大,因为众所周知该工具经常失败。 有功能相似的工具吗? 问题 使用您的帐户从另一个工作站运行时,该工具会失败吗?是 它是否通过您(和/或)另一个使用他人帐户的工作站失败?是 工作站的事件日志中是否有任何内容?没有

2
Windows 2003; 查找具有非继承/更改权限的文件夹
问题:我正在寻找一种审计/搜索目录结构(Windows 2003)并找到任何未从其父级继承权限的文件夹或添加其他用户/组的文件夹的好方法。 背后的故事 我们正在将旧的Windows 2003文件服务器迁移到2008 R2盒中。该旧服务器是从NT4迁移的。当前的大多数文件夹都使用旧的(不建议使用?)Domain \ Administrators和Domain \ Users组。这些是仍在AD中的组,我无法在2008 R2权限中使用这些组。 因此,在将所有共享数据从旧服务器自动复制到新服务器之前,我首先需要“现代化”旧共享的权限。但是,我知道在过去的几十年中,对某些[未记录]的文件夹的权限进行了修改,以使其不继承自父文件夹或添加其他用户。因此,我寻求一种找到它们的方法!


2
Hyper-V下的虚拟防火墙?
我们目前正在考虑在基于Hyper-V R2的服务器上安装pfSense实例,以充当内容过滤器,强制门户和通用防火墙。 尽管虚拟化防火墙/网关通常是不好的做法。.有时您必须使用已有的东西!:) 我们有2个物理NIC。1个面向Internet(WAN),另1个面向内部LAN。 如何确保所有互联网访问都通过pfSense VM? 是否有配置消除了pfSense VM绕过LAN NIC的流量的可能性? 抱歉,如果这是一个愚蠢的问题,我今天是开发人员:D

3
Postfix中继到Office365
我试图在Linux机器上安装Postfix服务器,以将所有邮件中继到我们的Office365(Exchange,由Microsoft托管)邮件服务器,但是,我不断收到有关发送地址的错误消息: BB338140DC1:to = relay = pod51010.outlook.com [157.56.234.118]:587,延迟= 7.6,延迟= 0.01 / 0 / 2.5 / 5.1,dsn = 5.7.1,状态为退回(主机pod51010.outlook.com [ 157.56.234.118]说:550 5.7.1客户端没有作为该发送者发送的权限(以回复DATA命令的结尾) Office 365要求MAIL FROM和From:标头中的发送地址与用于身份验证的地址相同。我已经尽我所能在配置中想到的一切来使此工作正常。我的postconf -n: append_dot_mydomain = no biff = no config_directory = /etc/postfix debug_peer_list = 127.0.0.1 inet_interfaces = loopback-only inet_protocols = all mailbox_size_limit = 0 mydestination = xxxxx, localhost.localdomain, localhost …

1
PuTTY可以配置为显示以下UTF-8字符吗?
我希望能够渲染此推文中显示的字符: 我保存了推文的JSON数据,并编写了一个单行python脚本进行测试。 python -c 'import json,urllib; print json.load(urllib.urlopen("http://c.sente.cc/BUCq/tweet.json"))["text"]' 下图显示了此命令在两个不同的腻子会话上的输出,一个使用Bitstream Vera Sans Mono字体,另一个使用Courier New: 接下来是正确输出的示例(我没有使用PuTTY): 原始JSON在此链接上使用Twitter的API。 如何获得腻子显示这些字符?


6
带Exchange 2010的PowerShell Remoting:值不能为null
我在通过远程PowerShell会话运行Exchange 2010 cmdlet时遇到困难。 我以管理员身份启动本地PowerShell会话并发出以下命令- PS C:\Windows\system32> $mailcred = Get-Credential PS C:\Windows\system32> $mailSession = New-PSSession -ComputerName MAILSRV -Credential $mailcred PS C:\Windows\system32> Enter-PSSession $mailSession [MAILSRV]: PS C:\Users\jdoe\Documents> Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010 [MAILSRV]: PS C:\Users\jdoe\Documents> hostname MAILSRV [MAILSRV]: PS C:\Users\jdoe\Documents> Get-ExchangeServer Value cannot be null. Parameter name: serverSettings + CategoryInfo : + FullyQualifiedErrorId : System.ArgumentNullException,Microsoft.Exchange.Management.SystemConfigurationTasks.GetExchangeServer …


1
由于“在Kerberos数据库中找不到服务器”错误,NFS(使用Kerberos)安装失败
运行时: sudo mount -t nfs4 -o sec=krb5 sol.domain.com:/ /mnt 我在客户端上收到此错误: mount.nfs4: access denied by server while mounting sol.domain.com:/ 在服务器syslog上,我阅读了 UNKNOWN_SERVER: authtime 0, nfs/mercury.domain.com@SOL.DOMAIN.COM for nfs/ip-#-#-#-#.ec2.internal@SOL.DOMAIN.COM, Server not found in Kerberos database UNKNOWN_SERVER: authtime 0, nfs/mercury.domain.com@SOL.DOMAIN.COM for krbtgt/EC2.INTERNAL@SOL.DOMAIN.COM, Server not found in Kerberos database UNKNOWN_SERVER: authtime 0, nfs/mercury.domain.com@SOL.DOMAIN.COM for krbtgt/INTERNAL@SOL.DOMAIN.COM, Server …

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.