服务器管理员

系统和网络管理员的问答

1
选择运输服务提供商
我的组织可以从主要数据中心提供商处为单归属IP传输支付大量费用。现在,我们已经准备好开始考虑转换为与公交提供商的直接关系的位置。 这个问题在这里关于这个问题去触摸略有下降,但它不是很全面。例如,公认的答案指出,Cogent和Hurricane Electric被认为是廉价的提供商,而Level(3),AT&T和Telia被认为是更好的提供商。它没有做的就是确切解释为什么一个提供者可能比另一个提供者更好。 我对BGP,多宿主以及对等和传输的概念非常熟悉,但是我没有了解为什么其中一些提供者会比其他提供者更好。 明确地说,我不是要向提供者提出建议,也不是要提及任何有关此事的名称。我很高兴离开去做自己的“购物”研究。我只是有一个问题,我需要将苹果与苹果进行比较,而且我不知道要寻找什么! 如果有所作为,我们的组织位于英国。

2
为什么在lsof输出中看到webmin?
我正在运行一个服务器应用程序(用C编写),该应用程序绑定到我的服务器上的localhost地址上,127.0.0.1并使其在第一种情况下在端口上侦听10000,在第二种情况下在端口上侦听20000 当我运行命令时,我lsof | grep IP在最后一栏中是: 本地主机:webmin(LISTEN)(第一种情况) 本地主机:20000(LISTEN)(第二种情况) 因此,而不是端口10000存在webmin。 这是什么意思?我发现了这个。 它说Webmin是Unix系统管理的基于Web的界面。这对我没有帮助;为什么webmin在我的端口列表中看到?

3
dhcp-snooping选项82在2610系列Procurve交换机上丢弃有效的dhcp请求
我们正在缓慢地开始在HP ProCurve 2610系列交换机上实施dhcp-snooping,这些交换机均运行R.11.72固件。我看到一些奇怪的行为,其中,由于“来自客户端的不受信任的中继信息”,源自“下游”交换机的dhcp-request或dhcp-renew数据包会被丢弃。 完整错误: Received untrusted relay information from client <mac-address> on port <port-number> 更详细地,我们有一个48端口HP2610(交换机A)和一个24端口HP2610(交换机B)。借助于与交换机A端口之一的DSL连接,交换机B在交换机A的“下游”。dhcp服务器已连接到交换机A。相关位如下: 开关A dhcp-snooping dhcp-snooping authorized-server 192.168.0.254 dhcp-snooping vlan 1 168 interface 25 name "Server" dhcp-snooping trust exit 开关B dhcp-snooping dhcp-snooping authorized-server 192.168.0.254 dhcp-snooping vlan 1 interface Trk1 dhcp-snooping trust exit 将交换机设置为信任授权dhcp服务器所连接的端口及其IP地址。对于连接到交换机A的客户端来说,这一切都很好,但由于“不可信的中继信息”错误,连接到交换机B的客户端被拒绝了。出于以下几个原因,这很奇怪:1)任一交换机上均未配置dhcp-relay,2)此处的第3层网络是同一子网。DHCP数据包不应具有修改的选项82属性。 默认情况下,dhcp-relay确实已启用: SWITCH A# show dhcp-relay …

2
有没有办法从命令行更改.iso文件卷ID?
我.iso在linux下有一个文件,一直在尝试寻找一种无需重新创建.iso文件即可更改卷ID的方法。例如,大多数创作工具都mkisofs提供了用于设置音量的开关(-V)。但是我不知道如何更改现有.iso文件。 为了澄清起见,我要更改的位是此Volume id:字符串。这是isoinfo命令中的转储示例。 % isoinfo -d -i /usr/share/virtualbox/VBoxGuestAdditions.iso CD-ROM is in ISO 9660 format System id: Win32 Volume id: VBOXADDITIONS_4.1.8_75467 Volume set id: Publisher id: Data preparer id: Application id: MKISOFS ISO 9660/HFS FILESYSTEM BUILDER & CDRECORD CD-R/DVD CREATOR (C) 1993 E.YOUNGDALE (C) 1997 J.PEARSON/J.SCHILLING Copyright File id: Abstract File …
8 linux  iso  disk-image 

4
自动缩放MySQL服务器的方法?
我运行的网站流量激增,因此自动缩放解决方案在这种情况下非常有利可图。当前,Web服务器能够水平自动缩放,但瓶颈在MySQL服务器上。 我已经尝试过使用Amazon RDS Multi-AZ,但是12 GB数据库的升级大约需要15分钟,而停机时间则是几分钟。当我已经知道在某个特定时刻将会出现流量激增时,它就起到了很大的作用。 我也考虑过Xeround。尽管对于这种规模的数据库而言,这是非常昂贵的,但这可能是最好的解决方案。无论如何,这不是一个选择,因为我在法律上需要数据库位于欧盟。 我已经阅读了有关Scalr的内容,但不确定是否有帮助以及如何使用。 我已经看到许多云托管提供商都提供了垂直扩展解决方案,我认为停机时间为零(据我所知,他们使用Xen虚拟机管理程序无法确定这是否真的可能)。那可能是一个解决方案,但我想知道它是否没有停机时间,以及MySQL配置(以及操作系统上的许多其他功能)如何能够在没有停机时间的情况下进行升级。 我已经尝试过使用MySQL从属服务器,但这根本没有帮助。 我正在使用memcache,它可以提供很多帮助,但还不够。我需要升级的原因是写入,而不仅仅是读取。 有什么建议么?先感谢您


1
NTP不同步,仅在服务重启时同步
我的ubuntu 11.10服务器在过去的3-4个月里一直很开心地坐在那里,然后突然时间开始不同步了一个小时。我不知道为什么,服务器的配置没有任何变化,我认为这可能取决于系统资源的使用情况。 无论如何要解决这个问题,我发现很多人建议安装NTP和NTP守护程序(ntpd),以便时间可以自动同步。我已经安装了NTPD,它似乎可以工作一天,然后突然停止工作。 当我做了一天之后 ntpq -q 列出连接的对等节点,我得到了错误 ntpq: read: Connection refused 如果我然后尝试重新启动服务 sudo service ntp restart 我收到以下消息 * Stopping NTP server ntpd start-stop-daemon: warning: failed to kill 26915: No such process * Starting NTP server ntpd 一旦我在大约5分钟内完成此操作,时间就会再次同步。如果我再次重新启动服务,我不会收到以上消息,我只会 * Stopping NTP server ntpd * Starting NTP server ntpd 如果我再次尝试ntpq -p我得到 remote …

4
apt-get update mdadm可怕的警告
只需在我的一台专用服务器上运行apt-get更新,然后留下一个相对可怕的警告: Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.26-2-686-bigmem W: mdadm: the array /dev/md/1 with UUID c622dd79:496607cf:c230666b:5103eba0 W: mdadm: is currently active, but it is not listed in mdadm.conf. if W: mdadm: it is needed for boot, then YOUR SYSTEM IS NOW UNBOOTABLE! W: mdadm: please inspect the output of …
8 debian  apt  mdadm  update 



5
哪些反向代理支持HTTP / 1.1 ETag和If-None-Match标头?
我正在为电子商务平台开发一个缓存系统,该系统将使用反向代理进行缓存。我计划通过使用正确的HTTP / 1.1标头来处理无效。也就是说,我将在第一代内容上设置一个ETag,并将该ETag值缓存在应用程序中。Cache-Control标头将指定“必须重新验证”,因此代理应在随后的带有ETag的请求上设置If-None-Match标头。应用程序将查找缓存的ETag值,如果匹配则将发送304响应,否则将生成完整的200响应。 我希望使用nginx,但我不能确定它是否支持ETags(文档表明它不支持ETags,但也许它们已经过时了?)。清漆是另一种选择,但我在这里也不满意。 哪些反向代理服务器完全支持ETag?我希望它实际上可以缓存多个版本,因此我可以执行拆分测试之类的事情而不必禁用缓存。也就是说,HTTP / 1.1指定客户端可以发送具有多个ETag值的If-None-Match,并且服务器应以匹配的ETag响应(如果有)。如果反向代理保留多个副本而不只是最后看到的值,并让服务器在每个要使用的请求上指定,那将是理想的。

6
通过FIFO登录,然后重定向到文件?
我有一个必须记录每个事务的应用程序。每条日志消息都会被刷新,因为我们需要记录导致崩溃的事件。我和我的同事很好奇如何在确保日志消息离开进程的同时实现缓冲的性能效果。 我们想到的是: 创建应用程序可以写入的FIFO,并且 通过重定向该FIFO的内容到常规文件cat。 也就是说,通常是: app --logfile logfile.txt 就是现在: mkfifo logfifo cat logfifo &> logfile.txt & app --logfile logfifo 这种方法有什么陷阱吗?在我们测试它时它可以工作,但是我们要绝对确保即使原始应用程序崩溃了,消息也能找到到达重定向文件的方式。 (我们没有应用程序的源代码,因此,编程解决方案是不可能的。此外,应用程序不会写入stdout,因此直接用管道传输到其他命令syslog是不可能的。因此,这是不可能的) 更新:我添加了赏金。接受的答案将不会涉及logger的原因很简单,logger是不是我所问。正如最初的问题所述,我只在使用FIFO时才发现问题。
8 linux  logging 

3
如何防止用户在OpenVPN中共享证书?
我有一台使用证书和LDAP身份验证的OpenVPN服务器。 问题是,一个用户可以共享他的证书,而其他有效的LDAP用户可以使用此证书。 题 如何确保Bob的证书只能与LDAP用户“ bob”一起使用?
8 linux  openvpn 

3
需要另一个域控制器
在我支持的大多数部门所在的一个站点中,我有两个域控制器(Windows 2003)。我的部门也住着另一座建筑物(位于另一个站点),但是它们没有DC。 这可能是一个经典问题,即当公司分布在多个站点时是否要安装额外的DC。 我们一直在遇到各种问题,例如登录脚本无法映射驱动器以及用户在被允许进入之前多次登录失败(即使他们输入了正确的密码)。 我在客户端上遇到了不同的错误。他们之中有一些是 : Netlogon,5719,由于以下原因,该计算机无法与domain domain.com中的域控制器建立安全会话:当前没有可用于服务登录请求的登录服务器。这可能会导致身份验证问题。确保此计算机已连接到网络。如果问题仍然存在,请与您的域管理员联系。 GroupPolicy,1055,组策略的处理失败。Windows无法解析计算机名称。这可能是由于以下一种或多种原因引起的:a)当前域控制器上的名称解析失败。b)Active Directory复制延迟(在另一个域控制器上创建的帐户尚未复制到当前域控制器)。 在服务器上,我不断收到这些错误: Netlogon,5722,从计算机SOMEPCNAME进行的会话设置未能通过身份验证。安全数据库中引用的帐户的名称为SOMEPCNAME $。发生以下错误:访问被拒绝。 *(以上错误在同一台计算机上不断重复。可能只需要将其重新添加到域中即可。)* NTDS复制,1864,这是本地域控制器上以下目录分区的复制状态。目录分区:CN = Schema,CN = Configuration,DC = domain,DC = com 最后一个看起来与未完全删除的DC有关。当我运行dcdiag时,表明我们正在尝试使用不再存在的服务器进行复制。我认为这不会导致我们遇到所有这些登录问题。 我想知道我们是否应该安装另一个DC或尝试其他方法。我们的客户主要运行Windows 7,但也有一些XP和Vista客户。 在不同站点上的PC之间,带宽看起来为37.4 Mb(已使用此实用程序iperf进行了验证)。 任何帮助表示赞赏。

2
rsync的默认远程Shell是什么?
只是好奇,当您不在守护程序模式下使用rsync时,rsync使用的默认远程shell是什么?根据手册页,它可以通过rsh或ssh运行。但是,手册页中没有任何地方指定如何设置要使用的选项。因此,在运行它时,它会提示我输入密码,但是它似乎并未指示正在使用哪个远程Shell。我知道这可能是一个虚拟的问题,但我确实可以作一些澄清。谢谢!
8 rsync 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.