服务器管理员

系统和网络管理员的问答

4
具有与Intel 82574L千兆位LAN NIC兼容的GUI的OpenBSD / FreeBSD防火墙
我最近购买了一台运行m0n0wall或pfSense的服务器,但是从那以后我才知道这两种防火墙产品都基于FreeBSD的版本,而这些版本尚未与新服务器中的NIC兼容。 我购买的SuperMicro服务器具有双Intel 82574L千兆位LAN NIC,我想找到一种在其上安装某种防火墙的方法,这将通过使用GUI简化防火墙管理。 我知道我可以简单地使用pf,但是既然我们想要一个GUI前端,那么我们有什么选择?我是否需要退回该服务器并找到销售兼容旧硬件的供应商,还是可以使该硬件正常工作?

3
sshd的自定义错误消息
是否可以为拒绝访问服务器的用户设置自定义错误消息?实际上,我只想在由于设置了IP过滤器而拒绝用户时显示此消息sshd_config。但是一条全局错误消息就足够了。
8 ssh  debian  unix 

2
猫* | grep某事…结果在什么文件中?
如果要运行以下命令 cat * | grep DATABASE Shell将吐出*文件中包含单词的所有行DATABASE。有什么办法还可以吐出每行分开的文件吗? 我试着使用-H了grep的选项根据该man说,print the filename for each match但在我的壳它只是说, (standard input):$DATABASE_FUNCTION = dothis();
8 bash  grep  cat 

2
阻止程序在Windows中删除文件?
我有一个可执行程序(没有源代码),该程序在某个文件夹中创建临时文件,然后在最后将其删除。我在程序上遇到了麻烦,想检查一下临时文件,看看是否可以在不更改源代码的情况下做任何事情。 有什么办法可以防止程序删除文件,或者防止所有程序删除某个文件夹中的文件?
8 windows 


1
Python / Django / WSGI / Apache-“ ImportError:没有名为站点的模块”
我正在尝试在本地ubuntu机器上使用django应用程序。但是,该站点无法正常工作,我的站点/var/log/apache2/errors.log充满了如下消息: ImportError: No module named site 我的/var/log/apache2/error.log(今天)看起来像这样: $ cat error.log | uniq -c 1 [Wed Jun 29 09:37:37 2011] [notice] Apache/2.2.17 (Ubuntu) mod_wsgi/3.3 Python/2.7.1+ configured -- resuming normal operations 12966 ImportError: No module named site 那是当我打开机器时它启动的通知,然后有12,966行都显示了该no module named site消息 请注意缺少日期时间字段。即使不访问网站(即即使不提出Web请求),也会重复出现这些错误。在浏览器中访问网站时,它挂起,好像在等待大量下载。 设定值 Apache模块 我正在使用python 2.5 virtualenv,其中包含许多通过pip安装的软件包(包括django 1.1)。我已加载mod_wsgi: $ ls -l /etc/apache2/mods-enabled/wsgi* …

1
Amazon EC2上的JIRA安装
尝试在只有600MB的EC2微型实例上安装JIRA。当我启动tomcat的那一刻,JIRA几乎耗尽了所有现有内存,它非常非常慢,甚至无法完全启动。 有在EC2上安装JIRA的经验吗?我们需要超过1GB的内存吗?我通过电子邮件发送给JIRA技术支持,他们回答说他们没有在亚马逊上安装JIRA的任何经验/知识,因此并没有太大帮助

2
rpm规范:基于发行版的条件需求
我正在尝试为RHEL / CentOS / SL 5和6编写一个rpm规范。该规范适用于python应用程序,因此在构建过程中没有差异。但是在RHEL / CentOS5上,我需要添加一个附加的依赖项。 我如何只为el5定义依赖项?我试过以下: %if 0%{?redhat} == 5 || 0%{?centos} == 5 Requires: kmod-coretemp %endif 不起作用(在CentOS5上构建不会添加kmod-coretemp依赖项)。 我也尝试过以下操作: %if %{?dist} == "el5" 它报告语法错误。我确定dist宏已设置并包含“ el5”。但我不确定if条件转换的语法是什么?rpmguide没有详细的答案。
8 redhat  centos5  rpm 


4
仅当存在合适的文档根目录时才使用VirtualDocumentRoot
我想建立一个可以动态创建Apache虚拟主机而无需重新加载配置的环境。 我可以使用mod_vhost_alias做到这一点,我可以像这样设置默认的虚拟主机 <VirtualHost *> UseCanonicalName Off VirtualDocumentRoot /var/www/sandboxes/domains/%0 ServerName catchall.host </VirtualHost> 效果很好,但是如果请求当前未设置的主机名,则会收到404 Not Found错误。 我真正想做的是仅在文档根目录存在的情况下才启动VirtualHost ,否则请尝试匹配另一个虚拟主机(换句话说,使VirtualDocumentRoot的存在与使用虚拟主机相同) ServerAlias) 我尝试将其作为第二个虚拟主机,而第一个虚拟主机仅处理所有请求,但这没有用-对配置了VirtualDocumentRoot的域的请求落入默认的虚拟主机。 因此,如何动态配置虚拟主机,但对于尚未配置的任何虚拟主机又回退到另一个虚拟主机?

3
查找使用Powershell在Exchange 2010中自动转发/重定向电子邮件的用户
我们使用的是Live @ edu,它实际上是托管的Exchange服务器,具有一些其他功能和可解决的限制,并且我试图找到所有人都在转发或重定向其帐户中的电子邮件。 我正在尝试删除尚未使用的旧帐户,但是我们为用户提供了有关重定向电子邮件的说明,因此我们应该期望某些用户确实在重定向其电子邮件,这将使他们的上次登录/注销时间无法反映出他们是否确实使用自动转发或自动重定向规则。 如何使用Exchange 2010 Powershell Cmdlet查找具有转发或重定向规则的用户列表? /编辑:就我的目的而言,找到是否有任何服务器端规则可能就足够了,无论规则是转发/重定向还是执行其他操作。





By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.