服务器管理员

系统和网络管理员的问答

2
您可以在Azure网站中拥有暂存和生产版位吗
我正在托管3个网站(所有网站都使用相同的链接数据库资源,但是我认为我必须为此在Azure中使用3个网站);www.website.com,provider.website.com和admin.website.com。 使用Windows Azure网站,您可以拥有一个暂存,生产版位吗?我认为此功能仅适用于Azure云服务,但有关此文档很少。如果不可能的话,除了将另外三个站点拆分为临时站点之外,还有其他方法吗? 我希望能够从升级到生产“交换”。
3 azure 

2
ZFS擦洗维修要求/保证的详细信息
我从文档中找不到有关维修工作原理和要求的详细信息。 要通过磨砂膏进行自动维修,需要镜像吗?RAIDZ?可以吗 两者都不(校验和本身是否包含奇偶校验)?
3 zfs 

1
Debian存储库的GPG密钥是否应在其维护者之间共享?
我正在按照本教程设置Debian存储库 https://wiki.debian.org/SettingUpSignedAptRepositoryWithReprepro 该存储库将由我和我的同事管理。我们要对软件包和仓库本身进行签名,因此我需要一个GPG密钥。自然,我不应该使用自己的GPG密钥,否则我的同事将无法管理该存储库。因此,我想到了专门为此存储库创建一个新的GPG密钥,然后与同事共享私钥。 这是由许多人管理回购的正确方法吗?我不喜欢共享私钥的想法(而且我认为对于由很多人管理的存储库来说,扩展规模不大),但是另一方面,我看不到另一种方法可以做到。 我猜有一个简单的解决方案,但是我对这种服务器缺乏经验并没有帮助。 编辑:此处提到共享私钥http://irtfweb.ifa.hawaii.edu/~lockhart/gpg/(最底部的用例2)

4
服务器功率计,220V [关闭]
我想随时间监视服务器的电源使用情况,但是我在220V区域(欧洲),所以我在网上可以找到的所有电压都是110V,就像这里的这样: 杀死功率计 似乎我所能找到的所有东西都配有英国插头,而且我住在克罗地亚-有关此类设备的任何信息-负担得起的价格范围约为20美元。

1
Exchange Web服务导致事务日志增长
我在具有基本身份验证的Exchange 2007上使用EWS。我只调用FindItems()方法,事务日志似乎增长惊人。 在我的测试服务器上,我运行了一个名为FindItems()的无限循环,日志每5-6分钟增长1 MB。在生产环境中,调用它会导致每10-15秒1 MB的增长! 当我仅向EWS发出只读请求时,为什么事务日志会增加?

4
证书如何提高安全性?
我正在尝试获取服务器证书。我说的对吗? 证书绑定到请求者(即客户端),以证明其身份。创建时的证书具有一定的安全性,因此,如果服务器名称更改,则该证书无效。因此,对于SSL证书,不能使用SSL。 这是证书的工作方式吗?如何提高服务器和客户端的安全性?

3
未经授权的电子邮件是使用Google Apps注册域发送的
我已经注册了域名2m.lt并将其添加到Google应用程序。有一个选项可以将所有发送到我的域(*@2m.lt)的电子邮件转发到我的邮件电子邮件帐户(admin@2m.lt)。 好了,一周前,我开始每天收到来自世界各地邮局局长的3至6封电子邮件,说找不到收件人。我看了看邮件,发现有人试图将电子邮件发送到不存在的地址。源地址为:@ 2m.lt 似乎有人在世界各地发送电子邮件,并将“发件人”字段设置为随机生成的帐户,但最后是我的域。我收到的所有这些奇怪的电子邮件仅适用于找不到收件人的情况。我想我的网域中有人收到了很多垃圾邮件。 我已经导出了这些消息,您可以在这里查看它们:http : //6.latest.formytestingaction.appspot.com/ 我已经更改了我的主帐户(admin@2m.lt)密码,但是这些消息仍然继续进入我的邮箱。有什么建议我该怎么办? 我试图在Google Apps论坛中问无济于事。
3 smtp  email 

2
如何解决Redis CPU使用率过高的问题?以及如何限制Redis CPU使用率?
我们继承了一个系统,在该系统中有一个用于排队操作的中央服务器。Redis被选作排队代理。 偶尔(例如每2-3天)redis服务的CPU使用率甚至会超过100%。 我试图阅读日志以查找原因: tail /var/log/redis/redis-server.log 但是它返回空结果。 我发现这篇文章提出了一些建议。但是redis不能回答我的命令。 在这一点上,我仍然坚持如何做以及如何发现问题。另外,有没有办法限制Redis的CPU使用量?
3 redis 

3
有什么方法可以从Linux日志文件中排除特定条目?
具体来说,我试图在Ubuntu Server(强壮的LTS)下保持良好的干净cron.log。除了预安装的4或5个cron作业之外,我还添加了4个自己的作业(使用cron.d方法)。现在,自动安装的作业之一是每小时运行一次的PHP会话到期脚本。 当然,它需要执行,但是坦率地说,我不在乎它何时执行。它每小时运行一次,并输出与下面类似的条目。 Oct 18 02:17:01 cobalt /USR/SBIN/CRON[18160]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly) Oct 18 02:39:01 cobalt /USR/SBIN/CRON[18233]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | xargs -r -0 rm) 由于此操作每隔一小时执行一次,并且产生相对较长的日志条目,因此它占了我的cron.log的90%。如果我翻阅日志文件以确保执行了我的日常备份脚本之类的脚本,则所有这些条目都会将其吞噬。 我有什么办法可以排除此过程的记录? 我意识到我可以使用grep或日志读取器程序进行搜索,但这并不是我真正想要的。我只希望能够“ …

3
在Windows 7上无法访问IIS
我在开发机器(Windows 7 RC)上创建了一个网站,并且能够从http:// localhost /或http://172.16.0.140/(我的IP)或http:// seven /(计算机名)访问它。 我可以从另一台计算机ping我的计算机,但是无法从另一台计算机访问该站点。 “该网页不可用” 你有什么想法吗?
3 iis-7.5 

1
如何使用Nginx前端对SSL客户端证书进行身份验证?
我有一些URL,我喜欢使用apache configs中的以下指令通过ssl客户端证书进行保护: SSLVerifyClient require SSLVerifyDepth 10 SSLRequireSSL SSLOptions +StrictRequire SSLRequire %{REMOTE_ADDR} =~ m/^127\.0\.0\.1$/ \ or ( %{SSL_CIPHER} !~ m/^(EXP|NULL)/ \ and %{SSL_CLIENT_I_DN_CN} eq "xxx" \ and %{SSL_CLIENT_S_DN_Email} in {"xx@xx.com", "xx@xx.com",} ) 似乎没有任何Nginx指令来处理此问题,因此我假设我必须将所有内容都传递给Apache后端。 这给我带来了一个问题,如何通过加密的SSL?在将它们传递给Apache之前,所有代理都在nginx级别解密ssl数据包。


2
iptables -i lo与-s localhost和-j REJECT与-P INPUT REJECT
前言 就像Linux中的所有内容一样,我敢肯定,有很多方法可以达到预期的效果iptables。我想将答案限于以下类别: 选项之间有什么区别? 哪个选项最好(或者它们相同)? 为什么您偏爱另一个? 并且请明确说明您要讲的类别。陈述偏好是可以的,但是并不意味着最好。 例如 我更喜欢将其--jump作为第一个参数,因为我认为将意图放在首位会更好,而且我喜欢像多个命令的参数一样垂直对齐。 题 其中一个比另一个更好吗? iptables -I INPUT --jump ACCEPT --in-interface lo iptables -I INPUT --jump ACCEPT --source localhost 其中一个比另一个更好吗? iptables -A INPUT --jump REJECT iptables -P INPUT REJECT

2
在无法创建/管理分区的设备上设置ZFS池的方法?
我有一个NAS(带有DSM 5.0的Synology DS214),无法创建和管理分区(也许我可以进行一些我不想做的黑客操作)。存在哪些方法来设置每个分区一个的多个ZFS池(对于初学者-仅想使用重复数据删除)?该设置应与NAS配合使用,即通过网络(我将通过NFS或CIF挂载映像)。 到目前为止,我的想法和相关问题: 通过循环设备安装的稀疏文件(将稀疏文件直接指定为ZFS vdev不起作用,请参见我可以为zfs池选择稀疏文件作为vdev吗?):问题是分配的循环设备的名称/编号不是常数,不知道增加带有内核参数的数字循环设备会如何影响性能(有理由将其默认值限制为8,对吗?) 如果存储数据的设备仅用于(以错误的形式)以字节形式保存文件中的数据,而其他所有内容均由另一台设备管理(如果无法创建分区,则是必需的),则必须将所有数据保存到ZFS系统或池也需要在设备上运行(至少池的名称和附加的vdev的列表),以使池在控制设备的故障中幸免。与ZFS相关的数据必须在外部备份。如何告诉ZFS在哪里存储其数据?我猜想,挂载目录(/etc/zfs等等)比告诉ZFS在创建池时将数据保存在何处更糟糕。

4
在Cloudflare级别终止SSL。我可以获得性能提升吗?
我在帖子中看到,由于仅在边缘协商SSL,因此在Cloudflare级别终止SSL且仅HTTP从Cloudflare到源的流量可以提高性能。 我经营的网站(通常是静态的)的安全性不是一个偏执的问题。 是否值得关闭我的letencrypt证书以使用Cloudflare提供的“灵活证书”,以避免边缘和源之间的昂贵往返费用? 编辑: 我关注的不是CPU(原始机器)。更重要的是,我是否可以加快边缘和原点之间的距离。

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.