服务器管理员

系统和网络管理员的问答

1
在AWS RDS上导入Mysql DB转储时出错
我从一台RDS服务器上提取了Mysql数据库转储,并试图在另一台RDS服务器上进行还原。在导入完整的数据库时,我遇到了以下错误。 ERROR 1419 (HY000) at line 2447: You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable) 之后,我将参数更改为1,然后重新启动服务器。 我再次尝试导入转储,但出现以下错误。 ERROR 1227 (42000) at line 2447: Access denied; you need (at least one of) the SUPER privilege(s) for this …

2
远程Powershell注册表命令拒绝SQL Server代理访问
我在执行SQL Server代理作业步骤期间无法执行Powershell脚本。我的powershell命令基本上连接到远程计算机(在同一域内),以将单个值写入注册表。从SQL机器,我能够成功地在本地(从Powershell ISE界面)手动运行Powershell脚本,因此我知道它可以工作。问题出在远程服务器上SQL Server代理的权限中,但我在此方面一无所知。 如果我使用根计算机“。”,则此Powershell命令将在我的SQL Agent Job步骤中工作。 # Access the DBQ registry setting for pausing $HKLM = 2147483650 #HKEY_LOCAL_MACHINE $reg = [wmiclass]'\\.\root\default:StdRegprov' $key = "SOFTWARE\MySoftwareApplication" $name = "PauseModule" $value = "1" $reg.SetStringValue($HKLM, $key, $name, $value) 我的问题是当我像这样指定远程目标计算机时出现异常: $reg = [wmiclass]'\\XXX.XX.XXX.XXX\root\default:StdRegprov' 这是例外: 以用户身份执行:DB-MAIN \ SYSTEM。作业步骤在PowerShell脚本的第4行收到错误。对应的行是'$ reg = [wmiclass]'\ XXX.XX.XXX.XXX \ root \ …

1
Bacula:写入备份失败
我根据此方法在Cent OS 7上安装了bacula 7:http : //www.backupcentral.com/phpBB2/two-way-mirrors-of-external-mailing-lists-3/bacula-25/howto-install-bacula -7-centos-7-fresh-install-126395 /。 现在我想备份一台服务器,但工作停滞了is waiting for a mount request。 导演显示以下消息: 31-Dez 15:42 bacula-sd JobId 6: Warning: label.c:362 Open file device "FileStorage" (/var/bacula/backups) Volume "Remote-0002" failed: ERR=file_dev.c:172 Could not open(/var/bacula/backups/Remote-0002,CREATE_READ_WRITE,0640): ERR=Keine Berechtigung 31-Dez 15:42 bacula-sd JobId 6: Warning: label.c:362 Open file device "FileStorage" (/var/bacula/backups) Volume "Remote-0002" …

3
什么设备/系统用作“棒上的路由器”
我需要创建几个不同的VLAN,并提供一种使流量在它们之间移动的方法。“坚持使用路由器”方法似乎很理想: 互联网 | 具有中继功能的路由器(“棒上的路由器”) * *路由器与交换机之间的中继 * 具有中继功能的交换机 | | | | | | | | | | | 局域网2 | 局域网4 | | 10.0.2.0/24 | 10.0.4.0/24 | | | | 局域网1局域网3局域网5 10.0.1.0/24 10.0.3.0/24 10.0.5.0/24 我们有支持中继的第2层交换机。问题是用什么作为棍子上的路由器。我的选择似乎是: 使用现有的Cisco 5505 ASA防火墙。看起来ASA可以执行路由,但它是100Mbps的设备,因此看起来充其量不是最佳选择 购买路由器。这似乎太过分了。 购买三层交换机。也显得矫kill过正。 使用现有的共享Linux Box作为路由器(例如NIS服务器) 使用专用的Linux盒作为路由器 我没想到的事 我认为(4)或(5)是我最好的选择,但是我不确定如何在它们之间进行选择。我预计必须通过VLAN的流量会很小,但会突然增加。路由给CentOS计算机增加了多少负载?
1 routing  vlan 

1
如何解决错误:“ ssh_exchange_identification:连接被远程主机关闭”
错误: ssh_exchange_identification:连接被远程主机关闭 有许多建议的解决方案,但似乎没有一个能解决我的问题。 这是我要完成的工作: 我上面有一个服务器(10.0.0.5)SSH。该服务器具有以下用户及其外壳程序: passport , shell=/bin/false user1, shell=git-shell user2, shell=git-shell me, shell=bash 该sshd_config文件,在末端输入以下内容: AllowTcpForwarding no Match User passport,user1,user2 AllowTcpForwarding true PermitOpen 10.0.0.5:8080 PermitOpen 10.0.0.5:22 我还启用了公共密钥身份验证。目标是禁用来自SSH的所有tcp转发,并且仅允许上述用户在两个端口上进行转发: - SSH - a web server 在我/etc/hosts.allow和.deny文件中,没有任何条目。 我在中设置了适当的authorized_keys file(只是ssh-rsa ...)/home/passport/.ssh/authorized_keys。 在Windows计算机上,尝试使用SSH: ssh passport@10.0.0.5 -N -L 22:10.0.0.5:22 -L 8080:10.0.0.5:8080 当“我尝试浏览”时,这可以正常工作,http://127.0.0.1:8080这意味着我的端口转发可以正常工作。 现在,我想尝试通过该隧道进行SSH并使用“ user1”: ssh -N …

1
强制快速停止IIS 7.5或应用程序池
我们有一个繁忙的网络服务器,每秒处理大约1000个asp.net请求。 我们有一个部署脚本,可以从开发框中复制编译的asp.net。 该脚本首先在生产服务器上停止IIS,复制代码,然后重新启动。 我们使用以下命令来停止该站点的应用程序池: %windir%\ system32 \ inetsrv \ appcmd停止apppool /apppool.name:ourappname 问题在于,这将停止接受新请求,但会等待现有请求完成。通常,少数几个请求最多需要一分钟才能完成,在此期间不提供任何新请求。因此,为了满足十几个请求,我们错过了等待大约12-20分钟的那一分钟左右收到的1000 * 60 = 60,000个请求。真傻 我们希望做的是在x秒内强制停止应用程序池。这似乎不可能。有没有更好的方法来完成我们正在做的事情,即iis 7的快速停止?
1 iis-7 

2
Google Cloud Platform上的Magento VM实例不允许上传任何文件
决定通过启动一键式Magento安装来尝试使用Google Cloud Launcher。一切运行顺利,并且确实启动并运行,但是我遇到了一个明显的错误,使整个事情变得毫无用处-我无法上传任何内容。 我尝试通过Magento后端方法上传,方法是进入静态块并单击“插入图像”按钮,并收到以下错误:该目录不可被服务器写入。 经过数小时的SFTP访问故障排除后,我终于通过FileZilla使它工作,只是遇到类似的错误:错误:[文件路径]:可以写:权限被拒绝错误:文件传输失败 我不确定使用Wordpress和其他平台是否会遇到类似问题,但我只是想提醒一下,看看是否有人提出了解决方案。另一个奇怪的事情是,如果您添加产品,则可以在那里上传图像。
1 cloud  google  magento 

1
如何在sql2008中更改SQL Server Reporting Services日志文件的位置?
我尝试通过使用以下步骤来更改SQL Server日志文件的位置,但由于我无法在两个Web配置文件中找到RTrace,因此它不起作用。 您需要修改三个文件来更改Reporting Services日志文件的位置。这些文件是: ·c:\ Program Files \ Microsoft SQL Server \ Reporting Services \ ReportManager \ web.config ·c:\ Program Files \ Microsoft SQL Server \ Reporting Services \ ReportServer \ web.config ·c:\ Program Files \ Microsoft SQL Server \ Reporting Services \ ReportServer \ Bin \ ReportingServicesService.exe.config 在上述所有文件的RSTrace下添加以下标签: 您的帮助将不胜感激。

2
插件“ InnoDB”注册为存储引擎失败。获胜7
我不得不重新安装MySQL,但是该服务无法从evnt viewer中列出的上述原因开始。 一个解决方案显然是删除几个前缀为“ ib_logfile”的文件,这些文件代表任何旧数据库。但是,我没有这些文件,并且我的服务仍无法启动...?当我说我没有这些文件时,我使用Windows搜索进行了搜索,结果为零,它们肯定不在我的mysql安装目录中。而且我没有链接中引用的“文档和设置/应用数据”文件夹。 实际上,我只有一个mysql安装目录,我知道它在哪里-我需要删除/更改什么?实例配置正确,我以管理员身份运行该实例,并在服务中列出了该实例,但是该服务本身无法启动 除了转向postgresql之外,还有其他提示吗?

1
MySQL错误:1067
当我尝试启动MySQL服务器服务时,出现错误: “无法在本地计算机上启动MySQL服务器,错误1067:进程意外终止” 我需要解决此问题而不必卸载MySQL服务器。有办法吗?
1 mysql 

1
启用IPTables后,局域网上的MySQL无法正常工作
我有两个Centos VM。 IP地址如下: VM_1 => 10.99.0.10 VM_2 => 10.99.0.12 Apache和PHP在VM_1中,而MySQL在VM_2中。两者都有iptables规则。VM_2使用规则正常。现在,我正在从VM_1进行测试。 首先,我禁用了 VM_1 iptables并连接到VM_2 MySQL(已成功连接)。 [root@foster ~]# service iptables stop iptables: Applying firewall rules: [ OK ] [root@foster ~]# mysql -h 10.99.0.12 -u root -p Enter password: Welcome to the MySQL monitor. Commands end with ; or \g. Your MySQL connection …

1
如何将DSQuery脚本添加到Excel?
我必须用家庭用户号码等更新AD。我已经编写了脚本并将用户名和电话号码导入Excel 脚本: dsquery user -samid "username" "OU=Sys,OU=Prod Services,DC=win,DC=ite,DC=com" | dsmod user -mobile "999" -hometel -u XXXXXX -p XXXXXXXXX 在Excel中:A1 =用户名B1 =编号 如何使上面的脚本起作用,以便它从Excel中获取用户名和数字并将其放入批处理文件中?

1
通过外部服务器路由SOAP请求
我需要与SOAP Web Service集成,该Web Service要求请求来自白名单的IP地址。 因为我经常在各地进行开发,所以每次都要求一个新的列入白名单的IP是很烦人的。 我有一个列入白名单的远程服务器。如何将SOAP请求(可以更改WSDL中的端点)路由到我的远程计算机,并将其转发到Web服务? 我的远程服务器用于其他用途,因此只需要转发特定的端口,而不需要转发所有流量。 哦,Web服务需要SSL。
1 proxy 

1
MikroTik无线网桥-负载不佳
一名技术人员在两座房屋之间架起了无线网桥,但我在负载下ping时遇到问题。 我在服务器/克林特模式下有两个MikroTik RB / SXTG设备。他们互相看见(没有障碍物),距离仅约20米。问题在于,负载下的ping需要数百毫秒的时间。 我已经尝试更新版本6.24并重新启动。我试过也将频率更改为自动,这似乎还不错。任何想法? 查看带有配置的屏幕截图。


By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.