服务器管理员

系统和网络管理员的问答

4
我应该选择网络托管公司还是继续搜索?
我一直在寻找一家优秀的网站托管公司,该公司可以为我提供托管基于PHP和MySQL的网站所需的所有服务。现在,这是一个基于社区的网站,用户将可以上传图片等。我想到的托管公司目前允许我执行所有操作...让我使用mail(),支持CRON作业等。他们的收费约为每月6美元。现在,这家公司的唯一问题是,托管帐户中随时可以存在50,000个文件限制。这种情况与他们网站上的首页广告“ UNLIMITED SPACE”相矛盾。除此之外,我不知道我为什么不应该选择这家托管公司。 但是我的问题是,一旦用户数量增加并且他们上传的文件数量超过50,000,我就无法忍受50,000个文件限制。现在,由于这是一个动态的网站,并且还包含付款等敏感问题。我不确定是否应该继续经营这家​​公司,因为我刚刚开始工作,后来又转到了一家不受限制的更好的托管公司50,000个文件。如果我在与该公司托管后需要切换,则需要备份帐户中所有文件(jpg,zip等)的备份,然后将其上传到新主机。我不知道有什么工具可以帮助我。你能说出你是否知道吗? 我现在可以继续与其他公司合作,但是它们的成本是当前价格的两倍/三倍,而且它们都具有比我目前选择的功能少的功能。如果我支付更多,那么他们就可以满足我的更高要求。不幸的是,我现在愿意与之合作的公司没有我可以切换到的其他更高/更好的计划。这就是真正非常糟糕的部分。 所以我的问题是: 由于我是从网站开始的,并且最初的用户范围会变小/变小,因此,我应该继续选择当前的选择,然后在需求增加后,改用更好的提供商吗?如果是,我如何将数据库(尤其是jpg文件等)传输到新的提供程序?我什至不知道备份和还原到另一台主机所需的工具。 (我不喜欢这个主意,但仍然..)我现在应该继续支付更多的钱,并与更好的提供商一起去(不知道网站是否真的能做得很好),只是为了节省自己的麻烦备份50,000个文件,然后从旧主机上载到新主机,然后开始支付两倍/三倍的价格,甚至不知道我是否会按预期收到退货? 如此庞大的备份和还原是我以前从未做过的事情,因此我被困在这里,试图决定要做什么。每月的价格也是我决定的一个重要因素。 所有这些网络托管公司都说一件事:备份和还原数据是客户的责任,他们不承担任何损失。因此,无论我想与哪个托管公司合作,他们都要求我通过FTP进行备份,以便我可以随时恢复它们(而且将文件放在本地似乎更安全)。有些提供备份工具,有些则不能,考虑到它们的免责声明,我不确定他们的备份工具可以信任多少。我从未将50,000个文件从一台虚拟主机备份和还原到另一台虚拟主机,因此,请所有经验丰富的人在那里,留下您的评论,让我知道您的建议,以便我决定。 我花了两天时间与自己搏斗,试图决定该怎么做,最后得出结论,这是一把双刃剑,如果没有其他建议,我就无法做出令人满意的最终决定。我相信必须有人在那里做出如此麻烦的决定。因此,感谢您提出的所有建议,以帮助我做出决定。 谢谢你们。 编辑: 我感谢所有答复,但是到目前为止,我还没有收到任何有关文件备份和还原工具的答复。有人真的有机会备份和还原其虚拟主机帐户中的文件吗?如果是,请提及这些工具及其相关的网站链接,以便我进行检查。谢谢!!!

1
将DNS重定向到另一个DNS服务器
我正在使用Windows Server 2012,在我的工作场所中,我已经在域控制器中完成DNS服务器的设置。因为我使用的是虚拟桌面。 问题是,当我想在该计算机上使用Internet时,当我将网络中的其余计算机配置为使用我自己的DNS服务器以加入我自己的域时(例如,我用作DNS服务器192.168.1.70) ,因为我的DNS服务器无法解析其他域,所以不能。 那么有什么方法可以扩展8.8.8.8 DNS服务器,或者如果我的服务器无法解析主机名,可以将其委托给另一台DNS服务器?

1
来自移动设备的网络错误数据的可靠性如何?
我们刚刚开始为我们的iOS应用程序使用New Relic mobile,并且看到网络错误间歇性地激增。错误列表包含一些自我解释的错误(未连接到互联网,超时,连接丢失)。现在,我将这归结为网络运营商的移动互联网性能(或缺乏)。列表中较难解释的一个是找不到主机。如果互联网服务不可靠,设备会遇到此错误吗?在这些高峰期间,我们的台式机网站(在同一服务器上)没有出现任何相同的错误。总的来说,我想知道来自移动设备的网络错误数据在连接不太可靠时的可靠性如何。

1
Google Cloud VPC子网连接
我们在VPC Network网络的子网subA内有一个Google管理的Kubernetes集群,然后在该VPC的一部分中还有一个子网SubB不同的区域。Kubernetes集群启用了VPC别名,因此服务范围和Pod范围实际上也是VPC的子网(相同的本地空间10.0.0.0/8)。 我们希望提供一个托管在subA上并且可由subB访问的kubernetes服务(带有内部负载均衡器)。我们已经设法通过防火墙规则使subA和subB上的实例彼此可达,但是这些实例仅针对网络(不是子网),服务帐户或标签,因此不能用于负载均衡器。 有什么线索吗?

1
类似链接任务的最佳实践?
我正在为小型办公室设置服务器,可以从Internet访问该服务器。由于我们的ISP具有透明的代理,因此大多数动态dns服务都会失败,而不是dyndns(不是我们的提供商),因此我们使用脚本对其进行手动设置-它连接到dyndns,获取包含信息的网页,剥离ip地址输出,并通过网络请求为我们的实际dns提供商设置单个域的ip地址。整个过程由crontab每小时运行一次 如果我想将此扩展到多个主机名,最好是每个主机名运行一个脚本(即,用于获取ip地址的单个脚本,每个主机名运行一个脚本),或者为该主机具有一个整体任务整件事?

2
NAS存储问题
我在Buffalo NAS上运行一个小程序,一些用户正在通过网络共享访问该程序。最近,该程序开始经常崩溃,并在用户对其进行处理时将其踢出去。我的问题:并发用户是否通过NAS上的网络共享访问同一文件会影响程序稳定性,还是NAS不支持更多用户使用不同的登录名访问同一共享?

2
VNC查看器为一个用户显示黑屏,为另一用户显示正常
我在CentOS 7上安装了TigerVNC,并为两个用户(user1和user2)配置了它的服务。直到最近,它一直运行良好。当我尝试使用user1与VNC Viewer连接时,它仅显示黑屏,而对于user2,一切都很好。每个端口都打开。 PS我主要使用过user1,我正在使用一些apache配置,而当我重新启动服务器时,它发生了。 先感谢您。 cat /etc/sysconfig/vncservers 显示此输出: THIS FILE HAS BEEN REPLACED BY /lib/systemd/system/vncserver@.service 同时cat /lib/systemd/system/vncserver@.service显示了这一点: [Unit] Description=Remote desktop service (VNC) After=syslog.target network.target [Service] Type=forking ExecStartPre=/bin/sh -c '/usr/bin/vncserver -kill %i > /dev/null 2>&1 || :' ExecStart=/usr/sbin/runuser -l <USER> -c "/usr/bin/vncserver %i" PIDFile=/home/<USER>/.vnc/%H%i.pid ExecStop=/bin/sh -c '/usr/bin/vncserver -kill %i > /dev/null …

1
无法以普通Linux用户身份运行Java
我在尝试在Linux上以普通用户身份运行Java时遇到问题。它可以以root用户身份运行,但不能以普通用户身份运行。 任何帮助将不胜感激。 谢谢 root @ pro1 [〜]#哪个java / usr / local / jdk / bin / java root @ pro1 [〜]#java -version Java版本“ 1.6.0_22” Java(TM)SE运行时环境(内部版本1.6.0_22-b04) Java HotSpot(TM)64位服务器VM(内部版本17.1-b03,混合模式) root @ pro1 [〜]#su istream istream @ xxxxxxxxx [/ root]#其中java / usr / local / jdk / bin / java istream @ xxxxxxxxx …
java 


2
有人似乎正在重定向到我的网站
我正在玩一个新的启动概念。我已经构建了一个节点应用程序,并在www上弹出了它的受限访问版本。我最近注意到,似乎有人复制了它,或者使用自己的域将其重定向到了它。 我不确定我能做什么,或者他们这样做的目的是什么。 我的网域:http : //mycalories.ca 他们的域名:http : //xmit.io 我查了他们,看来这是与美国一家公司相关的合法域名: Domain : xmit.io Status : Live Expiry : 2016-02-27 NS 1 : dns1.p04.nsone.net NS 2 : dns2.p04.nsone.net NS 3 : dns3.p04.nsone.net NS 4 : dns4.p04.nsone.net Owner : Jeffrey Arnold Owner : PhotoShelter, Inc. Owner : 33 Union Square West FL2 Owner …

2
如何保持用户会话活动
在Windows Server 2003上,如何设置一个用户的远程桌面连接永不过期? 我试过:NET USER / expires:never 但这不起作用,如果我关闭了远程桌面连接,然后再次尝试连接,则会再次出现用户名和密码提示。


2
缓解200A防火墙CPU高资源使用率
今天早上,我收到了一些最终用户的抱怨,这些抱怨说他们的整个部门网络都很慢并且断断续续。 因此,我检查了防火墙以查看设备是否有问题。根据我在FortiGate仪表盘状态中的观察,CPU资源非常高(99%)。我的第一个假设是清除日志,因为在警报日志中,Fortigate日志中提到该日志已满90%。根据我的理解,可以通过重新启动防火墙来清除日志。 重新启动防火墙后,网络似乎还可以,但是几分钟后它又重新启动。这种情况一直持续到现在。 有人可以告诉我还有什么地方可以解决此问题吗?我真的很感谢我能在这里提供的任何帮助。 编辑: diag sys top命令

1
鱿鱼不缓存任何东西
我正在尝试设置鱿鱼以缓存我的程序之一的下载,但不幸的是,我发现自己没有缓存任何内容,日志如下所示: 1414421675.540 1059 127.0.0.1 TCP_MISS/204 288 GET http://serverfault.com/posts/596890/ivc/d85b? - DIRECT/198.252.206.16 - 1414421676.548 769 127.0.0.1 TCP_MISS/200 1539 GET http://careers.stackoverflow.com/gethired/js - DIRECT/198.252.206.17 text/javascript 1414421677.226 674 127.0.0.1 TCP_MISS/204 442 GET http://careers.stackoverflow.com/ad/i/o8dlwjVTTd7-lrgGzmMcoFk-2LAw8 - DIRECT/198.252.206.17 image/gif 1414421685.217 48 127.0.0.1 TCP_MISS/200 4345 GET http://audaupdate.audatex.cz/SEARCH_TREE/ - DIRECT/93.189.233.60 text/html 1414421685.273 44 127.0.0.1 TCP_MISS/200 1407 GET http://audaupdate.audatex.cz/SEARCH_TREE/INDEX.DEF - DIRECT/93.189.233.60 …
squid 

1
DNS:域到子域
我希望尽可能使用DNS将mydomain.com和* .mydomain.com重定向到sub.domain.com。这都是相同的域。 以便: www.domain.com -> sub.mydomain.com mydomain.com -> sub.mydomain.com anything.mydomain.com -> sub.mydomain.com

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.