我总是很难确定是否应该以getSomething
vs 开头的某个方法findSomething
。
问题在于为设计不当的API 创建帮助程序。当从对象获取数据时通常会发生这种情况,这需要对象作为参数。这是一个简单的示例:
public String getRevision(Item item) {
service.load(item, "revision");
// there is usually more work to do before getting the data..
try {
return item.get_revision();
}
catch(NotLoadedException exception) {
log.error("Property named 'property_name' was not loaded", exception);
}
return null;
}
如何以及为什么要在将此方法命名为getRevision()
or时做出决定findRevision()
?