服务器管理员

系统和网络管理员的问答

5
如何找到本地用户帐户的创建日期?
我想获取本地用户帐户的创建日期(如果重要,请赢7)。我看过以下WMI对象(当然还有Google): Win32_UserAccount Win32_NetworkLoginProfile 从中返回的对象NetworkLoginProfile具有最后的登录时间,但没有创建日期。检查Date Created他们的个人资料文件夹的属性仅仅给出了日期的文件夹的创建,不一定帐户本身。

4
在Server 2012R2上安装KB2919355后出现Inaccessible_boot_device
我有一台刚刚安装KB2919355的服务器2012r2计算机(最近为Windows 8.1和Server 2012发布的mega 800 + MB补丁)。服务器是Dell Poweredge R715。磁盘是H200控制器上RAID1中的2x500GB SAS。 在更新之前,服务器一直运行良好-并且我已经安装了Dell管理工具,因此我知道不会出现磁盘警报失败或其他问题。在升级H200控制器固件的前一天,但是此后系统重新启动,没有任何问题。 重新启动更新后,它出现在黑屏上,并且带有可移动的鼠标光标,但没有其他任何操作-Ctrl-Shift-Esc和Ctrl-Alt-Del不起作用。让它坐在那里一个小时以上,什么都没有改变。 用“不要在BSOD上自动重启”选项启动,并得到INACCESSIBLE_BOOT_DEVICE错误原因。奇怪的是,它说:“我们只是收集一些错误信息,然后您可以重新启动。(0%完成)”,并保持为0%,从未取得任何进展。 尝试使用相同的BSOD重新启动。 重新启动进入“修复我的电脑”的工作原理。在命令提示符下,我可以看到所有分区和所有文件都完整无缺。chkdsk报告没有错误。 此后,服务器设法正常启动一次。重新启动后,即使反复尝试启动,它也从未恢复过,它们都以INACCESSIBLE_BOOT_DEVICE蓝屏结尾。 问题似乎与LSI RAID控制卡有关。有在具有与超微机类似问题的TechNet报告其他线程- http://social.technet.microsoft.com/Forums/en-US/6bf5815f-55d9-4403-8f41-a16ebcb83735/patch-kb2919355-makes- supermicro-machines-crash?forum = winserver8setup 我有一个有关戴尔的支持案例,戴尔正在他们的实验室中尝试复制此问题。在这里可能没有其他任何人可以做。 更新资料 根据戴尔的建议,我擦除了系统,并重新安装了带有GUI的Server 2012R2 Datacenter。除了安装Windows Update,我什么都没做。 安装KB2919355后,服务器正确重新启动。再次重新启动后,它蓝屏并显示INACCESSIBLE_BOOT_DEVICE错误。 我强烈建议您在解决此问题之前,不要在具有基于LSI的RAID卡的任何服务器上安装此更新。希望戴尔能够迅速提出解决方案。 来自戴尔支持的更新 这是我们现在正在大规模研究的一个问题,因为它不仅比戴尔更普及,最有可能必须由微软解决。我们将继续努力直到我们的资源用尽。我会及时通知您我们的发现。 戴尔支持的另一项更新 戴尔无法在他们的实验室中复制此问题。我已经确认我的系统中有2个存在相同的问题,并且重现很容易-安装Windows,安装更新,直到得到KB2919355,服务器在安装更新后的第二次重新启动时死掉。 他们目前正在为我建造一台交换机,以便与其中的一台交换,因此他们要测试一台损坏的机器。希望这可以帮助他们快速解决问题。

2
IIS httpErrors ExecuteURL将奇怪的查询字符串(如500; http://mysite.com/failed-page)附加到目标URL
我注意到IIS错误页面中的行为异常。我有这个设置: <httpErrors errorMode="Custom" existingResponse="Replace"> <remove statusCode="500" /> <error statusCode="500" responseMode="ExecuteURL" path="/error-page" /> </httpErrors> 有时,由于查询字符串太长而导致ASP.NET错误发生时,在尝试执行错误页面URL时立即发生第二个错误。我已经将问题跟踪到IIS将原始URL附加到错误页面URL的事实: Original: http://example.com/someurl?id=some_very_long_query_string_causing_security_exception Error: /error-page?500;http://example.com/someurl?id=some_very_long_query_string_causing_security_exception 这是一个巨大的问题。如果原始网址由于查询字符串过长而失败,则带有附加内容的错误页面也会失败,因为它的查询字符串甚至更长! 我相信这是IIS中最愚蠢的错误。有谁知道是否有一些补丁包?最糟糕的情况是,如果现在没有任何解决办法,是否有办法禁用此行为或任何技巧来阻止IIS将未经请求的内容附加到错误页面?因为它破坏了整个自定义错误页面机制。
8 iis  iis-7.5 

3
svchost.exe -k netsvcs占用> 1GB内存
我注意到我的生产服务器“ svchost.exe -k netsvcs”稳定地占用了超过1GB的ram内存,我认为这有点多余。 这是任务列表/ svc将为我提供的过程: Appinfo, CertPropSvc, gpsvc, IKEEXT, iphlpsvc, LanmanServer, ProfSvc, Schedule, SENS, SessionEnv, ShellHWDetection, Winmgmt, wuauserv 我想知道列出的可能是导致此内存泄漏的过程以及如何解决的过程。过去有人有过这种行为吗? 服务器正在运行Windows Server 2008 R2(内部版本7601:Service Pack 1),其主要功能是运行内部应用程序处理器工作程序。

3
重命名Azure上的虚拟网络
是否可以重命名Azure上的现有虚拟网络?例如,通过powershell。 我在门户网站UI中看不到任何选项,并且已经在现有网络中设置了可观的部署。
8 azure 

1
如何接受使用Powershell通过SCCM部署的软件更新的EULA
我正在尝试使用Start-CMSoftwareUpdateDeploymentcmdlet将软件更新组部署到现有集合。 PS WHO:\> Start-CMSoftwareUpdateDeployment -SoftwareUpdateGroupName "Update Group - Microsoft Updates" -CollectionName ` Eval_OSUpdates -DeploymentType Required -SendWakeUpPacket $true -AllowRestart $true -PersistOnWriteFilterDevice $true ` -DownloadFromMicrosoftUpdate $true -DeploymentName "Evaluation Deployment - Update Group - Microsoft Updates" ` -UserNotification DisplayAll -RestartWorkstation $false -AllowUseMeteredNetwork $true 给出了所有必需的参数,但是我在执行时收到以下错误: Start-CMSoftwareUpdateDeployment : ConfigMgr Error Object: instance of SMS_ExtendedStatus { …

3
将HTTP连接升级到SSL / TLS
我目前有一个服务器,该服务器会自动将所有HTTP请求重定向到等效的HTTPS站点。问题在于,似乎某些浏览器不接受SSL证书(StartSSL.com)或不支持SNI,因此它们会收到证书警告,并且用户将不会继续在网站上浏览。 是否有任何机制尝试使浏览器使用HTTPS而不是纯HTTP,并且在该机制不起作用时(例如,不接受证书或不支持SNI),它将继续使用HTTP。 目前,我正在将Apache 2.4与多个虚拟主机一起使用,这些虚拟主机都使用重定向HTTP连接Redirect / https://domain.example/。

2
大文件上传的ColdFusion设置
我正在尝试设置一个Coldfusion服务器来接受大文件的上传,并且遇到了一些限制。到目前为止,这是我观察到的内容: ColdFusion Administrator中有两个限制上传大小的设置:“发布数据的最大大小”和“请求限制内存”。如果您上载的大小(包括HTTP开销)大于这些设置之一,则上载将被拒绝。我不知道为什么我们需要其中两个。据我所知,较高的那一个都没有任何作用。较低的获胜。 当有人尝试上传太大的文件时,他们不会收到很好的错误消息。发送大约1个TCP窗口值的数据后,上传将永远停止。它以非常糟糕的方式挂起。即使在客户端放弃并断开连接之后,相关的apache线程仍然被占用(我可以使用mod_status看到它)。卡住的线程只会不断增加,直到没有剩余的线程可以接收新请求并且必须重新启动服务器为止。 “请求节流”是我真的不明白的事情。关于它的所有文档都将其称为存储区域的大小。如果是这样,那么我看不到它与文件大小的关系。它暗示了我只是不想相信的事情:ColdFusion将整个上传的文件先将其吸收到内存中,然后再将任何文件写入磁盘。当上载循环(读取中等大小的块,将其写入磁盘,重复直到完成)如此简单时,没有理智的人会这样做。(我知道HTTP multipart / form-data帖子的结构使它变得有点难,但是……肯定有像Adobe这样的具有Web开发产品的大公司可以做到这一点……是吗?) 如果实际上是在进行全文件限制,那么他们如何期望我们选择可行的大小限制?允许1 GB的存储空间,同时有几个用户甚至可以尝试在没有内存的情况下运行服务器。而什么是我们要做的事情,不是让技嘉上传?人们可以发布视频,而没有时间进行编辑! 附加信息 这是一些版本号。 网络服务器: Server: Apache/2.2.24 (Win64) mod_jk/1.2.32 ColdFusion: Server Product ColdFusion Version ColdFusion 10,285437 Tomcat Version 7.0.23.0 Edition Enterprise Operating System Windows Server 2008 R2 OS Version 6.1 Update Level /E:/ColdFusion10/cfusion/lib/updates/chf10000011.jar Adobe Driver Version 4.1 (Build 0001) 附加信息#2 我不知道您为什么想知道我在限制字段中输入了哪些值,但是一段时间后它们都被设置为200 MB。我将“发布数据的最大大小”增加到2000 …

3
如何为git等工作负载获得良好的NFS性能?
我vagrant为运行OSX的开发人员管理设置,以管理VirtualBox系统进行开发。 为了inotify在Linux机器内部提供支持,我们避开了与VirtualBox共享目录的常用方法:相反,Virtualbox机器公开了一个NFS共享,该共享安装在OSX中。 Git(以及诸如sourcetree之类的相关工具)在OSX的共享目录中运行。这种方法的性能极差:运行通常需要5秒钟git status。将小型存储库克隆到已安装的NFS驱动器中可能需要花费几分钟(在本地驱动器上需要5-10秒)。 显然,NFS性能要比直接写入本地SSD差,但是NFS只是通过Virtualbox在虚拟专用网络接口上运行。 我运行了几个基准测试。首先: dd if=/dev/zero of=test bs=16 count=16384 每个结果均基于100个样本。 # local drive Min. 1st Qu. Median Mean 3rd Qu. Max. 0.990 1.000 1.020 1.021 1.030 1.130 # on the shared NFS drive Min. 1st Qu. Median Mean 3rd Qu. Max. 6.000 6.278 6.390 6.482 6.570 7.630 # …

1
子域的DKIM和SPF
我在通过subdomain.example.com访问的Linode上管理VPS,我需要从该子域发送电子邮件。我无法在Linode DNS管理器中设置任何TXT记录,因为example.com的名称服务器是其他名称服务器,而不是ns1.linode.com等。因此,我需要请有权访问example.com的人添加一些记录为了我。如果在子域的域仪表板中设置了SPF和DKIM的TXT记录,它们有何不同?
8 subdomain  spf  dkim 

1
Windows Server 2012中的碎片整理选项
我正在查看defrag.exe的命令行选项以及Windows Server 2012上的“ ScheduledDefrag”任务,但我不理解其中的某些参数。特别是,当我查看时,defrag /?我看到: /D Perform traditional defrag (this is the default). /L Perform retrim on the specified volumes. “非传统”碎片整理由什么组成?什么是后备? 另外,在计划任务下,命令行为 %windir%\system32\defrag.exe -c -h -k -$ 我看到这-c意味着“所有卷”, -h意味着“正常优先级”,-k意味着“ 平板合并 ”,并且显然,-$意味着“ 从任务计划程序中调用了defrag.exe ”。 为什么-$重要?


1
Cgroup-设备上没有剩余空间
我有Debian 7盒子,没什么问题: mkdir /cgroups/test echo 500 > /cgroups/test/cpu.shares echo 3167 > /cgroups/test/tasks bash: echo: write error: No space left on device 我该如何解决? 在fstab中: cgroup /cgroups cgroup defaults 0 0 我已经安装了:cgroup-bin,libcgroup1,libpam-cgroup
8 debian  cgroup 

3
加入域后使用本地管理员帐户登录
我的印象是,一旦您加入域,就将禁用本地管理员帐户。我在Azure中做了以下工作: 创建Windows Server 2012 R2实例并提升为域控制器。 在Windows Server 2012数据库实例和加入的域上创建了SQL Server 2012 SP1。 在带有远程桌面6.2.9200(RDP Protcol 8.0)的Windows 7盒中,如果不使用创建的域管理员帐户,则无法将RDP到我的盒中。换句话说,我的印象是本地管理员帐户已被停用。 但是,在Mac上,使用来自应用程序商店的RDP客户端,我可以使用本地管理员帐户登录,没有任何问题。我还注意到,我可以从另一个Win7机器上的旧RDP客户端进行RDP。 有任何想法吗?

1
防止货叉炸弹进入Docker容器
我目前正在努力限制我致电给用户的进程数sandbox。 我在内部配置了进程限制,/etc/security/limits.conf如下所示: sandbox hard nproc 100 但是,如果我想以sandbox用户身份连接到容器,则ssh返回: shell request failed on channel 0 因此,我以的身份登录root并检查了sandbox用户正在运行多少个进程,但少于5个。 那么,是什么让我无法通过ssh登录? 在没有设置限制的情况下,sandbox用户的ssh登录正常。 还是有其他方法可以防止叉子炸弹袭击?
8 ssh  pam  containers  docker 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.