服务器管理员

系统和网络管理员的问答

1
您如何在AWS的Linux上创建大型的,可扩展的共享文件系统?
在AWS上提供作为单个文件系统公开的大型,可增长的共享存储的可接受/合理/最佳方式是什么? 我们目前大约每两周制作1TB EBS卷,并使用no_subtree_check和nohide导出NFS。在此设置中,客户端上的单个安装下会出现不同的导出。这种安排不能很好地扩展。 我们考虑过的选项: 具有ext4的LVM2。resize2fs太慢。 Linux上的Btrfs。显然还没有准备好黄金时间。 Linux上的ZFS。显然还没有准备好迎接黄金时段(尽管LLNL使用了它) Solaris上的ZFS。这个组合的未来(对我而言)不确定,并且新操作系统混合在一起 glusterfs。听到的大部分都是好故事,但有两个令人恐惧的故事(也许是古老的故事)。 理想的解决方案将提供共享,单个fs视图,轻松的可扩展性,快照和复制。 感谢您分享想法和经验。

5
不可变标志在Linux中的实际使用
想要改善这篇文章吗?提供此问题的详细答案,包括引文和为什么答案正确的解释。答案不够详细的答案可能会被编辑或删除。 按照目前的情况,这个问题不适合我们的问答形式。我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意调查或扩展讨论。如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 7年前关闭。 有没有人在现实世界中使用过Linux中的不可变标志? chattr + i file.txt 由于root可以取消设置属性,因此您似乎在保护文件免受具有root访问权但不了解该功能的用户的侵害。

1
无法使摩托罗拉MC3190与WiFi接入点关联
使用Symbol / Motorola MC3190的Wireless Fusion管理工具,我们无法使手持设备关联到WiFi接入点。使用Fusion软件中的“查找WLAN”功能,我们可以看到该设备正在检测到接入点,因为它确实出现在检测到的WLAN列表中。因此,由于它可以看到可用的WLAN,因此无线电/硬件似乎工作正常。接入点使用WPA2 AES进行安全保护,并且其他设备都没有问题。它是非企业级访问点,因此在Fusion WLAN配置文件中选择的安全模式为“ WPA2-个人”。它似乎提供的唯一线索是Fusion Wireless Status中的Log信息。在日志中,在“设置SSID:”消息之后约10秒,显示消息“关联超时”。

1
您如何衡量一组分叉进程的内存占用量?
假设我有一个使用200MB内存的进程,并且它fork()s: python -c "import os; data='x'*200000000; os.fork(); raw_input()" 诸如“ top”之类的程序将显示每个进程使用200MB内存,而SHRd内存很少,因此看起来好像这些进程总共使用了400MB。但是,由于fork()为进程的内存页实现了写时复制(COW),因此现实情况是,这些进程总共仅使用200MB。 为什么top不能显示COW的内存部分?有没有办法做到这一点?还是可以使用其他命令代替? 注意:OSX上的“顶部”似乎有一个RSHRD列,可以满足我的期望。我的问题是针对Linux。

4
我通过软件安装策略部署了Flash Player。如何升级?
我有一台Windows Server 2008计算机作为我的DC。今年早些时候,我创建了一个软件安装GPO来部署Adobe Flash Player插件MSI。我将策略分配给计算机,大约一半运行Windows XP x86,另一半运行Windows 7 x64。一切都像发条一样。 创建软件安装策略时,我通过在Orca中编辑MSI来禁用Flash Player插件的自动更新功能。我这样做是因为我希望所有机器都运行完全相同版本的插件。 现在,已经过去了一段时间,并且已经发布了Flash Player插件的较新版本。现在是我推出插件的更新版本的时候了。我已经有了新的MSI,但是我对下一步的工作一无所知。 我在“软件安装GPO”中看到了“升级”选项卡,但其中的所有内容都将用作较大主程序的附件,而不用于随时间推移发布的更新。 我已经读到,最好是使用新的MSI创建新的软件安装策略,撤销旧的GPO,然后分配新的GPO。我觉得,随着时间的流逝,我将获得比积极政策更多的被撤销政策。 我还读到有些人通过将旧的MSI替换为新的MSI并只是告诉GPO重新部署而取得了成功。这似乎是一种后门方法,只会使我陷入麻烦。 简而言之,通过组策略推出新版本的正确,最佳实践或首选方法是什么?

1
没有必需属性的默认值
在没有合理默认值的情况下,建议在资源(如模板)中使用属性的方法是什么?该属性值应在运行时提供。如果不是,则厨师配方执行应出错。 我现在拥有东西的方式将属性值应用于模板时是空字符串。 /recipes/default.rb template "/var/tmp/my_script.sh" do source "my_script.erb" mode "0755" variables({ :url => node['environment']['url'] }) end /templates/default/my_script.erb #!/bin/bash echo "The url is: <%= @url %>" 生成的/var/tmp/my_script.sh文件如下所示: #!/bin/bash echo "The url is: " 但是我希望它会出错。有什么建议吗?
8 chef  chef-solo 

1
在后缀队列中的文件上修改电子邮件的收件人地址
我的mailq中有几封电子邮件被退回,原因很充分,该电子邮件地址错误。我想知道是否可以即时修改收件人的地址。我可以看到延迟存储邮件的目录,并且我可能可以在其中更改某些内容,但是我想知道是否有适当的方法来执行此操作。 任何想法?
8 linux  email  postfix 

3
基于Web的磁盘空间可视化器
我有许多Linux网络服务器,它们想跟踪磁盘空间的去向,并将磁盘空间保持在最低水平。 通常,我登录SSH并用于du找出浪费磁盘空间的位置,但这既麻烦又缓慢。像KDirStat这样的可视化工具将是理想的,但是它至少需要安装X服务器,这违背了目的。 是否有任何基于Web的磁盘空间可视化器?我愿意接受其他解决方案。

3
自定义Openssh Shell
环境是Ubuntu Server 12.04 我想在服务器上创建一个只能ssh到在日志文件上运行tail -f并在程序结束后关闭会话的用户(ctrl + c)。 有没有办法做到这一点?
8 linux  ubuntu  ssh  shell 

7
无法在Ubuntu 12.04上启动Rabbitmq服务器
我尝试rabbitmq-server在ubuntu服务器12.04上安装,但失败。 然后,按照http://www.rabbitmq.com/install-debian.html中的指南添加apt源列表。 但是重新安装仍然具有如下相同的错误: $ sudo aptitude install rabbitmq-server ... Setting up rabbitmq-server (2.8.7-1) ... * Starting message broker rabbitmq-server * FAILED - check /var/log/rabbitmq/startup_\{log, _err\} ...fail! invoke-rc.d: initscript rabbitmq-server, action "start" failed. dpkg: error processing rabbitmq-server (--configure): subprocess installed post-installation script returned error exit status 1 No apport report written …

1
为了使域信任起作用,我需要打开哪些防火墙端口?
我在两个不同的林中有两个Active Directory域。每个域都有两个DC(都为Windows Server 2008 R2)。这些域也位于不同的网络中,并通过防火墙连接它们。 我需要在两个域和林之间创建双向林信任。 如何配置防火墙以允许这样做? 我找到了这篇文章,但是并没有很清楚地解释DC之间需要哪些流量,而一个域中的域计算机之间需要哪些流量(如果需要),而另一域中的DC需要所需的流量。 我可以允许DC之间的所有流量通过,但允许一个网络中的计算机访问另一个DC中的DC会有些困难。

4
无论如何,有没有要让msiexec回显到stdout而不是登录到文件
作为持续交付流程的一部分,我想在给定的计算机上安装MSI。msiexec加psexec可以完美地做到这一点,但是msiexec似乎只能登录到文件,我需要它才能登录到stdout / stderr。 现在,要将输出返回到我们的CI软件中,我必须添加第二步以回显日志的内容,这似乎没有意义。 是否有人曾经面对过这个问题(并克服了这个问题?) 在此先感谢您的任何帮助。 标记
8 logging  stdout  stderr  msi 


3
如何避免服务器文档与实际设置不同步?
我们拥有适用于我们环境的相当不错的文档(采用AsciiDoc格式),该文档最近允许另一个人在30分钟内从头开始重新创建整个设置。 但是,我注意到在初始设置后,很容易发生对系统进行小的更改(例如:inetd被禁用,我的IMAP服务器在另一个端口上监听ManageSieve连接,新的路由器被添加到exim配置中)不会立即出现在文档中(如果有的话)。 我的想法是通过(部分地)从配置文件和其中的注释中生成文档来避免此问题-一种实现此方法的方法可能是将/etc其/usr/local/etc放入某些源代码管理系统(例如git),然后运行该脚本可在每次提交时重新生成文档。但是,我不确定这是否会过大和/或太难解决(毕竟,我不想要文档中源文件的完整副本,而只是差异)。 其他人如何避免服务器文档过时-是否有一种很好的方法可以使它们自动保持同步,或者您只是有纪律在修改系统的同时更新文档?

1
使用git自动签署所有提交[关闭]
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 7年前关闭。 使用git 1.7.9,可以使用-S选项签署提交。是否可以通过设置它为默认值git config --global? 因此git commit -S -m 'Commit message',与其相反,那只是正义git commit -m 'Commit message'。
8 git  pgp 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.