服务器管理员

系统和网络管理员的问答

3
Nginx + Php5-fpm无法呈现php文件
我花了好几个小时弄清楚如何安装Nginx + Ruby企业版+ PHP5-fpm和MYSQL,终于全部安装好了,而且一切似乎都已经开始了。 但是由于某些原因,php文件未得到处理。 .html文件可以正常工作,但是当我尝试查看.php文件时,即使它存在,它似乎也不存在。有趣的是,当我尝试查看不存在的.html文件时,会收到一条不错的Nginx 404消息,但是当我查看.php文件时,甚至没有得到。 因此,据我的新手了解,似乎配置有问题,或者Nginx和PHP-fpm没有互相交谈。 我一直在看nginx配置文件的许多其他示例,并且我确定事情的一切都还可以。好吧...这还是conf文件的相关部分: location ~ \.php$ { fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME /var/www/eman/$fastcgi_script_name; include fastcgi_params; } 和 fastcgi_connect_timeout 60; fastcgi_send_timeout 180; fastcgi_read_timeout 180; fastcgi_buffer_size 128k; fastcgi_buffers 4 256k; fastcgi_busy_buffers_size 256k; fastcgi_temp_file_write_size 256k; fastcgi_intercept_errors on; 任何帮助是极大的赞赏。 编辑:这是从测试php文件“ http://eman.id.au/test.php ” 返回的标头: HTTP/1.1 404 Not Found …
8 linux  nginx  php5  php-fpm 

2
sql_error后重新启动mysql复制
我有两台mysql服务器,一台主服务器和一台从服务器。 有人继续从属并创建了一个表,然后又继续使用了主方并创建了相同的表。当然,此DDL语句已复制到从属服务器,从而导致错误,并导致复制在错误发生时停止。 在删除从属服务器上的表或在该语句之后开始复制之后,应该如何重新启动复制过程? 显示从站状态输出: mysql> show slave status \G *************************** 1. row *************************** Slave_IO_State: Waiting for master to send event Master_Host: xx.xx.xx.xx Master_User: buildbot Master_Port: 3306 Connect_Retry: 60 Master_Log_File: mysql-bin.024536 Read_Master_Log_Pos: 33489509 Relay_Log_File: mysqld-relay-bin.049047 Relay_Log_Pos: 32575097 Relay_Master_Log_File: mysql-bin.024476 Slave_IO_Running: Yes Slave_SQL_Running: No Replicate_Do_DB: Replicate_Ignore_DB: Replicate_Do_Table: Replicate_Ignore_Table: Replicate_Wild_Do_Table: Replicate_Wild_Ignore_Table: Last_Errno: 1050 …

3
VLAN-规划?
我们的网络是平面L2。 在某个时候,我们需要(我想,但严格来说,这不是我的责任)开始对其进行VLAN划分,因为显然我们将要进行大量广播聊天,并且最近我们的防火墙之一已达到其arp表限制(可以说防火墙的arp表限制很低,但是我们在那儿)。 那么,您如何提出将VLAN沿LAN下行的方法呢? 在我们的情况下,我们是一个站点,但是只有一个小镇的大小(我想是校园)。 我们有一个非常典型的集线器/分支LAN,其中有几个核心交换机,边缘交换机直接连接到其中,有些通过光纤到铜缆转换器直接连接。 我们的边缘套件是Procurve,Prosafe和一些较旧的Baystack等的组合。 我们的大多数客户端都使用DHCP,一些客户端使用静态IP,但是我们可以处理这些问题,网络打印机也使用静态IP。 正如我所看到的,基于园区中的物理位置,VLAN有很多选择,即建筑物A和B中的任何边缘交换机都位于VLAN xx上,或者它可以基于其他因素。 简而言之,我以前没有做过,很容易潜入并快速进行操作,然后后悔。 请问如何处理?

1
我如何观察nginx在做什么?(解决:“ 1024个worker_connections不够”)
我在nginx上运行的流量非常低的站点,有4个工作线程,每个连接1024个。 我每隔几个小时开始在错误日志中看到“ 1024 worker_connections不够”,并且我的网站变慢/变黄了。Nginx重新启动可以在接下来的几个小时内完全解决该问题。 显然,正在发生奇怪的事情,我无法为我的应用程序的4k并发用户提供服务。 除了查看访问日志(看起来很正常)之外,还有没有办法更详细地观察nginx在做什么? 是否存在一些臭名昭著的配置组合,这些组合组合可能导致旧连接保持打开状态而不是关闭状态? 谢谢。 编辑 这看起来不对 # lsof |grep nginx |grep CLOSE_WAIT |wc -l 1271
8 nginx  lsof 

8
在CentOs 5上安装/启用PHP Pecl Intl扩展
原始问题: 我在CentOs 5机器上安装PHP Pecl Intl扩展时遇到问题。 安装完这两个命令后,icu并libicu使用以下命令: $ yum install icu $ yum install libicu 我试图像这样安装Intl扩展: $ /usr/bin/pecl install intl 我选择搜索ICU库和头文件的默认位置。它最终像这样崩溃: checking whether to enable internationalization support... yes, shared checking for icu-config... no checking for location of ICU headers and libraries... not found configure: error: Unable to detect ICU prefix or …

2
如何在Wireshark中过滤数据包的内容?
我有一个与Oracle数据库进行通信的应用程序,它的日志记录非常糟糕,因此,我可以通过数据包嗅探TNS来锻炼它向数据库发送的SQL的唯一方法。我想用那些包含特殊名称的包来过滤这些包,即包中是否存在特殊字符串。我怎样才能做到这一点? 谢谢。
8 wireshark 


2
tmux是否具有屏幕具有的所有功能?那些屏幕不见了?
我正在考虑从屏幕切换到tmux,但是我投入了大量时间来开发一个广泛的.screenrc,而且我不想在将其移植到tmux数小时后发现tmux无法做重要的事情对我来说。 我已经看过这两种方法的在线比较,但都没有深入探讨或回答许多(对我而言)重要问题,这些问题可以归结为两个问题: 屏幕可以做tmux无法做的重要事情吗? tmux不能执行该屏幕有什么重要意义? (客户端-服务器体系结构很好,但是据我所知,它没有提供任何新功能。许可证显然更好。更小,更精简是很好的,但对我来说不是改变游戏规则。) 由于这两个问题非常广泛,因此让我举一些具体的例子: tmux是否具有完整的命令历史记录?(对于发送到tmux本身的命令,而不是shell命令。这是屏幕缺少的内容:如何返回(GNU)屏幕命令历史记录?(不是shell命令历史记录!)) 我假设我可以将键绑定到tmux命令? 我假设我的tmux配置文件可以获取其他文件? 是否可以将击键绑定到source命令,以便可以轻松地动态更改配置? tmux是否具有ACL设置?(我从没真正在屏幕上需要这些,但是很高兴知道它们在那里。) tmux可以打开默认窗口吗?(la screen -t somename 1 ssh someserver) 我可以自己寻找这些特定问题的答案,但它们只是两个较大问题的示例,我也想听听不一定适合我的任何示例的较大问题的答案。完全有可能,如果tmux缺少某些内容,那么我将在花费大量时间进行切换之后再发现它,这就是我要避免的事情。谢谢!


3
突然大量文件系统损坏的原因?(“根索引节点不是目录”)
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 5年前关闭。 我有一台笔记本电脑运行Maverick(很高兴直到昨天),并带有Patriot Torx SSD。整个分区的LUKS加密;最重要的是一个LVM物理卷;然后在此基础上将根目录和根目录放在ext4逻辑卷中。 昨天我尝试引导它时,它抱怨无法安装根文件系统。运行fsck,基本上每个inode似乎都是错误的。起始文件系统和根文件系统都显示类似的问题。检查备份超级块无济于事。 e2fsck 1.41.12 (17-May-2010) lithe_root was not cleanly unmounted, check forced. Resize inode not valid. Recreate? no Pass 1: Checking inodes, blocks, and sizes Root inode is not a directory. Clear? no Root inode has dtime set (probably due to old mke2fs). Fix? …
8 linux  ssd  corruption  fsck  ext4 

3
Postgres vs MySQL:哪一个更难以扩展?
根据您的经验,哪个数据库服务更难扩展?MySQL还是Postgres?我知道MySQL具有几项现成的缩放/聚类功能,但是对于Postgres,没有现成的。CMIIW。 编辑: 抱歉,我的问题是横向扩展(水平扩展),即群集,分片等。我知道两者都可以水平扩展,但是哪一个更易于实现? 感谢你的分享。


6
Windows共享:指定的网络名称不再可用
我们有一个EMC NX4 SAN盒,可将CIFS共享提供给许多Windows Server 2008 R2应用服务器。应用程序服务器正在使用CIFS共享来提供大量图像文件(共享时约为2500 ops / sec),但是SAN和应用程序服务器均未显示任何明显的压力迹象。 有时,应用服务器有时会突然断开与SAN的连接。任何尝试从SAN提供文件服务的.NET代码都会失败,并显示以下信息: System.IO.IOException: The specified network name is no longer available 如果我RDP到应用程序服务器并尝试通过资源管理器访问“ \ san-name”,则会收到相同的错误。所有其他应用服务器都可以正常访问它。我还可以完美地访问“ \ ip-of-san”,并且可以ping通。 重新启动应用程序服务器可以解决此问题,但是考虑到SAN可以正常工作并且计算机可以访问它,因此可以用某种程度的方法解决该问题-就像“ \ san-name”访问权限f倒。 在上周,两个不同的应用程序服务器都发生了这种情况,因此我不怀疑单个应用程序服务器是原因。暂时忽略原因-如何在不重新启动计算机的情况下恢复“ \ san-name”连接?我可以以某种方式查询出了什么问题吗? 事件日志在应用程序服务器或SAN上均不显示任何内容(除了由问题引起的相关ASP.NET错误)。 更新: 根据建议,下次我将尝试重新启动Workstation服务,并查看是否有助于解决该问题。绝对不是修复程序,但是比我目前正在重启整个计算机的方法要快。有什么方法可以查询Workstation服务维护的连接状态? 更新2: 确认重新启动工作站服务可以“解决”该问题。下一步是尝试更改reg以提高MaxCmds值。无法确认是否是问题所在,只能假设它运行了很长一段时间而没有问题。



By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.