服务器管理员

系统和网络管理员的问答

2
在ubuntu服务器中切换eth0和eth1
我有一个简单的问题。我有一台运行带有2个NIC的Ubuntu服务器8.04 LTS的计算机。主板上的一个连接到互联网,而一张PCI卡的连接到内部网络。在安装过程中,它检测到主板上的NIC为eth1,而PCI卡为eth0。我希望他们反过来。尤其是因为主机服务器将不会使用PCI NIC,所以它仅用于将在其上运行的某些虚拟机。 因此,当前计算机启动时会激活eth1(主板NIC)以dhcp获取IP,而单独保留eth0(PCI NIC)。这正是我想要的,除了eth0和eth1可以切换。 谢谢。

3
备份VirtualBox VM
有没有人有很好的完整策略来备份在VirtualBox下运行的一堆虚拟机? 我打算在单个硬件平台上运行少数几个虚拟机,并将它们每晚备份到外部磁盘,该磁盘将在每个周末轮流移出现场。 (为澄清起见,如果可以避免,我无意在此过程中关闭计算机) 我是否认为我可以编写一个脚本,该脚本每天晚上创建一个快照,然后将“主”磁盘映像复制到外部介质,然后再次删除快照? 更好的想法深表感谢!

3
是否可以通过SNMP共享SMART数据?
是否可以通过SNMP共享SMART数据?我希望能够制作它的仙人掌图并将其连接到Nagios。 我想做的是能够获取可通过SNMP访问的硬盘上的一些统计信息。这将使我能够绘制$ SMART_MEASUREMENT_VALUE的数量与时间的关系图。


3
如何在Ubuntu Jaunty服务器上安装无头JDK?
我最近设置了一个运行JDK的构建服务器(例如,编译Java源代码)。Ubuntu中的OpenJDK软件包将OpenJDK JRE作为依赖项引入,而依赖项又依赖于仅与图形环境相关的大量软件包。对于标准JRE,有一个无头版本的软件包,但对于JDK,没有。 之前已经在各个地方讨论了这个问题,而我找到并使用的一个解决方案是: $ apt-get --no-install-recommends -d install openjdk-6-jdk $ dpkg -i --ignore-depends=openjdk-6-jre /path/to/just-downloaded.deb 在执行此操作的同时,它现在使我的系统具有一棵坏掉的依赖树,并且apt-get拒绝进一步安装,直到我运行apt-get -f。 有更好的解决方案吗?
8 ubuntu  headless  java 

3
解决SQL Server /数据库排序规则不匹配的方法是否比更改每一列更简单?
免责声明:我知道这个问题已经被问过一百次了,但是我只是想检查一下,在继续编写并提供大量代码来实现这一目标之前,我没有错过一个更简单的解决方案。 我们的软件使用的数据库最初是为SQL Server 7设计的,因此,创建该数据库的所有脚本都不会为任何字符列指定任何显式排序规则。相反,当数据库创建/还原到SQL Server 2000或更高版本时,每一列都会继承数据库排序规则(恰好是SQL_Latin1_General_CP1_CI_AS因为这是SQL Server 7的默认设置)。 从理论上讲,这没什么大不了的,因为如果我们的数据库是从头开始在客户服务器上创建的,它将继承客户的服务器排序规则(通常是现代安装的默认设置Latin1_General_CP1_CI_AS),并且一切正常。但是,当他们向我们发送数据库备份,或者我们向他们发送数据库备份时,这种情况就无法解决了,无论何时代码尝试访问临时表等,我们或他们都会遇到可怕的排序规则不匹配错误。 我们已经尝试教育客户安装或重建他们的SQL Server实例以使用我们首选的排序规则,但是当然这并不总是会发生,而且也不总是可能。 涉及创建新数据库和复制数据的解决方案对我们而言实际上并不实用,我们需要一个“魔杖”,我们可以在实时数据库中挥动一下魔杖,以就地校正所有列而不会干扰数据。我正在考虑编写一个实用程序来执行此操作,但是由于这将是一项艰巨的任务,因此有人有更简单的建议吗?
8 sql-server  sql 

4
Linux:丢失文件的组所有权
我有一个项目,其中包含我在Linux中创建的许多文件。 我需要给另一个用户写权限。因此,我创建了一个“ dev”组,他和我是该组的成员,并将文件的所有权更改为该组。 现在,典型文件具有以下权限: -rw-rw-r-- 1 phil dev 5617 Jul 14 15:45 profile.html 但是,当我编辑profile.html文件时,它会像这样还原为我,而我的同事却失去了编辑功能。 -rw-rw-r-- 1 phil phil 5617 Jul 14 15:45 profile.html 我如何避免它还原成这样?更改所有权是错误的做法吗?还是用错误的选择完成了?还是这与我的编辑器(emacs)配置有关?

6
监视Internet连接稳定性的软件
关闭。这个问题是题外话。它当前不接受答案。 想改善这个问题吗? 更新问题,使它成为服务器故障的主题。 5年前关闭。 已锁定。该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。它目前不接受新的答案或互动。 由于世界上最好的ISP之一提供了出色的Internet连接服务,因此我所在地区的Internet连接非常非常不稳定。我有时可以连接,但是大多数时候连接会断开(带有错误消息),几分钟后,连接将恢复。如果我直接ping域名(即在cmd命令中),我将收到一条消息。unable to resolve hostping www.google.com -tcannot ping 由于连接的闪烁性,很难向支持人员证明互联网连接不稳定。因此,我正在考虑使用一种软件来记录连接情况,以便我可以向技术人员介绍并确保他们没有借口不解决我的问题。 有没有这样的软件? 编辑:当然,这样的软件不应该记录我的浏览习惯,并且即使我不在线也必须能够监视和记录Internet连接状况。
8 untagged 


1
启动openLDAP
我在公司中以系统管理员的身份工作,我需要部署openLDAP。我读了很多材料,但我真的不知道从哪里开始。 首先关于公司: 服务: 电子邮件:每个用户都有一个电子邮件帐户,例如firstname.middlename.anothername.lastname@company.com,以及一个电子邮件别名/转发者,格式为firstname@company.com或有时是[First-let-of-first-name]] lastname @ compant.com Jabber:每个用户都会获得一个格式为firstname@jabber.company.com的jabber帐户。在某些情况下,如果名称冲突,该名称将变为firstname.lastname。 Trac和Redmine:每次使用都会获得Trac和Redmine的称呼,通常是他的名字。 一个timetrex登录名或名字。 机器登录名。 邮件列表的会员资格,例如all @ company.com,management @ company.com,accounts @ company.com等。 一个MediaWiki帐户,格式与电子邮件别名/转发者相同。 部署服务器之一上的ssh帐户,格式与电子邮件别名/转发器相同。 我认为我应该做的是:我应该使用inetOrgPerson并为我们的组织创建自定义方案。我不确定的是我如何管理这么多不同的登录名,以及如何尊重软件知道要使用哪个登录名。我写了一个自定义方案,可以存储以下信息: 全名 电话 细胞 地址 市 国家 部 已加入 有人会指出我正确的方向吗?我浪费了很多时间搜索它,但是什么都想不起来...非常感谢您抽出宝贵的时间阅读问题。

4
反向DNS查找如何处理垃圾邮件过滤器?
我听说大多数垃圾邮件过滤器在发送SMTP服务器(或类似的东西)的原始IP地址上使用反向DNS查找,作为验证过程的一部分。我想确保我的电子邮件能够通过此检查。我怎样才能准确地验证我的电子邮件是否正常? 在研究它时,我注意到,如果我查看来自Gmail的有效电子邮件的标题,则会看到以下内容: Received: from mail-pz0-f185.google.com (mail-pz0-f185.google.com [209.85.222.185]) by mx.google.com with ESMTP id 10si2346996pxi.164.2009.07.22.22.26.19; Wed, 22 Jul 2009 22:26:19 -0700 (PDT) 当我在209.85.222.18上执行nslookup时,它将以mail-pz0-f185.google.com进行响应,这是我所期望的。如果它以不同的域响应,那么我认为那将指示问题并且将使检查失败。 这是反向DNS查找的全部内容,还是我叫错了树?


3
为什么“ ps”输出无法解析进程的uid?
上下文:在ubuntu Linux 2.6.24-22-xen#1 SMP x86_64 GNU / Linux上 我正在通过init.d脚本启动守护程序,但是在“ ps”输出中,它以数字形式显示守护程序的用户。例如 1000 17560 1 1 11:04 ? 00:00:09 /usr/lib/jvm/java-6-sun/bin/java -server -jar /home/superduperadmin/server/daemon.jar 1000映射到/ etc / passwd中的superduperadmin。 为什么是这样 ?是因为superduperadmin太长了吗?

7
我如何知道驱动器正在旋转什么?
我已经在我的Linux服务器的驱动器之一上启用了“ spindown”,只能由BitTorrent客户端访问-这意味着,当我没有洪流运行时,其他任何东西都不应访问磁盘并将其从Spindown中唤醒(对吗? )。 但是有些事情使磁盘每15分钟左右旋转一次。如何跟踪流氓元凶? 感谢您的任何反馈!

6
我可以将NX附加到现有的X会话吗?
我在ubuntu工作计算机上运行NX服务器,并在ubuntu家用计算机上使用NX客户端在家工作。 设置的问题是,每次执行此操作时,我都必须创建一个新的X会话-我无法登录到我在工作中运行的现有锁定会话。 这要求我要么回家(如果我知道自己想在家工作),要么先注销工作,或者一旦我在家中创建了一个新的X会话,就进行流程浏览器并杀死其中的故障流程另一个X会话。 因此,有没有办法使用NX Client连接到运行NX服务器的计算机上的现有X会话?

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.