服务器管理员

系统和网络管理员的问答

5
限制使用sudo -s
我正在某些Linux服务器上设置Nagios,但是遇到了一些问题。该check_ide_smart插件需要对系统具有root访问权限才能运行。要运行它,我使用check_by_ssh插件将ssh插入远程主机上的nagios帐户,然后check_ide_smart使用sudo 运行。 最初,我添加了以下几行/etc/sudoers以允许程序运行: nagios ALL=NOPASSWD: /usr/lib/nagios/plugins/check_ide_smart 尽管在本地运行时这很好,但是从Nagios运行时却遇到了一个问题:没有生成TTY,这阻止了插件的工作。 我在sudo的手册页中找到了-s选项,该选项生成一个shell并在其中执行程序。当我尝试使用时sudo -s,由于-s显然将命令更改为,所以遇到了权限问题/bin/bash -c /usr/lib/nagios/plugins/check_ide_smart,这是sudoers文件不允许的。我尝试将sudoers文件更改为使用该命令,但这没有用,并且使用引号是语法错误。 我最终通过使用以下行来使其工作/etc/sudoers: nagios ALL=/bin/bash 这对我来说真的很不对劲,因为我允许nagios用户生成一个root shell,他们可以用它进行任何操作。 此时,尽管如此,我还是可以通过将命令放入nagios用户具有只读特权的shell脚本中来工作,因此我创建了一个shell脚本: #!/bin/sh /bin/bash -c /usr/lib/nagios/plugins/check_ide_plugin $@ 不幸的是,我永远无法通过传递的参数($@)来正确使用该插件,因此我不知道这样是否可行。 编辑:我需要引用$@它才能工作。谢谢@derobert和@pjz。我仍然不知道它是否可以工作,因为我可以使用@Mike Arthur的解决方案来工作。 有没有一种方法可以让我sudo -s在不产生根外壳的情况下工作? 回答: 将以下行添加到/etc/sudoers: nagios ALL=NOPASSWD: /bin/bash -c /usr/lib/nagios/plugins/check_ide_smart * 注意结尾的星号;没有它,这是行不通的。感谢@Mike Arthur的回答。
8 linux  security  sudo 

4
您问每个新雇主什么?
已锁定。该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。它目前不接受新的答案或互动。 大多数程序员都知道Joel测试-12个是/否问题,可以快速评估公司在其开发部门中所处的位置。这些问题是“您使用源代码管理”和“您有规范”之类的问题。 sysadmin的等效问题是什么?表示雇主的机敏的10或12个是/否问题是什么?
8 untagged 


2
ECC Chipkill错误:哪个DIMM?
我们经常使服务器中的DIMM损坏,并在syslog中出现以下错误: 5月7日09:15:31 nolcgi303内核:EDAC k8 MC0:通用总线错误:参与处理器(本地节点响应),超时(无超时),内存事务类型(通用读取),mem或i / o(mem访问) ,缓存级别(通用) 5月7日09:15:31 nolcgi303内核:MC0:CE页面0xa0,偏移量0x40,纹理8,校正子0xb50d,第2行,通道0,标签“”:k8_edac 5月7日09:15:31 nolcgi303内核:MC0:CE-无可用信息:k8_edac错误溢出设置 5月7日09:15:31 nolcgi303内核:EDAC k8 MC0:扩展错误代码:ECC chipkill x4错误 我们可以使用HP SmartStart CD来确定哪个DIMM出现错误,但这需要使服务器停产。在服务器启动时,有什么巧妙的方法可以解决哪个DIMM出现故障吗?我们所有的服务器都是运行RHEL 5的HP硬件。
8 linux  hardware  memory  ecc 

7
哪种存档/压缩格式?
已锁定。该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。它目前不接受新的答案或互动。 Zip,Rar,7z,Gzip,BZip2,Tar等。我听说7z是本月的风情,为什么?是最适合所有情况,还是针对特定情况有更好的选择? 还是实际的文件存档器(例如WinZip,WinRar,7Zip等)(相对于格式)会产生更大的影响? 在您的答案中,您可以描述提到的格式使用哪种速度/压缩权衡。 请提供指向任何可支持您答案的经验测试的链接。 背景:我需要备份一个自定义搜索索引,该索引可以创建大约3000个相对较小的文件(小于10MB),每个文件包含大量重复数据。 (与往常一样,维基百科上有一篇相关的文章,但是关于性能比较的部分很简短。) 谢谢


4
自托管应用程序还是将其外包?[关闭]
按照目前的情况,这个问题不适合我们的问答形式。我们希望答案会得到事实,参考或专业知识的支持,但是这个问题可能会引起辩论,争论,民意调查或扩展讨论。如果您认为此问题可以解决并且可以重新提出,请访问帮助中心以获取指导。 8年前关闭。 已锁定。该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。它目前不接受新的答案或互动。 假设您有能力影响组织中的IT采购,那么您使用什么标准和流程来评估外包决策?在基本的“内部托管商业应用程序”与托管/软件即服务决策之间,我看到了三种不同的情况: 购买新的硬件和软件以内部托管新应用程序,或将其外包。 外包当前正在内部托管的现有应用程序。 将当前正在外包的应用程序带回内部。 该决定最终取决于预算和资金,但是您还考虑其他哪些因素?时间?专长?与其他系统集成?
8 untagged 

13
锁定台式机USB端口
如何锁定台式机上的USB端口,以便我们可以防止台式机上使用USB驱动器。 我应该澄清这些是Windows XP桌面。 我们还应该假设,像大多数新台式机一样,许多台式机都将USB用于键盘和/或鼠标。


6
IIS6网站/应用程序池可以使用的最大内存是多少?
我有一个在Windows 2003 SP2 x86上运行的IIS 6服务器。该服务器具有4GB的RAM,并在分配2GB的情况下始终运行。 我意识到,使用x86,服务器将无法利用所有4GB RAM,并且应用程序空间也受到限制,但是IIS进程似乎在其他地方受到限制。w3wp.exe从未分配超过500MB的内存,有时我会从繁忙的.NET应用程序中获取OutOfMemory异常(有几个正在运行的应用程序,每个应用程序都有一个单独的应用程序池)。 IIS6网站/应用程序池可以使用的最大内存是多少?

3
是什么导致JBoss上的PermGen OutOfMemoryError?
JBoss中PermGen OutOfMemoryError的根本原因是什么? 我在开发环境中运行JBoss AS 4.2.2,这是在大量重新部署Web应用程序之后发生的。 Christian Vest Hansen的博客提供了JVM选项,这些选项很有帮助,但不能完全解决问题: -XX:+UseConcMarkSweepGC -XX:+CMSPermGenSweepingEnabled -XX:+CMSClassUnloadingEnabled -XX:MaxPermSize=128m

7
不同操作系统之间共享的便携式硬盘应使用哪个文件系统?
一些类似的已经问了,不过我的标准是有点不同。我需要在Mac OSX,Linux和Windows XP系统之间共享便携式硬盘(USB /火线),其中共享的文件有时大于4GB。在所有支持此功能并允许读/写访问的操作系统上,是否都有可用的文件系统可用?如果没有,那么在这些操作系统上安装其他软件方面的下一个最佳解决方案是什么?

6
提高rsync备份性能
假设一个系统将始终具有主副本,而另一个系统将始终具有最新副本(少于48小时),那么通过unix框之间的ssh镜像改善rsync的最佳技术是什么? 另外,要扩展这种方法以处理数十台机器来推动这些变化,该怎么做?
8 backup  unix  rsync  mirror 

12
Active Directory的替代品
已锁定。该问题及其答案被锁定,因为该问题是题外话,但具有历史意义。它目前不接受新的答案或互动。 活动目录有什么好的选择吗? 为了澄清,在全部使用Active Directory部署和维护许多仅Windows的站点之后,我开始想知道为什么我从未三思而后行地使用其他东西,例如Linux。我了解到可能还没有功能齐全的替代产品,但是我至少正在寻找有志于成为活动目录并为之努力的东西。


By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.