服务器管理员

系统和网络管理员的问答

1
LAN上的大Ping超时
我有几个站点,在本地千兆连接上,较大的ping(14kb或更高)将超时。较小的Ping可以正常工作。 Server 2003机顶盒经常发生这种情况,但在2008 R2上有(较少)发生这种情况的报告。 有没有人对从哪里开始解决此问题有任何建议?可能与交换机相关,还是与网络,操作系统/驱动程序有关?

1
从Hyper-V迁移到ESXi后,邮件卡在草稿文件夹中
我的一位客户希望将Hyper-V Exchange 2010盒子移到其他子网上的ESXi盒子,这有几个原因。我将VMWare Converter从Hyper V机器运行到ESXi盒,这一切似乎都已按计划进行。 当盒子启动时,我更改了网络配置以反映新的子网信息,检查了DNS以确保更改得以传播,等等。我注意到来自OWA的测试电子邮件不会发送,而是放在草稿文件夹中。传入的电子邮件也以重复形式出现,但至少它们到达收件人。 发送连接器看起来正确(类型:SMTP,地址:*,成本:1,网络:使用DNS记录自动路由邮件,并且源服务器是本地交换服务器)。该test-servicehealthcmdlet显示所有必需的服务正在运行。事件查看器中未显示任何用途。 有人对解决这样的问题有任何想法吗? 编辑:运行test-mailflowcmdlet会产生故障,但是似乎并不能说明原因。

4
如何将服务器HBA注册到EMC Clariion存储系统
我刚刚通过Emulex HBA将Solaris盒(旧的Enterprise 420R)连接到Clariion存储阵列,但是Navisphere软件仅通过十六进制引用ID来查看系统,而不是通过代理的主机名来查看。尝试分配存储空间时,我的服务器丢失了,在线帮助显示: 验证服务器是否为: 物理连接到存储系统。 服务器的HBA或NIC(手动或通过Navisphere Server Utility或主机代理)注册到存储系统。 显然,Clariion正在查看服务器路径(因此为十六进制代码),那么如何将HBA注册到存储系统?
2 emc  clariion  emulex  hba 

1
如何同时使用Nginx Gzip,缓存和SSL?
我当前正在将Nginx与NodeJs一起使用,并且试图编辑nginx.conf文件以允许缓存。 在下面的当前设置下,我可以使用SSL和GZIP,但是如何添加缓存?我收到错误404。我的文件具有以下结构:/ root / Poplive / Dec5 / public 在公共场合,我有一个文件(main-built.js)和文件夹(/ javascripts | / css),这些是我尝试缓存的文件和文件夹。 我试过了... 1)我将指令放在下面的nginx.conf中的位置/ {}下 location ~* /.*\.(/javascripts|main-built.js)$ { expires 24h; } 结果,没有缓存,但是GZIP可以工作 下面的Nginx.conf events { worker_connections 1024; } http { upstream myapp { server 127.0.0.1:3100; } #Add Gzip sendfile on; keepalive_timeout 2; tcp_nodelay on; gzip on; gzip_http_version …
2 nginx  node.js 

2
使用“ eb start”命令行实用程序创建Elastic Beanstalk环境时如何标记它?
5月,AWS引入了标记弹性beantalk环境的功能。 使用“ eb start”创建弹性beantalk环境时,我们无法弄清楚如何标记该环境。 我们使用“ eb命令行界面”创建环境。使用此机制,您可以通过命令行或使用.elasticbeanstalk / optionsettings传递配置参数。environment_name文件。有人知道如何使用optionsettings文件标记环境吗? 如果不是,是否有人知道创建环境后对其进行标记的方法?


5
在Ubuntu 12.04中更新到最新的稳定php
我们运行的是Ubuntu 12.04服务器,默认情况下安装了php 5.3.10。我以为Ubuntu只在更新中应用了错误修正,因此5.3.x之类的micros应该会通过。 显然,我们的版本没有更新,但是我们陷入了php中的一个严重错误,该错误已在5.3.15中解决。我应该等待更长的时间才能发布此版本吗?还是有安全的存储库供Ubuntu用来不断更新php和与php相关的软件包?
2 ubuntu  php  php-fpm 

1
PBS Jobs-串行与并行作业,哪个适合我的情况
我可以访问使用“扭矩”的群集(我认为),并且我们使用PBS脚本提交作业。我需要运行超过200个用Java开发的应用程序实例。该应用程序充当形成P2P网络的对等方,这意味着这些实例通过套接字相互通信。 我能够在集群的单个节点上运行100个实例来进行测试,但是在单个节点上运行200个实例却无法正常工作,并且我无法请求更多资源(内存,内核等)。 ) 我的问题是:我应该按照自己的方式来做吗?使用串行脚本,在其中我一个个地启动所有实例,然后将它们发送到后台,然后等待它们吗? 是否可以使用并行脚本来完成此任务,在该脚本中我可以要求2个节点并在每个节点中实例化我的应用程序的100个实例?在这种情况下,我还有其他问题:我该怎么办?是否可以保证两个作业同时运行?所有200个实例必须同时运行。 为了形成P2P网络,在串行作业中必须至少知道一个对等IP地址,我可以在脚本中获取节点IP地址并将其作为参数传递给应用程序,但是在具有2个节点的并行作业中,我该如何做这个? 这是我当前正在使用的脚本的一部分... #PBS -l nodes=1:ppn=4 #PBS -l pmem=6GB #PBS -l walltime=00:20:00 IP=`/sbin/ifconfig eth0 | grep 'inet ' | awk '{print $2}' | sed 's/addr://'` PORT_PEER=3000 java -jar $JAR $JAR_PARAMS -ip=$IP -port=$PORT_PEER & # first peer, others connect to this one.. for i in {1..99} do …
2 cluster  pbs  linux 

1
设置新的KMS主机-_VLMCS DNS输入的最佳实践是什么?
我的任务是在我们的环境中将PDC设置为新的KMS主机。我对KMS主机的DNS条目有疑问。 _tcp中现有主机的_VLMCS条目已存在。什么是最佳实践,因为我不确定。 我应该设置新主机,然后将DNS条目指向它,还是应该删除_VLMCS条目,然后为新主机设置一个新的_VLMCS DNS条目。 我在其他环境中进行了测试,DNS条目不会像MS所说的那样自动创建,因此它要么是指向旧的,要么是手动创建新的。有人知道什么是最好的吗? 如果我要这样做,该过程是在设置新主机之前删除条目,还是在设置新主机之前先降级旧主机,然后再更改DNS条目? 这是针对服务器2008 R2 / Windows 8.1环境的,尽管我认为OS在这里并不重要。

1
为什么我用Git不断获取错误的索引文件[关闭]
我不断收到以下错误: error: bad index file sha1 signature fatal: index file corrupt 我知道短期的解决方案是删除索引,然后离开,但是我的问题是,为什么它一直在发生? 我没有在仓库中运行任何类型的实用程序(我知道),并且硬盘驱动器具有足够的磁盘空间。 由于本周已经发生了两次,所以我有点担心。这可能是高清故障的征兆吗? (编辑)更多信息 git仓库位于我通过SSH从OSX访问的ubuntu服务器上。我还使用Samba的Sublime文本来访问代码库。我已经禁用了Sublime文本Git插件,我认为这可能是导致问题的原因。从那以后没有发生过,但我也没有任何证据。

4
我应该如何坚持修改域名记录以保护共同所有者?
我知道记录格式中没有任何字段与共同所有权明确相关。 这种情况必须经常出现-一方拥有(即注册人)域名,另一方实际运营站点。以我为例:我的雇主即将将电子商务站点许可给另一家公司。我的雇主是域名的当前注册人。 显然,被许可方应该有权访问域名记录,以将域名重新指向其自己的Web主机,添加/更改名称服务器等,更改管理员联系地址,更改整个MX记录等。被许可人只是被许可人,而不是实际的所有者/注册人。这很重要,因为例如,如果被许可人违反了许可协议(例如通过出售竞争对手的产品),我的雇主有权终止该协议-但是,如果他们无法重新控制域名,那将不值多少。 到目前为止,我有几个想法: 依靠我们的注册服务商提供的“两级”帐户授权(大多数其他人也可能这样做),即保留我自己作为帐户的超级用户,将被许可人添加为该帐户的管理员,这样他们就可以完全“工作”访问记录; 锁定域以防止被许可方转让(“状态”字段下的“客户端被禁止”),尽管也许可以通过管理员访问权限进行更改。 在某些情况下,我们从“专业域名所有者”那里购买了域名,并使用了我们的注册服务商提供的托管服务,效果很好。此类服务背后的意图显然是在交易过程中保护买卖双方。针对许可证类型交易的服务,而不是所有权的完全变更显然必须具有完全不同的功能,我仍然认为,也许这样的服务可能由一个或多个注册服务商提供。 如果您想回答“这是法律问题”,请不要回答。这不是法律问题或系统管理员问题,而是业务问题。与许多业务问题一样,它具有来自各种功能(法律,IT等)的多种可能解决方案。法律解决方案体现在许可协议中。Sys Admin解决方案针对域名记录的管理细节进行管理,以便协调双方(显然)出于不同原因而需要访问同一域名记录的两方可能存在的利益冲突。

2
SBS 2k8备份不会刷新Exchange日志
我们正在使用SBS 2008附带的Small Business Server Backup将所有驱动器备份到iomega iSCSI-Target。备份工作正常,一切都显示为成功备份。 但是交换日志已登录,C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group并且C:\Program Files\Microsoft\Exchange Server\Mailbox\Second Storage Group未刷新。 什么会导致这种行为?

2
作为代理服务器运行时的Apache服务器状态
我们正在将apache作为代理服务器运行,并且在apache之后有tomcat。我们正在使用server_status模块,但是当我们尝试访问server_status时,https://host.com/server-status它重定向到tomcat并显示404错误。我对此很陌生,尝试过apache文档,但无法找出解决方案。Fyi。我们启用了ssl 当前的ssl.conf设置: ProxyRequests Off ProxyPreserveHost On <Proxy http://localhost:8081/*> Order deny,allow Allow from all </Proxy> ProxyPass / http://localhost:8081/ ProxyPassReverse / http://localhost:8081/ ProxyPassReverse / http://myhost:8081/ <Location /server-status> SetHandler server-status Order deny,allow Deny from all Allow from 10.90 </Location> 建议更改后 ProxyRequests Off ProxyPreserveHost On <Proxy http://localhost:8081/*> Order deny,allow Allow from all </Proxy> ProxyPass …

1
获取WebDav上传进度和状态(Linux,davfs2)
我在带有davfs2 1.4.6的Linux机器上使用WebDAV。当我将文件复制到已安装的WebDAV服务时,它的运行速度非常快,就像常规的本地驱动器操作一样。实际上是因为文件首先复制到~/.davf2/cache目录中。但是,我如何知道上传已完成以及在哪里可以看到当前进度?有没有办法知道由于空间或文件大小限制而导致上传失败?

3
使用IPMI工具从HP Superdome(sx2000)检索IPMI传感器数据
我正在尝试使用LAN上IPMI协议从HP Superdome(sx2000)提取数据传感器。我启用了IPMI协议,并在Superdome上设置了IPMI协议的密码。我使用ipmiutil工具作为IPMI客户端,该客户端连接到服务器,但获得了无意义的结果(与ipmiutil手册页相比)。下面是命令的输出: C:\ipmi>ipmiutil.exe sensor -N <IPADDRESS> -P <IPMI_PASSWORD> ipmiutil ver 2.83 isensor: version 2.83 Opening lan connection to node <IPADDRESS> ... Connecting to node <IPADDRESS> -- BMC version 1a.03, IPMI version 1.5 _ID_ SDR_Type_xx ET Own Typ S_Num Sens_Description Hex & Interp Reading 0001 SDR EntA 08 0b d2 00 …
2 hp  ipmi  hp-ux  ipmitool 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.