服务器管理员

系统和网络管理员的问答

1
Synology iSCSI Target-使用PXE安装Ubuntu Server
大规模iSCSI / PXE菜鸟在这里。 我的Synology NAS上有一个iSCSI目标,该目标已使用VirtualBox附加在OSX中。我在以下Synology上安装了Ubuntu Server安装ISO/volume1000/IsoMount/ 是否可以在不通过VirtualBox客户端计算机路由流量的情况下使用PXE将Ubuntu Server安装到iSCSI目标?我目前在劣质的互联网连接上处于远程状态,想在我不在时开始该过程。 这是可能的还是未受过教育的白日梦? 任何帮助表示赞赏。

2
LINUX:帮助我递归搜索整个目录以查找文件的上次访问时间
我最近继承了一个linux Web服务器,以前的管理员用来将所有内容基本转储到其中。我想做的是获取目录中所有文件的列表,这些文件按文件的上次访问时间排序,目的是清除公司根本不使用的所有文件。 我假设我应该回溯3个月,因为该公司非常活跃地使用其Web服务,因此过去3个月中未曾碰到的任何事情很可能是无价之宝。 我尝试使用以下答案:https : //stackoverflow.com/questions/5566310/how-to-recursively-find-and-list-the-latest-modified-files-in-a-directory-with-s 但这似乎效果不佳。 请注意,我的Linux管理员经验非常初级。我精通部署和配置,但是我从未做过这样的事情(我的意思是,这件事真是一团糟,非常需要它)。 我不反对将PHP脚本组合起来运行它,但是,同样,我对PHP也不那么热衷,因此我确实需要这里的一些直接帮助。理想情况下,如果我确定发现的所有内容都是垃圾,那么运行一个脚本,该脚本还将具有一个删除文件选项,将是我的工作,甚至是可以包含rm的BASH命令序列。 在此先感谢您提供的所有帮助,我非常感谢。
1 linux  bash 

4
如何使两台Web服务器在一台机器上工作?
我想在一个刚购买的VPS上托管五个网站。 一个名为domain.com的PHP网站 django网站beta.domain.com phpmyadmin,将是domain.com/phpmyadmin phppgadmin,将是beta.domain.com/phppgadmin 和另一个名为domain2.com的Django网站 所有的django网站将在Apache中以mod_wsgi运行,所有的PHP网站将在具有fastcgi的nginx中运行。 我是开发人员,而不是系统管理员,因此我很难确定实现此目的的最佳方法。我从nginx运行PHP的原因是因为我不想安装mod_php,这使我可以在apache中使用worker MPM。 目前,我有8080端口运行的nginx和80端口运行的apache。当我转到domain.com时,它会打开django网站。当我转到domain.com:8080时,它会打开PHP网站。 就像我之前说过的,我不是服务员,所以这些东西让我很头疼。有什么方法可以通过nginx访问内容而无需在URL中指定端口号?

1
Ubuntu 12.04 Server-具有uWsgi的Django无法正常工作
我对使用服务器非常陌生。我正在尝试使用uwsgi和nginx在Ubuntu 12.04 AWS上运行Django。 我找到了我正在关注的教程:http : //uwsgi.readthedocs.org/en/latest/tutorials/Django_and_nginx.html 我创建了一个虚拟的evn: virtualenv uwsgi-tutorial cd uwsgi-tutorial source bin/activate 然后我使用pip安装了Python和Django。然后我开始了一个名为Django的项目mysite 然后我安装了uwsgi pip install uwsgi 然后我创建了一个test.py文件: def application(env, start_response): start_response('200 OK', [('Content-Type','text/html')]) return "Hello World" 然后我跑了uwsgi: uwsgi --http :8000 --wsgi-file test.py 本教程声称,如果我将浏览器指向我http://myip:8000应该Hello World在浏览器中看到的内容。但是,我的浏览器处于等待状态,好像它根本没有连接到服务器一样。 运行时,uwsgi --http :8000 --wsgi-file test.py我在终端中得到以下输出: *** Starting uWSGI 2.0.1 (64bit) on [Tue Feb 25 …
1 ubuntu  django  uwsgi 


1
Slurm:对于GPU和仅CPU作业有两个单独的队列
目前,我们已设置Slurm来管理一个由六个节点组成的小型集群,每个集群具有四个GPU。到目前为止,这一直很好,但是现在我们想利用Intel Core i7-5820K CPU来完成仅需要CPU处理能力的作业。每个CPU有六个核心和12个线程,每个GPU需要一个线程/逻辑核心,因此(每个节点)剩余8个线程可用于“仅CPU”作业。 当前配置: 猫/etc/slurm-llnl/gres.conf Name=gpu File=/dev/nvidia0 Name=gpu File=/dev/nvidia1 Name=gpu File=/dev/nvidia2 Name=gpu File=/dev/nvidia3 猫/etc/slurm-llnl/slurm.conf(节选) SchedulerType=sched/builtin SelectType=select/cons_res SelectTypeParameters=CR_Core AccountingStorageType=accounting_storage/none GresTypes=gpu MaxTasksPerNode=4 NodeName=node1 CoresPerSocket=4 Procs=8 Sockets=1 ThreadsPerCore=2 Gres=gpu:4 State=UNKNOWN NodeName=node2 CoresPerSocket=4 Procs=8 Sockets=1 ThreadsPerCore=2 Gres=gpu:4 State=UNKNOWN NodeName=node3 CoresPerSocket=4 Procs=8 Sockets=1 ThreadsPerCore=2 Gres=gpu:4 State=UNKNOWN NodeName=node4 CoresPerSocket=4 Procs=8 Sockets=1 ThreadsPerCore=2 Gres=gpu:4 State=UNKNOWN NodeName=node5 …

1
建立StrongSwan连接时运行自定义脚本
我在Debian主机上设置了StrongSwan VPN服务器,并且想在客户端连接到它时运行自定义脚本。我唯一想出的就是定期检查日志文件的内容,但这似乎很麻烦。 是否有任何方法可以指定要在连接时执行的脚本,最好以某种方式来推断用于该连接的原始IP和登录信息?

1
扩展和容量规划的最佳实践:仅VM?VM +容器?仅集装箱?集群?还有吗
(我找不到类似的问题,但已经回答了,但由于我是法国学生,所以也许我不使用好话;)) 我要寻找的最接近的答案是:可扩展Web应用程序硬件拓扑最佳实践,但不能解决所有问题 我建立了一个小型私有云(Openstack),我可以在其中运行KVM VM,大多数情况下是为我的数十个网站以及某些客户端运行每个域/网站一个VM。 我计划测试是否可以演变为“混合云”,使某些事物在我的云中运行,而另一些事物在EC2上运行,因此我想确定我的“做事方式”是否最适合我的使用。 这些VM运行CoreOS,然后运行不同的Docker服务(一个用于Nginx的容器,一个用于pgsql的容器,等等)。如果一项服务在某些方面太“短”了,那么我要么创建一个更大的VM,将旧的VM复制到更大的VM并删除旧的VM,要么我为需要的服务创建一个专用的VM(例如,第二个专用于Nginx的VM,以处理更多连接。 但是,我想知道自己是否做错了事。 我之所以选择使用此“模型”,是因为我希望在不同的域/客户端之间建立强烈的隔离,因为我想回想起过去并逐渐习惯Docker,并且因为我发现Docker是最有效的方法之一快速部署服务。 我是否应该只使用每个服务具有一个VM(而不是每个域一个VM)的VM(因此没有容器)? 还是应该只使用容器来分隔不同的服务,然后在节点中将所有服务混合在一起运行?就像数十个容器,它们分别提供不同的服务和不同的客户?然后,如何有效隔离不同的域/客户端?然后如何扩展这些服务?仅添加更多节点? 还是我应该创建一个由大型VM或裸机组成的集群,然后使用它们来创建一个大型CoreOS集群,该集群应该能够通过向其添加更多裸机节点来进行扩展?然后适用于容器的相同问题。 抱歉,如果我的问题看起来太愚蠢,新手或不合适,但我宁愿现在问,而不是什么时候退后一步;) 任何建议欢迎:) ÿ


3
Oracle 10g:备份失败,日志磁盘已满-如何恢复数据库?
由于备份失败,用于事务日志的磁盘似乎已满。 该数据库不接受连接,因此无法手动运行(HP Data Protector)备份作业。 Oracle实例直接从SAN挂载磁盘,因此Windows没有可见的任何文件系统。 但是,数据库服务正在运行。是否有一种简单的方法来恢复数据库,也许可以重新运行备份作业并还原服务? 假设除tnsping之外没有Oracle知识;-) 在alert_mydatabase.log文件中,(<orahome>\admin\mydatabase\bdump\), ORA-15041: diskgroup space exhausted ... ARCH: Archival stopped, error occurred. Will continue retrying ...

4
在网络适配器上启用接收方扩展和IPsec任务卸载v2
在Windows Server 2012 RTM上运行最佳实践分析器(此虚拟服务器在hyper-v主机上运行)时,我收到两个配置警告。 在网络适配器上启用接收方缩放(RSS) 我运行以下PS cmdlet: Enable-NetAdapterRss-名称* 输出: Enable-NetadapterRss : The request is not supported. At line:1 char:1 + Enable-NetadapterRss -Name * + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidOperation: (MSFT_NetAdapter...1E300D0AB920}"):ROOT/StandardCi...rRssSettingData) [Enable-NetAdapterRss], CimException + FullyQualifiedErrorId : Windows System Error 50,Enable-NetAdapterRss 接下来,由于PS cmdlet无法正常工作,因此我进入了网络适配器设置。而且,当然,我看不到任何称为“接收方缩放”的选项。 在网络适配器上启用IPsec任务卸载v2(TOv2) 对于这一点,我进入了网络适配器属性(请参见上面的屏幕截图),有一个名为IPSec Offload的选项。设置为“ Auth Header”和“ ESP Enabled”。但是,BPA仍然抱怨未启用此设置。 我是否必须在hyper-v主机的网络适配器上启用这些配置设置?我想知道如何配置这两个选项。 更新: …

1
如何在mod_rewrite RewriteCond中访问GET参数?
我正在尝试从mod_rewrite访问GET参数。 例如,给定以下URL:http : //myserver.com/foo.png?foo=bar 以下规则无法捕获此URL: RewriteCond %{REQUEST_URI} bar [NC] 虽然这个做: RewriteCond %{THE_REQUEST} bar [NC] REQUEST_URI是否不包含GET参数?THE_REQUEST是要走的路吗?

1
强制使用白名单的经过身份验证的smtp电子邮件
我需要一个exim设置,该设置仅允许经过身份验证的smtp电子邮件,例如,电子邮件来自时除外root@servername。这就是我今天所拥有的: acl_not_smtp (custom_begin_outgoing_notsmtp_checkall) deny authenticated = * condition = ${if !eq {root@$primary_hostname}{${address:$h_from:}}} message = REJECTED accept 该解决方案阻止所有未经身份验证的电子邮件。有人有更好的解决方案吗?
1 exim 

2
在域环境中的计算机上安装软件
我正在使用的网络非常小,我的客户端只有2个台式机,它们位于由具有活动目录的Windows Server 2012计算机管理的域设置中。 我的客户在两台计算机上运行着几个不同的天气程序。这些天气程序要求您插入一个代码,该代码又可以使软件进行身份验证并下载RADAR信息。 当我使用用户帐户登录并插入代码时。一切都按预期进行。但是,当您注销用户帐户并再次重新登录时,他们的代码不会保存,这意味着您每次用户登录时都必须重新插入该帐户。 我不寻常的是,我有1个帐户,可以正常运行。我可以登录然后注销,软件会记住代码,仅此而已。但是,所有其他帐户每次登录时都必须重新输入代码。 所有用户帐户都是域管理员,并且所有帐户都具有完全相同的权限。谁能给我有关在何处或需要解决此问题的任何建议? 谢谢。 感谢您的回复。我相信即使我对GPO不太熟悉,也可能需要进一步研究。经过最后几个小时的试验后,我能够确定问题出在注册表中(我认为)。 当我以本地管理员身份安装该软件时,请插入代码以使其正常运行,一切都会正常进行。我可以注销并重新登录,一切都很好。 当我以域用户身份登录时,我插入了代码,一切正常,但是当我注销并重新登录时,代码被删除了,我必须再次插入它们(每次登录/注销时都必须这样做)。 因此,经过数小时的试验,我终于以域用户帐户重新安装了该软件,但是,我将安装目录更改为更改后的名称,以免覆盖本地管理员。这样做之后,我输入了注销的代码,然后又重新输入,一切都很好。但是,当我登录到本地管理员帐户时,代码已被删除。 这样,我就可以相信问题出在注册表之内。但是,这是我所做的,并且不确定如何从此处进行。 如何安装此软件,插入代码并进行设置,以便当用户使用其域用户帐户登录到此计算机时,该软件会记住要使用的代码吗?

1
损坏的fetchmail配置
我正在尝试在OSX 10.5.6机器上配置fetchmail。我已经按照以下步骤设置了.fetchmailrc: poll my.mailserver.com with proto IMAP timeout 30 user "username" is "username" here options ssl keep 我正在使用.netrc文件存储用户名/密码,如下所示: machine my.mailserver.com login username password secret 但是,当我运行fetchmail时,出现以下错误: reading message username@my.mailserver.com:1 of 458 (4436 octets) fetchmail: timeout after 30 seconds waiting for listener to respond. fetchmail: socket error while fetching from username@my.mailserver.com and …
1 mac-osx  email 

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.