服务器管理员

系统和网络管理员的问答

2
nginx:为什么我不能将proxy_set_header放在if子句中?
使用此配置: server { listen 8080; location / { if ($http_cookie ~* "mycookie") { proxy_set_header X-Request $request; proxy_pass http://localhost:8081; } } } 重新加载Nginx服务时出现此错误: Reloading nginx configuration: nginx: [emerg] "proxy_set_header" directive is not allowed here in /etc/nginx/conf.d/check_cookie.conf:5 nginx: configuration file /etc/nginx/nginx.conf test failed 此配置可以正常运行,但不能满足我的要求: server { listen 8080; location / { proxy_set_header …

4
OpenWrt在同一端口上配置标记和未标记的VLAN
我已在MikroTik路由板RB750UP(带有内置交换机的AR7240 CPU的AR7240 CPU)上安装了OpenWrt。我在下面提供了其他详细信息,但我的问题是: 如何在同一端口上配置未标记和标记的VLAN? 我已经成功地分别配置了非标记VLAN和标记VLAN,但是没有针对同一端口进行配置。之所以要这样做,是因为我将Ubiquiti NanoStation loco M2插入了提供无线局域网的端口(需要未标记的帧),但是我也想配置一个标记的VLAN来管理机车(即访问其管理) ip通过标记的货车)。 以下是更多详细信息: 硬件 MikroTik路由器板RB750UP Ubiquiti NanoStation loco M2 swconfig 输出: swconfig dev eth0 help switch0: eth0(AR7240/AR9330 built-in switch), ports: 5 (cpu @ 0), vlans: 16 <snip> 这是RB750的AR7240 / AR9330交换机的布局图(我相信是这样)的链接。 操作系统 OpenWrt BARRIER BREAKER(出血边缘,r36085),使用自定义配置构建 # uname -a Linux OpenWrt 3.8.3 #3 Wed Mar …

2
最低Wifi信号强度的行业标准?
为了建立可靠的连接,是否需要有多强的Wifi信号行业标准?例如,也许Wifi端点设计为可以可靠地连接到-70db信号的规范。 我们正在为办公室设计Wifi网络;我们有一个以db为单位的信号强度图。我们正在尝试确定其与用户实际Wifi连接的对应方式。 另外,它是否随协议或频率而变化?

2
Ubuntu 12.04上的Postgresql 9.2“无效的语言环境名称”
今天,我通过apt.postgresql.org在Ubuntu上精确安装了Postgresql 9.2-直到我被困在“无效的语言环境名称:it_IT.utf8”错误之前,所有操作都相对轻松了: root@ubuntu:/tmp# sudo -u postgres psql -Xc "CREATE DATABASE test TEMPLATE template0 ENCODING 'utf8' LC_CTYPE='it_IT.utf8'" ERROR: invalid locale name: "it_IT.utf8" 我确实跑locale-gen it_IT.utf8了,实际上: root@ubuntu:/tmp# locale -a C C.UTF-8 en_GB.utf8 en_US.utf8 it_IT.utf8 POSIX 日志似乎没有关于postgres为什么无法识别它的任何有意义的信息_IT.utf8 ...您能帮上忙吗?

5
如何将我的部署密钥移至无业游民?
我想将ssh密钥移入无业游民并将其放进去~/.ssh,最简单的方法是什么?我的Vagrant文​​件中包含以下内容: config.vm.synced_folder "conf.d", "/svr/conf.d" config.vm.provision :shell, :inline => "ls -l /svr/conf.d/.ssh" 总数4 -rw-r--r-- 1个无业游民无业游民1670 Mar 26 08:19 id_rsa.mediapop config.vm.provision :shell, :inline => "cp /svr/conf.d/.ssh/id_rsa.mediapop /home/ubuntu/.ssh/id_rsa" config.vm.provision :shell, :inline => "ls -l /home/ubuntu/.ssh" 总数4 -rw ------- 1 ubuntu ubuntu 0 Mar 22 08:56authorized_keys -rw-r--r-- 1 root root 1670 Mar 26 08:59 …
9 vagrant 

1
1GB VPS-Apache Worker MPM-FCGID-最大并发连接数-RAM CAP
我花了一两个星期研究和设置我的服务器,以使用Worker MPM和FCID运行Apache。我正在尝试对其进行优化,以允许尽可能多的并发连接。在Worker MPM上找到良好的信息一直是一场噩梦。 服务器-具有1GB RAM的VPS(关闭Apache仅使用约150MB RAM)我希望Apache具有约750MB的内存使用率CAP-这样我的服务器将永远不会用完RAM。 我已经运行服务器大约两年了,没有任何问题-但是我们最近开始流式传输MP3,这需要更多的并发连接。该服务器还受到了一些较小的DDOS攻击-因此我将设置减少了一吨,以防止服务器内存不足-我还为速率限制添加了一些防火墙规则。 我现在进行的设置看起来运行良好-但是我遇到了一些Segmentation Fault错误 [Sat Mar 23 03:19:50 2013] [notice] child pid 28351 exit signal Segmentation fault (11) [Sat Mar 23 03:56:20 2013] [notice] child pid 29740 exit signal Segmentation fault (11) *** glibc detected *** /usr/sbin/httpd.worker: malloc(): memory corruption: 0xb83abdd8 *** 还有一些内存不足错误 Out of …

3
fail2ban是否监视轮换的日志文件?
fail2ban是否继续监视轮换的日志文件? 例如,我有一个监视/var/log/fail2ban.log的规则,该规则由系统每周(7天)自动轮换一次。我想要一个规则来监视该日志中的被禁IP,以查找在过去10天中被禁止5次的重复违规者。那可能吗?

3
Linux /etc/security/limits.conf说明
任何人都可以解释(或知道来源)提供关于limits.conf中各项的详细信息吗?手册页没有提供太多细节。 例如,它说: rtprio maximum realtime priority allowed for non-privileged processes (Linux 2.6.12 and higher) priority the priority to run user process with (negative values boost process priority) 这些有什么不同?他们可以采取什么价值观?他们默认为什么? 有些项目是显而易见的,但是在哪里可以找到更好的解释(默认值,范围,其实际含义等): data maximum data size (KB) fsize maximum filesize (KB) memlock maximum locked-in-memory address space (KB) cpu maximum CPU time (minutes) nice …

2
绕过特定IP的openvpn
我的台式机运行的是Trisquel GNU / Linux 6.0(基本上是Ubuntu 12.04的自由版本),我使用OpenVPN连接到商业VPN提供商以进行Internet访问。 它目前通过VPN路由我的所有流量,这很棒,但是我正在寻找一种方法,允许对一个特定IP地址的请求绕过VPN。我敢肯定有办法,但是重复的网络搜索还没有发现任何东西(最好的发现是在Windows的Cisco VPN客户端上执行此操作的说明)。 你能帮我吗? 谢谢。
9 linux  vpn  routing  openvpn  gnu 

2
文件大小超出限制后,Logrotate不会旋转文件。
从logrotate联机帮助页。 除非一天的日志标准基于日志的大小,否则它将一天最多修改一次日志 根据手册页,如果配置基于日志大小,则logrotate应该旋转文件。但是,即使文件大小大于100k,我的文件也没有得到。 有人可以指出是什么问题。 我的配置 /home/jetech/work/lampstack-5.3.9-0/apache2/logs/access_log { copytruncate compress # dateext rotate 365 size 100k olddir /home/jetech/work/lampstack-5.3.9-0/apache2/old_logs notifempty nomail missingok }

2
即时修改nginx代理的数据
我有一个Nginx设置,可以接收来自外部主机的请求并将它们代理到内部服务器。 配置看起来像这样: server { listen 10.0.0.66:443; server_name my.example.com; root /websites/my.example.com ssl on; ssl_certificate /websites/ssl/my.example.com.crt; ssl_certificate /websites/ssl/my.example.com.key; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $remote_addr; proxy_set_header Host $http_host; location / { proxy_pass https://10.0.0.100:3000/; } } 出于实验/测试目的,我希望能够通过任意二进制文件运行内部主机答复的内容,并以二进制文件响应的内容进行响应。 对于例如,如果我想压缩HTML在代理我会贯穿htmlcompressor服务器的响应,然后发送输出作为代理的响应给客户端。最终结果将是最终客户获得缩小的html。 我知道nginx有各种各样的插件和示例来完成本地提供的数据,但是如何为代理设置它呢?

3
如何在没有用户交互的情况下使用APT安装软件包?
我有一个脚本,可以下载并替换Debian squeeze中的内核头文件。 function fixHeaders(){ #Replace the kernel headers from OVH with standard kernel headers... aptitude -y install linux-image-2.6.32-5-amd64 sed s/'GRUB_DEFAULT=0'/'GRUB_DEFAULT=1'/g update-grub echo "Rebooting the machine. Run this script again after reboot and choose option 2." sleep 1 reboot } 我遇到的问题是,在aptitude下载软件包后,它将脚本扔到了文本gui中,并向用户提出了一系列问题。有什么方法可以跳过此操作或在适当的时间发送选项卡/输入以为所有答案选择“确定”吗?

2
如何使sshfs + VPN + git成为可容忍的工作环境?
当前,我正在从事的项目的代码库位于公司服务器的远程位置。它必须保持那样。远程git存储库也无法公开。 我当前的设置是: 连接到 VPN 运行sshfs以安装代码的副本 开始编写代码 完成后:ssh连接到远程服务器并在其中运行git命令 问题在于,VPN有时会sshfs掉线,因此我的安装中断,我的IDE冻结。我要做的是手动重新连接VPN,然后sshfs再次运行,然后恢复工作。 但是随着VPN跌倒次数的增加,它变得很烦人。 因此,我想知道是否sshfs为某种类型的缓存设置了任何设置,这些设置将允许我工作,并且仅在VPN恢复后才同步更改。 这可能没有任何意义,因为如果远程驱动程序不可用,则没有任何可写入的内容。那么,使用某种watch东西并用于rsync双向移动更改的另一种设置又如何呢(无论是保存文件时还是执行时git pull) 我不能只是git clone,因为我不能重现整个环境以在“本地”工作(数据库和其他东西) 该代码必须在他们的服务器中,以便我测试/查看我的工作,我必须访问一个URL,即我的沙箱。每当我要查看更改时,我都无法git push。
9 ssh  vpn  rsync  git  sshfs 

2
是否需要手动设置接口广播地址?
我正在从旧的网络工具转换脚本: ifconfig eth0 192.168.2.1 netmask 255.255.255.0 到iproute2: ip link set eth0 up ip addr add 192.168.2.1/24 dev eth0 并且我注意到新命令默认情况下不设置广播地址。 什么是: 1: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP link/ether 1c:6f:65:c5:d6:d7 brd ff:ff:ff:ff:ff:ff inet 192.168.2.1/24 brd 192.168.2.255 scope global eth0 就是现在: 1: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP …
9 linux  iproute2 

4
如何从命令行更改vCenter Server Appliance IP?
我已在特定网络上的物理服务器上安装了vCenter 5.1设备(VCSA),并为其分配了内部IP。然后,该服务器(Dell R620)转到远程托管位置,在该位置,该服务器连接到IP和子网完全不同的网络。 因此,我现在需要做的就是将vCenter Server的IP更改为可以远程连接的IP。 我只能从主机本身内部启动设备的控制台。 如何使用命令行(以root用户身份登录)更改设备IP?

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.