服务器管理员

系统和网络管理员的问答

3
通过cron rsync。如何启用日志记录?
我正在使用rsync将远程服务器备份到另一台计算机。 在cron.daily中,我有一个文件: rsync -avz -e ssh root@example.com:/ /mybackup/ 它使用公钥/私钥对进行登录。这似乎在大多数情况下都有效,但是,我(愚蠢地)只通过查看我知道每天都会更改的一些重要文件(MySQL转储)上的日期来进行真正的检查。显然,该文件之后可能会发生错误。 有时会失败。当我手动运行它时,有时会发生诸如“客户端重置”之类的事情。 记录它的最佳方法是什么,以便我可以确定地检查它是否完成?cron日志不指示任何错误。我没有尝试过,但是备份计算机上较旧版本的CentOS上的rsync手册页没有显示--log-file选项。我想我可以使用>重定向stdout,但是我真的不想知道每个文件。我只想知道这一切是否奏效。 谢谢
8 rsync 

6
没有经验的管理员的Linux文件服务器
我自愿参加的一个慈善机构希望为其大多数Windows机器(约五台XP和7台机器,时不时带有一些Mac笔记本电脑)提供文件服务器。对于服务器,我有一台配备Intel Core 2 Duo 3GHz处理器,4GB DDR2 400MHz RAM和500 GB HDD的PC。(我应该指出,他们目前没有任何服务器-他们只是使用Windows共享其中一台PC上的文件夹。) 什么是Linux发行版,可以轻松配置Windows文件服务,又足够稳定和安全,无需专家sysadmin即可保护敏感数据? 我猜想Debian发行版可能适合安全法案,但是我不知道有什么适合新手sysadmin的。 此外,是否有任何杀手级应用程序使此操作易于管理和设置(特别是作为Windows文件服务器- 此答案是一个很好的例子)?FreeNAS是否足够?设置完成后,我需要采取哪些最小的措施来保护数据安全? 我找到了这个有用的答案,但这并不是我仅想启动,运行和维护安全文件服务器的问题。

4
如何在建筑物之间建立网络?
我需要一些帮助,以便在分布在我大学多个建筑物中的数百台计算机之间建立网络。是的,这将是我大学计划的一部分。 请查看此图像,它将使您对我要实现的目标有足够的了解。 所有建筑物中的所有计算机都应能够连接服务器。 一旦网络建立,将在Intranet上提供一组服务,并且网络使用将是中等的。好吧,假设会有一个电子邮件服务器和一个http服务器。我的观点是,我承担不起太多的性能损失。 将一栋大楼中的计算机彼此连接起来很容易,但是,我对如何将它们全部连接到服务器一无所知。我的意思是,仅用一根电缆不足以将1座建筑物连接到服务器,对吗? 我应该如何搭配呢?我不希望有详细的配置。只要抬起头就行。

2
如何检查是否为已启动的服务设置了OS X“禁用”标志?
根据launchctl(强调我的)的手册页: -w覆盖Disabled键并将其设置为false。在以前的版本中,此选项将修改配置文件。现在,Disabled键的状态存储在磁盘上的其他位置。 由于已在.plist文件本身中不再设置禁用标志的当前状态,因此检查Disabled密钥不再是判断服务是否在下次启动时运行的准确方法。 该“磁盘上的其他位置”在哪里?更重要的是(更重要的是),如何检查此标志是否设置? 另外,是否可以将服务设置为在下次启动时运行而无需强制立即启动(与一样launchctl load -w /Library/LaunchDaemons/my-service.plist)?

3
SNMP-所以我有一个MIB。怎么办?
我似乎无法全神贯注于MIB的目的。我收集了供应商提供给我的〜20个MIB文件,但是我该怎么办? 我也有一些由供应商提供的OID,这些OID似乎无效。当我发出“ snmpget -v1 -c public 192.168.0.123 .1.4.6.3.2.6.2”(假设这是有效的OID)时,出现错误,指示变量未知。这听起来像硬件配置问题吗?我是否需要将MIB“加载”(由于缺少更好的用词)? 不幸的是,供应商对回复我的问题的电子邮件完全没有反应,因此,我们将不胜感激。
8 snmp 


1
IIS7返回的日期标头错误
我正在从IIS 7提供ASP.NET应用程序,但是我们遇到了一些奇怪的Cookie问题。该代码在其他环境中运行良好,因此我们假设这是特定于此服务器的(相关问题)。 我们一直在查看返回的http标头,有人指出日期http标头显示的是1月1日,而不是今天的日期(到目前为止,无论当前日期是什么,它始终显示该日期)。系统时钟设置正确(我们也可以通过DateTime.Now正确打印当前时间/日期),因此我们无法弄清为什么现在可以工作。有人有什么想法吗?这是红鲱鱼吗? 谢谢,詹姆斯
8 iis  asp.net  cookies 

2
OpenSolaris ..嗯,它变得不再维护了吗?
http://hub.opensolaris.org/bin/view/Main/downloads 我看到2009.06的下载和2010.03的开发下载。(当前月份为2010-12) 这是否意味着自从Oracle收购Sun .. OpenSolaris以来,该交易已停滞不前?(至今)

4
Ubuntu云版本如何通过ssh强制执行“无root登录”?
我想调整ubuntu云版本默认设置,其中拒绝root登录。 尝试连接到这样的机器会产生: maxim@maxim-desktop:~/workspace/integration/deployengine$ ssh root@ec2-204-236-252-95.compute-1.amazonaws.com The authenticity of host 'ec2-204-236-252-95.compute-1.amazonaws.com (204.236.252.95)' can't be established. RSA key fingerprint is 3f:96:f4:b3:b9:4b:4f:21:5f:00:38:2a:bb:41:19:1a. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added 'ec2-204-236-252-95.compute-1.amazonaws.com' (RSA) to the list of known hosts. Please login as the ubuntu user rather than root user. …
8 ubuntu  security  ssh  root  cloud 

3
使用Puppet部署我们自己的软件?
(对于这个问题的愚蠢,我们事先道歉。我通常是程序员,而不是系统管理员,但我本人要自己去自动化一些事情,并清理一些自动化的事情,但不是最漂亮的方法。 。:-) 我一直在研究用于将软件自动部署到一堆服务器的各种工具,例如cfengine,Puppet和Chef。到目前为止,Puppet看起来最吸引人,但我当然还没有承诺任何事情。 这些工具看起来都可以很好地完成工作,以使一堆服务器使用预打包的软件保持最新。 我不明白的是:人们如何使用一种工具(如Puppet)来管理我们自己的内部软件的部署?我想我不知所措我,因为我已经看到了一千教程展示了如何保持阿帕奇ensure => latest(这是很酷的),但是没有一个相当相当于我用例的今天,这是更多的东西一样: 当人类按下按钮时, 从版本控制存储库B中提取分支A 运行命令C进行编译 将二进制文件D复制到服务器E1到E10 在每台服务器上,运行命令F以使所有更改生效 Puppet听起来很棒,我完全看到了声明性,幂等配置优于某些shell脚本的优势,但是我还没有看到任何有关“您要将Shell脚本更新为Puppet(或Chef,或cfengine)的教程”,应该做”。有这样的事吗?对其他人来说,显而易见的是如何采用Puppet文档中提供的内容并复制我想要的行为?我只是不明白吗? 到目前为止,对我来说听起来像是,人类(#1)会手动打包Puppet外部的软件(#2和#3),手动更新Puppet配置,这会触发Puppet更新服务器。 .. 也许?(我确定您可以告诉我,这里我有点困惑。) 谢谢!

1
考虑6个Exchange许可证和TMG 2010的Exchange 2010 HA拓扑的最佳做法
考虑到以下因素,什么是最佳拓扑? 6 x Exchange 2010标准许可 2个单独的位置,假定在出现链路问题时可以支持冗余 4个具有Forefront Security和Forefront Protection / Security的Forefront TMG 2010 使用这些Exchange在全球多个地点。大多数位置将通过VPN隧道连接(肯定是托管Exchange的位置)。 我在想这样的事情: 主要位置(大约70-100人): NLB 2x TMG 2010 1x Exchange 2010 CAS / HUB角色 2个Exchange 2010邮箱角色(主动+被动) 位置支持(约20人): NLB 2x TMG 2010 1x Exchange 2010 CAS / HUB角色 2个Exchange 2010邮箱角色(主动+被动) 管理层希望确保在主要位置出现问题(电源故障,链路丢失等)的情况下,第二个位置可以支持来自世界各地的所有流量,反之亦然。我们有6-7个地点,以后还会有更多地点(不是很大,但每个地点大约有10人以上)。 我确实知道CAS / HUB是单点故障(并且没有NLB),但是我只是缺少更多许可证来对此做一些冗余。 您如何看待这种方法?您认为哪种方法更好?

4
有人用一个开关就使整个网络崩溃
抱歉,这可能不是一个真正的问题,但是我敢肯定,这将使您在世界末日的情景享受上有所作为。 我的公司是一家大公司的承包商。我们需要将各种设备插入其内部网络。它们具有(安全性)限制,可以防止我们将交换机或路由器插入其可用的任何以太网插孔。(为什么这甚至有意义?) 现在,由于我们确实需要多个插孔,我们要求他们为我们解除这一限制。他们告诉我们他们做到了。当我们到达现场时,我们将一个开关(非常基本的东西)插入了插孔,然后整个世界都结束了。他们经历了严重的网络故障,并收到“重复的ip,重复的mac”等日志,整个工厂陷入停顿。 当然,我们被指控为这一混乱负责。我和我的同事们完全不知道如何发生。您是否知道为什么一台交换机会导致整个网络崩溃?

3
centos 100%的磁盘已满-如何删除日志文件,历史记录等?
由于磁盘空间已满,mysqld无法启动: 101221 14:06:50 [ERROR] /usr/libexec/mysqld: Error writing file '/var/run/mysqld/mysqld.pid' (Errcode: 28) 101221 14:06:50 [ERROR] Can't start server: can't create PID file: No space left on device 正在运行df -h: Filesystem Size Used Avail Use% Mounted on /dev/sda2 16G 3.2G 12G 23% / /dev/sda5 4.8G 4.6G 0 100% /var /dev/sda3 430G 855M …

2
Linux RAID-0性能不能超过1 GB / s
我无法从设置中获得最大吞吐量。硬件如下: 双四核AMD Opteron(tm)处理器2376 16 GB DDR2 ECC RAM 双Adaptec 52245 RAID控制器 48个1 TB SATA驱动器设置为2个RAID-6阵列(256KB条带)+备用磁盘。 软件: 普通香草2.6.32.25内核,针对AMD-64编译,针对NUMA优化;Debian Lenny用户群。 基准测试运行:disktest,bonnie ++,dd等。所有结果均相同。这里没有差异。 io调度程序:没有。是的,这里没有技巧。 到目前为止,我基本上一直认为,对多个物理设备进行条带化(RAID 0)可以大致线性地提高性能。但是这里不是这种情况: 每个RAID阵列可实现约780 MB / s的持续写入和1 GB / s的持续读取。 同时使用两个不同的过程同时写入两个RAID阵列的速度为750 + 750 MB / s,从两者读取的速度均为1 +1 GB / s。 但是,当我使用mdadm或lvm将两个阵列条带化时,写入速度约为850 MB / s,读取速度约为1.4 GB / s。至少比预期少30%! 对条带化数组运行两个并行的写入器或读取器进程并不能提高数字,实际上,这会进一步降低性能。 那么这里发生了什么?基本上,我排除了总线或内存争用,因为当我同时在两个驱动器上运行dd时,聚合写入速度实际上达到1.5 GB / …


By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.