服务器管理员

系统和网络管理员的问答

2
如何将最新代码推送到自动缩放组中
如何将最新代码推送到自动扩展组的计算机中 我试图在运行生产服务器AWS用auto scaling framework。 我想知道如何将新发布的代码部署到运行的生产服务器中。 我现在不在乎down time。 我nginx使用反向代理来 运行Web服务器puma 执行此任务的通常做法是什么? 我认为要登录AWS控制台,请找到所有服务器IP和SSH。更新代码库并重新启动puma Web服务器不是维护优质产品的好方法

1
仅在Linux客户端上的Openvpn TLS握手错误
我将我的VPN配置为接受服务器上udp 1194上的流量。 我生成了3个.ovpn文件,包括密钥和证书。我在Windows Openvpn客户端和Android Openvpn connect上测试了3个配置文件,没有任何问题。 现在,我正在尝试使其在Debian系统上运行,但是我无法弄清为什么它无法运行。客户端与Windows pc在同一网络下,因此我认为防火墙无法阻止它。 Debian客户端仅在TLS身份验证报告期间超时:TLS密钥协商失败...,并且TLS握手失败。 在服务器端,我可以看到一个数据包“ TLS:..的初始数据包”,然后在这里我们还有一个 60秒后出现TLS错误:TLS错误:TLS密钥协商失败。 我能做什么?
1 openvpn 

1
Postfix无法接收邮件
我有一个VPS,安装和设置Postfix和达夫科特的Ubuntu 10.04下一个单一的系统用户这个和这个导游。我可以发送电子邮件,但无法接收。我有一个域名tema.ee,其中包含所有必要的DNS记录 tema@artemis:~$ host tema.ee tema.ee has address 46.182.27.240 tema.ee mail is handled by 10 tema.ee. tema@artemis:~$ host -t NS tema.ee tema.ee name server ns2.selectel.org. tema.ee name server ns1.selectel.org. /var/log/mail.log除了imap登录和断开消息连接外,什么时候我都不会收到电子邮件。 主机文件: tema@artemis:~$ sudo cat /etc/hosts 127.0.0.1 localhost 46.182.27.240 tema.ee artemis 主机名: tema@artemis:~$ hostname -f tema.ee Netstat输出: tema@artemis:~$ netstat -tap Proto …
1 ubuntu  email  postfix 

2
HP SL250s无法从网络启动,对DHCP也不显示
我有一台HP Proliant SL250s Gen8(右侧)服务器,该服务器显然无法从网络启动。如果我将系统配置为在BIOS中进行PXE引导,或者如果我按F12键,则它确实会启动Intel引导代理程序(用于netboot)并声称正在尝试DHCP。但是,系统无法启动。此外,tcpdump -i eth0 -s 1500 port bootps or port bootpc在引导过程中在PXE服务器上运行不会显示来自服务器MAC地址的任何DHCP请求。 我已经确认使用相同的交换机端口和电缆的第二台服务器能够使用我的PXE服务器进行引导。当引导第二台服务器时,以上tcpdump命令成功捕获了DHCP请求。 我以前没有使用过HP服务器。我错过的某个地方的BIOS中是否有一个“使其启动”按钮?;-)

1
依赖项失败:POSTGIS RHEL6
我正在尝试在RHEL6.3x64上安装POSTGIS。 为此,我使用了以下步骤 已安装epel-release-6-7.noarch.rpm 百胜安装postgis 存在依赖性问题,无法安装。 Loaded plugins: product-id, security, subscription-manager Updating certificate-based repositories. Unable to read consumer identity Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package postgis.x86_64 0:1.5.3-1.el6 will be installed --> Processing Dependency: /usr/bin/rebuild-gcj-db for package: postgis-1.5.3-1.el6.x86_64 --> Processing Dependency: proj for package: postgis-1.5.3-1.el6.x86_64 --> …

2
SATA硬重置链接
这是我的dmesg输出: ata2.00: exception Emask 0x0 SAct 0x2 SErr 0x0 action 0x6 frozen ata2.00: cmd 60/48:08:6f:13:3a/00:00:01:00:00/40 tag 1 ncq 36864 in res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout) ata2.00: status: { DRDY } ata2: hard resetting link ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300) ata2.00: configured for UDMA/133 ata2: EH …
1 sata 


1
用户的AD登录审核
我想审核用户的最后登录-不幸的是,我们有10个域控制器,并且没有集中式日志记录软件。 我的问题是从用户'x'请求最后一次'n'登录事件的最佳方法是什么。然后,我计划对每个域控制器执行$ PS-Session并汇总所有结果。 我的目标是确定他们的帐户是否已从未知设备/位置连接。 任何帮助将不胜感激。我怀疑我必须对Get-Eventlog进行处理,然后对过滤器进行处理?

1
使用mod_rewrite的.htaccess重定向规则
我有一个PHP脚本,可根据查询从数据库动态生成内容。用户可能会在文本框中搜索用户名“ mark”。内容由PHP提供,位于www.domain.com/?username=mark,尽管我希望用户将提供的URL视为www.domain.com/username/mark.html。同样,用户可以按配置文件(整数)进行搜索。内容在www.domain.com/?profile=2上生成。我希望用户将提供的网址视为www.domain.com/profile/2.html。这可行吗? 这是我的.htaccess文件: RewriteEngine On RewriteRule ^username/([^/]*)\.html$ /?username=$1 [L] RewriteRule ^realname/([^/]*)\.html$ /?realname=$1 [L] RewriteRule ^profile/([^/]*)\.html$ /?profile=$1 [L] 已启用Mod_rewrite,但此文件似乎无法正常工作。

1
App MSI安装在新映像的PC(Win10)上挂断[关闭]
我正在研究第1层引发的问题。我有一个专有应用程序,该应用程序内置于MSI中,可以与VBscript一起部署。我没有进行构建,也没有访问源文件的权限。 在已经上网了一段时间的PC上,安装过程大约需要2分钟,并且可以正常运行。在新映像的PC(具有相同映像!)上,安装只会挂起并且永远不会完成。一些文件和快捷方式已复制到相关目录,但安装程序未完成,该应用程序也无法启动,因此某些核心功能无法通过。 Windows事件日志中没有任何相关消息出现。此时安装日志总是挂断: InstallShield 6:55:08: Registering file c:\Program Files (x86)\[app]\[subfolder]\Lib\igVIEW15a.ocx (32-bit) 整个日志中还包含以下几种: InstallShield 6:55:08: Error loading ISBEW64.exe...File does not exist InstallShield 6:55:01: Error extracting ISBEW64.exe from ISRegSvr.dll 我认为软件包或脚本在大多数系统上都不会损坏,只是在某些系统上没有。我在想缺少某种相关的核心文件或注册表项。Google告诉我这些是InstallShield文件,但是不幸的是,它们的支持论坛没有付费用,因此看不到那里的任何简单修复程序。 我已经为此工作了两天,我感到很困惑。有任何想法吗?

4
自定义名称服务器专用托管
我有一台高端专用服务器,将使用它托管大约3到4个客户端网站。 如何为他们提供自定义名称服务器地址? EG:1and1说名称服务器必须是ns54.1and1.co.uk和ns55.1and1.co.uk 我可以设置ns1.mydomain.com和ns2.mydomain.com,然后为每个设置A记录到ns54.1and1.co.uk和ns55.1and1.co.uk的实际IP地址吗? 以上工作吗?设置自定义名称服务器名称的最简单方法是什么? 谢谢!

1
我可以在lvextend之后lvreduce而不会丢失其中的ext4分区吗?
在将根分区从一个磁盘移动到另一个磁盘的拙劣尝试中,我做了以下工作: 添加新磁盘 用parted分区(第3部分现在几乎完全填满了磁盘) 初始化物理卷 $ pvcreate /dev/sdb3 Physical volume "/dev/sdb3" successfully created 扩展了卷组以包括此新的物理磁盘 $ vgextend myvg /dev/sdb3 Volume group "myvg" successfully extended 扩展了逻辑卷(我认为这是我的专长:我认为我应该将pvmove的内容添加到该组中的新pv中-有人可以确认吗?) $ lvextend /dev/mapper/myvg-root /dev/sdb3 我现在想撤消lvextend,然后继续执行将旧物理卷的内容移到新物理卷的原始计划。我是否可以减小逻辑卷(我还没有用resizefs之类的东西触及/ dev / mapper / myvg-root中的ext4分区)而不必担心会损坏ext4文件系统?如果是这样,我如何告诉它减少正确的数量? $ lvreduce --by-exactly-the-amount-occupied-by-PV /ev/sdb3 /dev/mapper/myvg-root
1 lvm  ext4 

1
PPTP VPN已连接但无法访问网络资源
我有一个Windows Server 2012 R2,该服务器连接到连接调制解调器的路由器。该服务器还是静态IP地址为192.168.0.201的域控制器和DNS服务器 在服务器上设置了“路由和远程访问”,同时还设置了VPN服务器。局域网和请求拨号路由已启用 VPN客户端使用静态地址池,并且该地址池与DHCP的地址池没有重叠。同样在客户端VPN设置上,我清除了“在远程网络上使用默认网关” 服务器上的IPconfig / all: Windows IP配置 主机名 。。。。。。。。。。。。:DC服务器 主Dns后缀。。。。。。。:test.local 节点类型。。。。。。。。。。。。:混合动力 IP路由已启用。。。。。。。。:是的 WINS代理已启用。。。。。。。。:否 DNS后缀搜索列表。。。。。。:test.local PPP适配器: 媒体状态。。。。。。。。。。。:媒体无法正常运行 特定于连接的DNS后缀。: 说明。。。。。。。。。。。:RAS(拨入)接口 实际地址。。。。。。。。。: DHCP已启用。。。。。。。。。。。:否 自动配置已启用。。。。:是的 自动配置IPv4地址。。:169.254.0.36(首选) 子网掩码 。。。。。。。。。。。:255.255.0.0 默认网关 。。。。。。。。。: 通过Tcpip的NetBIOS。。。。。。。。:已启用 以太网适配器NIC2: 特定于连接的DNS后缀。: 说明。。。。。。。。。。。:Broadcom NetXtreme千兆以太网#2 实际地址。。。。。。。。。:11-97-36-C6-H7-XE DHCP已启用。。。。。。。。。。。:否 自动配置已启用。。。。:是的 链接本地IPv6地址。。。。。:ee80 :: 973e:8e5f:ac05:512b%13(首选) IPv4地址。。。。。。。。。。。:192.168.0.201(首选) 子网掩码 。。。。。。。。。。。:255.255.255.0 默认网关 。。。。。。。。。:192.168.0.1 DHCPv6 IAID。。。。。。。。。。。:219191350 DHCPv6客户端DUID。。。。。。。。:00-01-00-09-5F-8E-86-94-10-98-63-Z6-B7-BD DNS服务器。。。。。。。。。。。::: …
1 vpn  pptp  rras 

1
iPad没有显示与无线网络连接的迹象
我刚刚开始为伦敦公司工作,该公司为英国境内的某些类型的会议提供iPad。这些iPad连接到我们自己的无线网络,并从本地服务器中提取数据。昨天,在其中一个事件中,我注意到了一件奇怪的事情: 即使未指示iPad已连接到我们的封闭无线网络,它们也可以正常工作。我的意思是: iPad“网络浪潮”没有出现 在网络管理器中,我们的网络旁边有一个旋转的圆圈(iPad自动连接到该网络) 网络管理员未给出DHCP服务器提供的任何详细信息 但是,当登录到访问点的Web管理控制台时,所有ipad都将获得ip地址,这可能表明iPad的性质有时会表现为这种行为。 任何想法为什么会发生这种情况?
1 dhcp  wifi  ipad 

1
如何记录响应请求的后端名称
我正在使用varnishncsa记录请求,这些请求花了很长时间才能在后端服务器上通过以下命令得到响应: varnishncsa -F '%t "%r" %s %T' | awk '$7 > 10 {print}' 我试图在后端名称上添加信息,但是此信息未显示在varnishncsa输出中: sub vcl_backend_response { std.log("backend_name:" + beresp.backend.name); } 我做错了什么?

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.