服务器管理员

系统和网络管理员的问答

1
如何为定义类型的通知或订阅设置处理程序?
如何在人偶中将处理程序添加到已定义的类型?例如,如果我有: define foo::bar ($baz) { ... } 我如何拥有处理程序foo::bar来处理包含 ... notify => Foo::Bar['zippidy'] ... ? 处理程序在收到通知时将在条件逻辑中运行各种Exec。
8 puppet 


1
为什么现代路由器不再需要时钟设置?
从我的思科书籍(CCNA级别)中,我了解到,在WAN连接中,必须将一个路由器配置为DCE,将另一个路由器配置为DTE。在现实生活中,我在两个路由器之间有一个DS-3。串行接口上​​没有CSU \ DSU(仅同轴输出)或DCE \ DTE配置。配置中没有时钟速率命令,只有dsu带宽XXX。如果重要的话,路由器使用c位帧。 一切都已配置并且可以运行,但是我只是想知道为什么没有DCE \ DTE配置。CCNA在教授老式技术吗?

3
当普通文件+隐藏+系统不等于已使用的总驱动器空间时,我的驱动器空间在吃什么
这很奇怪。所有目录大小都是正常的,所有其他文件夹的大小均应在20GB之内。差异是我无法在底部屏幕快照中找到占用150GB空间的文件。 下面,我针对许多子目录发布了属性。第二个屏幕截图是驱动器的大小。比较使用的空间,您将在单个驱动器上看到约150GB的差异。 有谁知道这可能来自哪里?我正在浏览explorer.exe中的所有隐藏文件和系统文件 更新资料 C:\Users\>vssadmin List Shadows vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool (C) Copyright 2001-2005 Microsoft Corp. Contents of shadow copy set ID: {4407d687-5021-4a57-a8bf-a94dd03428ce} Contained 1 shadow copies at creation time: 3/22/2012 7:09:43 PM Shadow Copy ID: {bf5b69c9-76cf-4218-b1ef-4c264ab3c468} Original Volume: (C:)\\?\Volume{f02f2f87-87dd-11e0-bed5-806e6f6e6963}\ Shadow Copy Volume: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy1 …

2
Windows 7 64位版本上的Outlook 2010“无法打开此项目”
我不得不承认这让我感到难过... 用户工作站 启用了缓存Exchange模式的Outlook 2010(32位) Windows 7 Pro(64位) 电子邮件帐户在Exchange 2003上 问题 用户无法在此计算机上的Outlook中打开某些电子邮件。错误消息为“ 无法打开该项目 ”。同一用户拥有一台笔记本电脑,该笔记本电脑装有Outlook 2010(32位)和Windows 7 Pro(32位)。他可以在他的笔记本电脑上打开这些电子邮件而没有任何问题。所以对我来说,这是Windows 7 Pro(64位)的错误。他还可以在BlackBerry上打开这些电子邮件。 我尝试解决此问题的方法... 从头开始重新创建他的Outlook配置文件 从头开始重新创建他的Windows用户配置文件 从头开始重新安装Office 2010 将他的Exchange邮箱移动到服务器上的其他存储组 安装了可以修复该问题的Microsoft修补程序(没有) 奇怪的是-他无法打开的大多数电子邮件都是从组织内的BlackBerry发送给他的电子邮件。巧合? 任何帮助是极大的赞赏!

1
Nginx追加URI中给定的路径
我正在尝试配置phpMyAdmin,所以我已经在Nginx中设置了流动位置,但是它将“ pma”附加到了根目录: 2012/08/14 13:59:49 [error] 10151#0: *2 "/usr/share/phpMyAdmin/pma/index.php" is not found (2: No such file or directory), client: 192.168.1.2, server: domain.com, request: "GET /pma/ HTTP/1.1", host: "192.168.1.24" 配置: location ^~ /pma { root /usr/share/phpMyAdmin; location ~ \.php$ { root /usr/share/phpMyAdmin; fastcgi_pass unix:/var/run/php-fpm/www.sock; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; fastcgi_param …
8 nginx 

2
嵌入式设备的Https,本地地址
我正在尝试将https添加到正在使用的嵌入式设备中。这些设备通常分配有本地ip地址,因此无法获得自己的SSL证书。所以本质上我的问题是,如何获得没有全局IP地址的设备的证书? 假设: 除非经过受信任的CA验证,否则浏览器将不信任证书。 但是,您只能获得全球唯一域的经过验证的证书。 那些笨拙的客户坚持使用本地IP地址。 类似的问题在这里 假设A: 获得公司主要网站的证书 复制该证书。+所有设备的私钥 用户连接到设备 设备发送证书。给用户 用户看到证书。是受信任的(忽略它不适合此服务器吗?) 用户使用cert中的公钥加密http 设备使用私钥 结果: 浏览器抱怨名称不匹配 客户可以访问彼此的私钥 不太安全 假设B: 获取公司主要网站的证书,用于每个设备 复制证书。+每个设备的私钥 用户连接到设备 设备发送证书。给用户 用户看到证书。是受信任的(忽略它不适合此服务器吗?) 用户使用cert中的公钥加密http 设备使用私钥 结果: 浏览器抱怨名称不匹配 安全 假设C: 为每个设备创建自签名证书 复制证书。+设备的私钥 用户连接到设备 设备发送证书。给用户 Firefox有一个金丝雀 用户使用cert中的公钥加密http 设备使用私钥 结果: 浏览器抱怨自签名证书 自签名证书可能是中间人攻击

3
debian 6 preseeding不断询问“将更改写入磁盘并配置LVM?”
我尝试使用专家配方为debian 6.0.5 netinstall配置lvm。我不想被问到任何问题,但它一直问我“将更改写入磁盘并配置LVM?” 这是我的preseed.cfg的一部分: d-i partman-auto/disk string /dev/sda d-i partman-auto/method string lvm d-i partman-auto/purge_lvm_from_device boolean true d-i partman-auto/choose_recipe select boot-root d-i partman-auto-lvm/new_vg_name string vg00 d-i partman-auto/expert_recipe string \ boot-root :: \ 128 50 128 ext2 \ $primary{ } $bootable{ } \ method{ format } format{ } \ use_filesystem{ } filesystem{ …
8 debian  lvm  preseed 

1
直接在端口80/443上运行Web应用程序服务器是一种不好的做法
我正在使用ec2实例在Amazon aws上托管Web应用程序。 在那种情况下,我将只运行一个应用程序。使用glassfish v3.0.1 我不想使用来运行该应用程序: www.mydomain.com:8080 or www.mydomain.com:8181 我只想使用: www.mydomain.com or https://www.mydomain.com 所以我将glassfish上的http-listener-1和http-listener-2更改为分别在端口80和443上运行。 这被认为是不良做法吗?我是一名软件工程师,我通常不处理服务器管理人员,因此在这些方面经验不足。 感谢您的指导。

1
64位Windows上的%ProgramFiles%差异
在命令提示符下,我得到以下信息: >echo %ProgramFiles% C:\Program Files 但是,某些应用程序(在本例中为PHP,尽管我从Apache的httpd.conf中看到了相同的行为),但它是: >php -r "echo $_ENV['ProgramFiles'];" C:\Program Files (x86) 为什么是这样? 背景:我正在开发与主机操作系统是32位还是64位无关的脚本,对于配置文件来说,这很好用。在32位系统上,%ProgramFiles%是“ C:\ Program Files”,而在64位系统上,%ProgramFiles%似乎返回C:\Program Files (x86)。我很好奇为什么在Windows命令提示符下(或在资源管理器栏中等)尝试使用同样的方法时,为什么它不成立。是否有64位命令提示符或其他内容?

4
如何为Apache httpd禁用SSLv2
我刚刚在https://www.ssllabs.com/上测试了我的网站,它说SSLv2是不安全的,我应该与弱密码套件一起禁用它。 如何禁用它?我尝试了以下操作,但不起作用。 /etc/httpd/conf.d/ssl.conf通过ftp 进入。添加 SSLProtocol -ALL +SSLv3 +TLSv1 SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:!LOW:!SSLv2:!EXPORT 通过腻子连接到服务器并发出service httpd restart命令。 但是它在网站上仍然显示不安全。我该如何解决?我的服务器是Plesk 10.3.1 CentOS。同一台服务器上有3-4个站点。

6
MX记录在什么情况下(如果有)应该指向localhost?
我以为这绝对没有理由或理由,但是在我张开嘴深泡菜之前,我想我应该问一下。 是否有任何其中一个MX记录应指向回送地址的情况?对我来说,这意味着任何尝试发送到该域的邮件服务器都将发送给自己,并且失败,但是我不是邮件专家,所以也许我丢失了一些东西。 在对为什么不收到电子邮件进行故障排除时,我遇到了以下问题?客户的问题,我在解决问题时遇到了麻烦。不过,也许我想得太多。
8 smtp  mx-record 

1
从SCSI硬盘恢复数据
我们有一台带有SCSI硬盘的旧服务器。服务器上周崩溃了,目前尚不清楚什么硬件组件被损坏。由于无论如何该服务器都将被淘汰,因此我们不想对其进行修复,而只是从SCSI驱动器中还原数据。 我们希望硬盘本身没有损坏,但是问题是我们没有其他装有SCSI控制器的计算机。 我有哪些恢复数据的选择? 除了承诺提供专业的数据恢复服务外,我还想买便宜的SCSI控制器卡(例如,我能以10欧元的价格找到IBM Adaptec PCI W-Ultra SCSI控制器,肯定比恢复服务费还便宜),将其插入某些台式PC的PCI插槽中,连接SCSI硬盘,然后将必要的数据从磁盘复制到PC上。考虑到SCSI硬盘已经相当旧(从1999年开始使用的是18 GB IBM磁盘),如果PC端的操作系统很重要(它是Win XP,服务器具有Win NT)或PC端的其他规格(PCI插槽?)等。 预先感谢您的帮助!

4
HTTPS比HTTP慢50倍以上
我有一个使用https将JavaScript文件传输到客户端的网站。该网站为getsimpleapps.com。 事实证明,使用https(20.08s-29.08s)加载此文件的速度比使用http(380ms)慢52倍。 该网站的首页与javacript文件共享相同的慢度。 http://getsimpleapps.com https://getsimpleapps.com 我最近从Dreamhost切换到了linode,并且骇入了让SSL在新服务器上运行直到实现的目的。我没有进行任何疯狂的配置。 linode运行Ubuntu 12.04,并且该站点位于(LAMP)堆栈的顶部。 我对堆栈溢出社区的问题是:如何在服务器上修复SSL和HTTPS?我知道栈溢出到处都是关于HTTPS速度慢的问题,但是没有给出真正的解决方案。ubuntu教程或配置指南将是理想的选择。 文件:/etc/apache2/sites-enabled/getsimpleapps.com <VirtualHost *:80> ServerAdmin admin@getsimpleapps.com ServerName getsimpleapps.com ServerAlias www.getsimpleapps.com DocumentRoot /srv/sites/getsimpleapps.com/public/ ErrorLog /srv/sites/getsimpleapps.com/logs/error.log CustomLog /srv/sites/getsimpleapps.com/logs/access.log combined </VirtualHost> <VirtualHost 50.116.58.18:443> SSLEngine On #SSLCertificateFile /etc/apache2/ssl/www.getsimpleapps.com.crt #SSLCertificateKeyFile /etc/apache2/ssl/www.getsimpleapps.com.key #SSLCACertificateFile /etc/apache2/ssl/comodo.crt SSLCertificateFile /etc/apache2/ssl/dreamhost/dh.crt SSLCertificateKeyFile /etc/apache2/ssl/dreamhost/dh.key SSLCACertificateFile /etc/apache2/ssl/dreamhost/dh.cer ServerAdmin admin@getsimpleapps.com ServerName getsimpleapps.com ServerAlias www.getsimpleapps.com DocumentRoot /srv/sites/getsimpleapps.com/public/ …

2
成功连接到VPN后,SSTP客户端会立即断开连接
我已经从Windows 7计算机成功验证并连接到SSTP VPN(在Windows 2008上),但是由于某种原因,建立连接后大约1-2秒断开了连接。 我已经完成以下工作: 在Windows Server 2008上定义了SSTP VPN。 与CA定义了同一台计算机。 颁发所需的证书并将其发布在客户端上。 我目前正在局域网中测试此VPN,因此所有需要的端口都已打开。 以下是尝试连接时的事件日志条目: 错误日志(客户端): 用户HOME \ User拨打了名为Home VPN的连接,该连接已终止。终止时返回的原因码为829。 错误日志(服务器VPN): 用户HOME \ User在2012年7月27日凌晨1:57通过端口VPN0-0连接,并在2012年7月27日凌晨1:57断开连接。用户处于活动状态0分钟0秒。发送了312个字节,接收了4528个字节。断开连接的原因是用户请求。 会是什么问题?如何解决或调试它? 更新:我在试图连接到VPN的Windows 7计算机上发现了事件日志(Log = System,Source = RasSstp)消息: 由于安全检查失败,终止了与远程访问服务器的基于SSTP的VPN连接。远程访问服务器上的安全设置与此计算机上的设置不匹配。请与远程访问服务器的系统管理员联系,并中继以下信息: SHA1证书哈希:065D681 ... 520375552F SHA256证书哈希:18DED363 ... EEEE28CFD00

By using our site, you acknowledge that you have read and understand our Cookie Policy and Privacy Policy.
Licensed under cc by-sa 3.0 with attribution required.